3 Replies Latest reply on Oct 13, 2015 3:11 PM by pegchan

    Scripted Install fails if it's not the last action

    Apprentice

      Hi,

      I'm running LANDesk 9.5 SP3.  I have a provisioning template with a scripted install of Windows 7 x64.  When the scripted install action is the very last action, the install starts and ends successfully.  If I edit the same template and add anything after the scripted install (HII or even just a simple wait command), the scripted install fails with the error "The call to the Web service failed."  I'm running these on the exact same computer on the same network and now I'm stumped. Can anyone help?  Thank you.

       

      The ldprovision log of the scripted install when it fails:

      2015-10-03 04:10:18(2328-2332) ldprovision.exe:*********  Begin an action - Scripted_install

      2015-10-03 04:10:18(2328-2332) ldprovision.exe:Do EnvironmentCheck

      2015-10-03 04:10:18(2328-2332) ldprovision.exe:Is WinPE Action=1, Is WinPe Environment=1

      2015-10-03 04:10:18(2328-2332) ldprovision.exe:Report might reboot status to core.

      2015-10-03 04:10:18(2328-2332) ldprovision.exe:Call web service SetActionStatus()

      2015-10-03 04:10:18(2328-2332) ldprovision.exe:Start TryallWebService Attempt:0.

      2015-10-03 04:10:18(2328-2332) ldprovision.exe:End TryallWebService Attempt:0. ExitCode:0

      2015-10-03 04:10:18(2328-2332) ldprovision.exe:Download handler ok.

      2015-10-03 04:10:18(2328-2332) ldprovision.exe:Launching action handler [ClientActionHandler.exe] with parameters ["]

      2015-10-03 04:10:18(2328-2332) ldprovision.exe:handler launched.

      2015-10-03 04:16:33(2328-2332) ldprovision.exe:Reporting action status: 5 to core

      2015-10-03 04:16:33(2328-2332) ldprovision.exe:Call web service GetStatusString()

      2015-10-03 04:16:33(2328-2332) ldprovision.exe:Start TryallWebService Attempt:0.

      2015-10-03 04:16:33(2328-2332) ldprovision.exe:End TryallWebService Attempt:0. ExitCode:0

      2015-10-03 04:16:33(2328-2332) ldprovision.exe:StatusString = The call to the Web service failed.

      2015-10-03 04:16:33(2328-2332) ldprovision.exe:Call web service SetActionStatus()

      2015-10-03 04:16:33(2328-2332) ldprovision.exe:Start TryallWebService Attempt:0.

      2015-10-03 04:16:34(2328-2332) ldprovision.exe:End TryallWebService Attempt:0. ExitCode:0

      2015-10-03 04:16:34(2328-2332) ldprovision.exe:End of action - Scripted_install

      2015-10-03 04:16:34(2328-2332) ldprovision.exe:Last action failed

      2015-10-03 04:16:34(2328-2332) ldprovision.exe:**********************************  End processing actions  **********************************

      2015-10-03 04:16:34(2328-2332) ldprovision.exe:ldProvision ended

       

      Here's the ClientActionHandler.log when it fails:

      2015-10-03 04:10:19(3116-3120) ClientActionHandler.exe:m_ForceReboot=1

      2015-10-03 04:10:19(3116-3120) ClientActionHandler.exe:There is no winnt32.exe file.  We've found setup.exe.  This is not a Windows XP install.

      2015-10-03 04:10:19(3116-3120) ClientActionHandler.exe:This is in WinPE2x environment

      2015-10-03 04:10:19(3116-3120) ClientActionHandler.exe:CreateHeaderFile - x:\ldprovision\setupinstall.header.txt

      2015-10-03 04:10:19(3116-3120) ClientActionHandler.exe:CreateBodyFile - x:\ldprovision\setupinstall.body.txt

      2015-10-03 04:10:19(3116-3120) ClientActionHandler.exe:Args = -V -H"x:\ldprovision\setupinstall.header.txt" -o"x:\ldprovision\setupinstall.body.txt" -f"x:\ldprovision\setupinstall.result.xml" http://Ourservername/landesk/managementsuite/core/ProvisioningWebService/WebService.asmx

      2015-10-03 04:10:19(3116-3120) ClientActionHandler.exe:start Try httpclient No=0.

      2015-10-03 04:10:19(3116-3120) ClientActionHandler.exe:end Try httpclient No=0.exitCode=1

      2015-10-03 04:10:50(3116-3120) ClientActionHandler.exe:start Try httpclient No=1.

      2015-10-03 04:10:50(3116-3120) ClientActionHandler.exe:end Try httpclient No=1.exitCode=1

      2015-10-03 04:11:22(3116-3120) ClientActionHandler.exe:start Try httpclient No=2.

      2015-10-03 04:11:22(3116-3120) ClientActionHandler.exe:end Try httpclient No=2.exitCode=1

      2015-10-03 04:11:58(3116-3120) ClientActionHandler.exe:start Try httpclient No=3.

      2015-10-03 04:11:58(3116-3120) ClientActionHandler.exe:end Try httpclient No=3.exitCode=1

      2015-10-03 04:12:52(3116-3120) ClientActionHandler.exe:start Try httpclient No=4.

      2015-10-03 04:12:52(3116-3120) ClientActionHandler.exe:end Try httpclient No=4.exitCode=1

      2015-10-03 04:13:22(3116-3120) ClientActionHandler.exe:start Try httpclient No=5.

      2015-10-03 04:13:22(3116-3120) ClientActionHandler.exe:end Try httpclient No=5.exitCode=1

      2015-10-03 04:13:50(3116-3120) ClientActionHandler.exe:start Try httpclient No=6.

      2015-10-03 04:13:50(3116-3120) ClientActionHandler.exe:end Try httpclient No=6.exitCode=1

      2015-10-03 04:14:10(3116-3120) ClientActionHandler.exe:start Try httpclient No=7.

      2015-10-03 04:14:10(3116-3120) ClientActionHandler.exe:end Try httpclient No=7.exitCode=1

      2015-10-03 04:14:45(3116-3120) ClientActionHandler.exe:start Try httpclient No=8.

      2015-10-03 04:14:45(3116-3120) ClientActionHandler.exe:end Try httpclient No=8.exitCode=1

      2015-10-03 04:15:34(3116-3120) ClientActionHandler.exe:start Try httpclient No=9.

      2015-10-03 04:15:34(3116-3120) ClientActionHandler.exe:end Try httpclient No=9.exitCode=1

      2015-10-03 04:16:33(3116-3120) ClientActionHandler.exe:Exit Code of InstallCallHTTPClient = 1

      2015-10-03 04:16:33(3116-3120) ClientActionHandler.exe:Failed to execute http handler

       

      ..And when scripted install is successful.   There's no change other than the exit code.

      2015-10-04 05:33:32(2052-1328) ClientActionHandler.exe:m_ForceReboot=1

      2015-10-04 05:33:32(2052-1328) ClientActionHandler.exe:There is no winnt32.exe file.  We've found setup.exe.  This is not a Windows XP install.

      2015-10-04 05:33:32(2052-1328) ClientActionHandler.exe:This is in WinPE2x environment

      2015-10-04 05:33:32(2052-1328) ClientActionHandler.exe:CreateHeaderFile - x:\ldprovision\setupinstall.header.txt

      2015-10-04 05:33:32(2052-1328) ClientActionHandler.exe:CreateBodyFile - x:\ldprovision\setupinstall.body.txt

      2015-10-04 05:33:32(2052-1328) ClientActionHandler.exe:Args = -V -H"x:\ldprovision\setupinstall.header.txt" -o"x:\ldprovision\setupinstall.body.txt" -f"x:\ldprovision\setupinstall.result.xml" http://Ourservername/landesk/managementsuite/core/ProvisioningWebService/WebService.asmx

      2015-10-04 05:33:32(2052-1328) ClientActionHandler.exe:start Try httpclient No=0.

      2015-10-04 05:33:32(2052-1328) ClientActionHandler.exe:end Try httpclient No=0.exitCode=0

      2015-10-04 05:33:32(2052-1328) ClientActionHandler.exe:Exit Code of InstallCallHTTPClient = 0

      2015-10-04 05:33:32(2052-1328) ClientActionHandler.exe:Create process (x:\cba8\httpclient.exe) with args (  -f "x:\ldprovision\026701_33.cfg" http://Ourservername/ldlogon/Provisioning/config/026701_33.cfg)

      2015-10-04 05:33:32(2052-1328) ClientActionHandler.exe:Process exit code:0

      2015-10-04 05:33:32(2052-1328) ClientActionHandler.exe:run command: "\\Ourservername\LDShares\Images\Production\OSInstall\W7_ENT_x86_SP1_Source\setup.exe" /unattend:x:\ldprovision\026701_33.cfg /noreboot .

       

      Scripted Install fails if it's not the last action.  Here is the template.

       

      Scripted Install works successfully if it is the last action.