6 Replies Latest reply on Jul 30, 2008 8:57 AM by phoffmann

    Inventory Scan only works once.

    Rookie

      We have a working LDMS and Management Gateway (MG) 3 device.

       

      Brokerconfig correctly obtains a certificate. The client device is

      connecting to the MG via the eth1 using a cross-over cable. The

      client device's hosts file has been modified to replicate a FQDN

      resolution to the MG. (192.168.0.1 gatewayname.dom)

       

      After broker correctly obtains and tests the certificate, we

      run an inventory scan that completes successfully. You can wait

      several minutes or reboot at this point but if you run another

      inventory scan it fails: LDISCN32: The inventory server LANDESK did

      not respond.

       

      Netstat 1 during the first inventory scan shows an active SSL connection to  our MG.

      Netstat 1 during the second inventory scan shows no connections attempting to be made to our MG.

       

      Note: After the first inventory scan, the device is correctly

      propagating on the LDMS managed device list. (so we know the first

      certificate / inventory scan worked like a charm)

       

      Attached is a much more detailed text file describing our issue.

       

      Thanx in advance!

        • 1. Re: Inventory Scan only works once.
          Rookie

          Update -

           

          Attempting to perform the above on a non-imaged / pre installed version of Landesk Agent.

          Maybe its our LANDesk Agent installed with our deployed windows image...

           

          Installing using a recovery Windows XP Sp2 cd...

           

          Will keep you all posted

           

          Thanks!

          • 2. Re: Inventory Scan only works once.
            Employee

            Mangement Gateway will reject machines that  hae matching GUID's.  Make sure you delete the GUID if you are going to create an image with the agent installed.

            1 of 1 people found this helpful
            • 3. Re: Inventory Scan only works once.
              Rookie

              Good one! Will do. So far the imaging process we use will create a unique GUID. But the method I was using for testing was not. I'll keep that in mind for future tests Thanks!

               

              Update - Looks like it is our security settings on our standard XP image. The bare bones XP Sp2 install worked like a champ.

               

              We have another test to try evolving WMI security settings. I'll keep you all posted on that process. I have not heard anyone else having this issue, but if we solve it, I'll be sure to post our solution.

               

              Thanks again!

              • 4. Re: Inventory Scan only works once.
                Rookie

                Update - No good. WMI settings were not our issue.

                • 5. Re: Inventory Scan only works once.
                  Rookie

                  Looks like something to do with a security setting 'somewhere' amongst our image. Up hill battle from here. Thanks for everyones help!

                  • 6. Re: Inventory Scan only works once.
                    phoffmann SupportEmployee

                    I'm pretty sure I've seen a "new SID generator" a few years ago somewhere - I can't find it at the moment, but that may help you.

                     

                    What kind of image are you using - not sysprep (I imagine) - since sysprep should (I say "should" but I've seen otherwise) generate new SID's for clients ... but if you can find the generator, that may save you a fair bit of work in terms of fixing this :).

                     

                    Paul Hoffmann

                    LANDesk EMEA Technical Lead.