5 Replies Latest reply on Jul 31, 2008 10:35 AM by MarXtar

    Strange query result...

    Rookie

       

      hi all,

       

       

      I have an odd query issue going on that I don't understand.

       

       

      I need to distribute a piece of software to all PCs on the network (Pidgin chat client).  So - I've set up the scheduled task with the software package in there, and it distributes fine.  But when it ran yesterday, obviously some of the machines were not switched on, or were not contactable for whatever reason, so quite a few machines are now missing the app.

       

       

      The best way forward I figured, is to create a query of all PCs that don't have the software installed, and associate this query with the software distribution task, and schedule this to run every day.  That way, any machines in the query will be in the group, and the app will install when the task runs.  I'm hoping this is 'best method' way of doing this.

       

       

      The problem is, though, there are a handful of machines in the 'Not installed' query that do actually have the software installed.  It shows in their inventory, and the machines even show up in a Software License Monitoring query for the app.  The inventory query is "Computer" "Type" Like "XP Workstation" AND "Computer" "Software" "Package" "Name" NOT LIKE "Pidgin", and as I say, there are some machines in there that do actually have the app in their inventory under software, and that also show up in SLM.

       

       

      So, it's weird.

       

       

      Any ideas what might be up??

       

       

      many thanks,

       

       

      Charlie.