7 Replies Latest reply on Aug 13, 2009 8:31 AM by cgatling

    Inventory Scan Error: The System Connot find the path Specified

    Rookie

       

      I am having some issue with the Inventory Scan function of a few devices (All servers).

       

       

      Since the Agent has been deployed I have been unable get a full scan to complete, whether initiated from the Client or the Core.

       

       

      When initiated from the client scan seems to bomb out part way through scanning the Hardware.  When intiated from the Core the scan fails with the error 'The Sytem cannot find the path Specified'.

       

       

      I have tried to force a full scan & sync (Using the /F /SYNC switches) but the same issue.

       

       

      Having searched all through the logs on both the server and client I am unable to determine exactly what it is failing on.  Please can someone point me towards the correct logs that would help me diagnose this better as it is starting to drive me crazy.

       

       

      Thanks,

       

       

       

       

       

      OD

       

       

        • 1. Re: Inventory Scan Error: The System Connot find the path Specified
          phoffmann SupportEmployee

          Several things.

           

          1 - I would encourage using the search function. Even searching for the string "The Sytem cannot find the path" results in a lot of hits - to various discussions and documents.

           

          So - do that. Use the search before posting, and/or state what steps you've already tried. And what version/service pack you're on. Please.

           

          Documents like:

          http://community.landesk.com/support/docs/DOC-1532

           

          Can be found easy ... you just need to search for the error string. We try and keep it simple.

           

          2 - I'd advise to change your user-name. Having e-mail addresses in any shape or form on a public form is a great way for bots to farm them and results in yet more spam :).

           

          Paul Hoffmann

          LANDesk EMEA Technical Lead.

          • 2. Re: Inventory Scan Error: The System Connot find the path Specified
            Rookie

             

            Fair point about the username - realised just after I'd posted so changed my name.  Unfortunately this discussion keeps the name it was logged under.

             

             

            I'm running LDMS 8.7 SP3 (8.70.0.109)

             

             

            The first thing i tried was to try and run the scan from the client using the /F /SYNC switches but this did not work.  I then tried by pushing this same command out to the client.

             

             

            After that I tried re-installing the client (Using both push and local install), then uninstalling & re-installing (again using Push & manual) but again no results.

             

             

            The last thing I've tried is outputting the scan to a file directly on the client as suggested inhttp://community.landesk.com/support/message/8221#8221.  Here it suggests copying the output into the ldscan directory however my output is empty.  I have used the same comman on a working client and it gives me the output i expect.  This last one leads me to think that it is a client based issue but I am at a loss as to what as a complete re-installation does not seem to work.

             

             

            The only info from logs I can provide is from the scheduled task logs:

             

            "Machine","CbaStatus","ExitCode","Duration","Begin","End","Command"

            "Server1","OK",-2147483645,0:00:01,07/08/2008 14:06:55,07/08/2008 14:06:56,"<qt/>c:\ldclient\LDISCN32.EXE<qt/> /NTT=SERVER:5007 /S=SERVER" /I=HTTP://SERVER/ldlogon/ldappl3.ldz /NOUI /W=20 /F /SYNC"

            "Server2","OK",-2147483645,0:00:03,07/08/2008 14:06:55,07/08/2008 14:06:58,"<qt/>c:\ldclient\LDISCN32.EXE<qt/> /NTT=SERVER:5007 /S="SERVER" /I=HTTP://SERVER/ldlogon/ldappl3.ldz /NOUI /W=20 /F /SYNC"

            ; "Job Complete","0 Done","2 Failed","0 Off","0 Unknown"

            In pasting this I've now just seen what the issue is so I've highlighted it above but I'm not sure how to change this or why on a few servers it is as above & on the rest it appears like this:

             

             

            "Server3","OK",0,0:01:42,07/08/2008 19:48:08,07/08/2008 19:49:50,"<qt/>C:\Program Files\LANDesk\LDClient\LDISCN32.EXE<qt/> /NTT=SERVER:5007 /S="SERVER" /I=HTTP://SERVER/ldlogon/ldappl3.ldz /NOUI /W=20 /F /SYNC"

            ; "Job Complete","1 Done","1 Failed","0 Off","0 Unknown"

             

             

            The script behind it uses the  %LDMS_CLIENT_DIR% variable so I'm not sure how this differs.  Can you suggest why this may be different?  I've looked at the client sidenvironment variables of both a working server and one that fails and all I can see is LDMS_LOCAL_DIR which is the same on both.

             

             

            Thanks,

             

             

             

             

             

            OD

             

             

             

             

             

            • 3. Re: Inventory Scan Error: The System Connot find the path Specified
              phoffmann SupportEmployee

              Good progress :).

               

              So - the devices which resolve the LANDesk path to "C:\ldclient\" are the ones with missing inventory. When CUSTJOB doesn't have a value in inventory to read, it assumes that the client "must be an old one" (8.1 and earlier) which didn't send this data in, and they resided in "C:\LDCLIENT\" usuall.

               

              There's a few things you can do.

               

              1 - You can create a script which uses a hard-coded path rather than a varibale. Something like

               

              [MACHINES]
              
              ; Because the client directory is not the same for all version of the LDMS
              ; client we use the ldrunner application to remotely determine the correct client
              ; directory.  This application is copied to the root of the C drive, but this
              ; location may be changed without impacting the functionality of this script.
              ;
              REMCOPY1=%DTMDIR%\landesk\files\ldrunner.exe, c:\ldrunner.exe
              
              ; Run the inventory scanner on this client, we assume that ldappl.ini will be
              ; in same dir as the ldiscn32.exe
              ;
              REMEXEC2=c:\ldrunner.exe <qt/>C:\Program Files\LANDesk\LDClient\LDISCN32.EXE<qt/> /L /SYNC /NOUI /NOCD
              
              ; Remove the ldrunner application
              ;
              REMDEL3=c:\ldrunner.exe
              

               

              I'm a bit curious how exactly you're getting an empty output-file. Just to make sure, if you're running this on the client, your command-line should look something like this:

              "C:\Program Files\LANDesk\LDClient\LDISCN32.EXE" /NTT=YourCore:5007 /S=YourCore  /I=HTTP://YourCore/ldlogon/ldappl3.ldz /V /F /SYNC /O=c:\output.scn
              

               

              Which will give you a file called "output.scn" in the root of C:\.

               

              You can then copy this file manually to your Core's LDSCAN directory. There's no way this file should be empty. If your client cannot get an LDAPPL3 file you should see an error saying so ("/V" is for "verbose" - which helps here).

               

              Paul Hoffmann

              LANDesk EMEA Technical Lead

              1 of 1 people found this helpful
              • 4. Re: Inventory Scan Error: The System Connot find the path Specified
                phoffmann SupportEmployee

                NOTE - in case people wonder where the script's from - I've plagiarised it from the "restore client records" script and just hard-coded the path.

                 

                Paul Hoffmann

                LANDesk EMEA Technical Lead.

                • 5. Re: Inventory Scan Error: The System Connot find the path Specified
                  Rookie

                   

                  Thanks for the response...

                   

                   

                  Firstly I tried to hard code the path into the script but unfortunately this did not work.  The task completed successfully but no inventory data was received by the Core.  However in some ways I do not expect it to ever work as when I tried to again output the results to a file the output was empty.  I have checked that the client is successfully downloading the ldappl3 and it appears that it is so that is not the issue.

                   

                   

                  When I run the command on the client the UI opens and for a brief second it starts scanning the hardware then the UI closes.

                   

                   

                  Thanks,

                   

                   

                   

                   

                   

                  OD

                   

                   

                   

                   

                   

                  • 6. Re: Inventory Scan Error: The System Connot find the path Specified
                    Employee

                    Olie,

                     

                    Can you try a couple of things for me?

                     

                    Please try running the following from a client machine:

                     

                    LDISCN32.EXE /L /F- /O=C:\outputfile.scn --> this is a hardware only output scan. Please check to see if it has anything in it.

                     

                    If it doesn't, try this:

                     

                    LDISCN32.EXE /L /F- /DO16 /O=C:\outputfile.scn -> this is a hardware only output scan running in 16 bit mode

                     

                    If neither of those work:

                     

                    LDISCN32.EXE /L /F /SYNC /O=C:\outputfile.scn /DEBUG -> this is a full sync scan that should generate an ldiscn32.log in your ldclient folder on the client machine where you are running the task. This should give us a little more data to work with. (hopefully)

                     

                    The /L tells your scanner to use the settings in your registry for the core server entries. If you find that of the two hardware scans, the /DO16 switch works, then you need to upgrade to the most recent service pack. This should really be done anyway, but that should be the tipping point,

                     

                    Also, have you seen anything in the application event logs or errorscan folders on the core server? Even if the output file is empty, I'm curious to know if client is even attempting to send data to the core server.

                    • 7. Re: Inventory Scan Error: The System Connot find the path Specified
                      Rookie

                      I've noticed that if one service is not running(started) on the core server, it will cause the inventory scan to produce that error message of "the system cannot find the path specified".

                       

                      Make sure the following service is running on the Core server:

                      LANDesk Inventory Server (LDinv32.exe is the executable)