7 Replies Latest reply on Nov 17, 2015 6:42 AM by ASelby

    Disappearing Data

    ASelby Rookie

      I've got a case of Disappearing Data.  We're running LDMS 9.6 SP2 and Data Analytics 9.62.0670.  New PCs arrive and are entered using the standard Enter New Device web form, creating a Stub record.  I then enter Asset Tag and Purchase Order information using DA web forms.  The Asset Tag and PO info remains with the record until partway through the Imaging process when the PC gets a new device name.  At that point the data seems to be deleted.  I've looked into the Device ID Attributes in the Inventory Services Manage Duplicates section and removed Computer.Device Name as one of the triggering attributes.  (Our Device Names change at least twice during imaging and any time the PC gets deployed to a new location.)  Since our PCs get reimaged fairly regularly, how can I assure that the PO info remains with the record throughout the lifecycle?

        • 1. Re: Disappearing Data
          MarXtar ITSMMVPGroup

          Use the 'Model Attributes' button in the top left of the Data Translation Services window. Are the inventory attributes you want showing in there? If so then they haven't been modelled and are likely to get deleted.

           

          Choose to model it and agree that you want it kept permanently. Without this set, any full synchronisation scan can cause the data to be deleted.

           

          Mark McGinn

          MarXtar Ltd/MarXtar Corporation

          http://landeskone.marxtar.co.uk

          LANDESK One Development Partner

           

          The One-Stop Shop for LANDESK Enhancements

          • 2. Re: Disappearing Data
            Frank Wils ITSMMVPGroup

            Your data will get overwritten by the full scan of the Agent coming in.

             

            The issue and solution is described for Warranty Information in this document:

            https://community.landesk.com/support/docs/DOC-30287

             

            You will have to look up the table where your data is stored... I can look it up later for you, but don't have access to a Core at this time...

             

            Frank

            • 3. Re: Disappearing Data
              MarXtar ITSMMVPGroup

              Frank is right although the doc is from before they added the 'permanent' option into the Data Analytics model attributes feature. If these are existing modelled attributes that have not been set as permanent, then the doc Frank references will work for you.

               

              Mark McGinn

              MarXtar Ltd/MarXtar Corporation

              http://landeskone.marxtar.co.uk

              LANDESK One Development Partner

               

              The One-Stop Shop for LANDESK Enhancements

              • 4. Re: Disappearing Data
                ASelby Rookie

                Thank you for the details!  I made the changes in Model Attributes and (at least for the first couple of test units) the data is hanging in there through the process.

                • 5. Re: Disappearing Data
                  ASelby Rookie

                  And now as I reimage a device for the second time, the Asset Tag and PO info are deleted.  On to the next attempts....

                  • 6. Re: Disappearing Data
                    VHARNUM Apprentice

                    I am having the same issue and it has been escalated to engineering.  TFS 263515.  A regular inventory scan seems to keep the information but then when I run a full sync scan the data gets deleted from the custom form.

                    • 7. Re: Disappearing Data
                      ASelby Rookie

                      Is it possible to view Modelled Attributes and their Relationship Type (01 or 99 or...) from within the Console?  I'm wanting to see just what it reads before I try to make any changes that might be redundant.  All I'm seeing (from my inexperienced perspective) is the option to add Model Attributes as referenced by MarXtar above, not read existing state.