3 Replies Latest reply on Dec 4, 2015 9:12 AM by leemir

    Landesk Provisioning Template Won't Load

    Rookie

      Trying to load a template and it hits 40 out of 40 tries and fails. Only one of my templates is failing. I haven't made any changes (that i know of) and it just started failing a day ago. I have read through other threads and found this post by [email protected]:

       

      If you check the provisioning.log under \\core\ldmain\log\provisioning you will see details on why it failed

       

      Corrupt Template
      • A corrupt template can prevent correct scheduling. One cause if this is if a template is imported, the drop down boxes are not filled in as they were pointing to objects from the previous core. For example, Software Distribution actions do not have a package specified. Same with Configure Agent actions. Also any actions with scripts will have this issue.
      • Another way to determine if your template is not configured properly is by reviewing the Provisioning.log on the core. If you see the following:

      INFO    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : Action LANDesk.Provisioning.Business.PAction_Distribute_software
      INFO    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : Got package ID 60, requesting snippet
      INFO    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : Requesting snippet for packageId 60
      INFO    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : Requesting SWD snippet with task IDN 2214, package ID 60
      ERROR    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : Exception encountered trying to get snippet (LANDesk.ManagementSuite.SoftwareDistribution.Business.PackageNotFoundException): This package has been deleted.
      ERROR    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : GetSoftwareSnippet failed

      I have looked into my logs and found a similar error:


      INFO PROV_SCHEDULE 12/3/2015 6:34:20 PM : Action LANDesk.Provisioning.Business.PAction_Distribute_software

      INFO PROV_SCHEDULE 12/3/2015 6:34:20 PM : Got package ID 765, requesting snippet

      INFO PROV_SCHEDULE 12/3/2015 6:34:20 PM : Requesting snippet for packageId 765

      INFO PROV_SCHEDULE 12/3/2015 6:34:20 PM : Requesting SWD snippet with task IDN 24523, package ID 765

      ERROR PROV_SCHEDULE 12/3/2015 6:34:20 PM : Exception encountered trying to get snippet (LANDesk.ManagementSuite.SoftwareDistribution.Business.LandeskClientExeException): String not found (Error.LandeskClientExe)

      ERROR PROV_SCHEDULE 12/3/2015 6:34:20 PM : GetSoftwareSnippet failed

       

      I am not sure if this is even relevant or some other provisioning task going on. I also am seeing alot of this error in my logs which is less helpful:

       

      ERROR TemplateFinder 12/3/2015 6:33:57 PM: couldn't find task for computer 30338

      ERROR ProvisioningService 12/3/2015 6:33:57 PM: Unable to find template for computer IDN 30338

       

      My question is how do I determine what exactly is failing on this template? How do I find the software package that is corrupt? Or am I dealing with something completely different?


      I also don't quite understand the post I found above and other posts on this topic. I am not sure what they mean by: "One cause if this is if a template is imported, the drop down boxes are not filled in as they were pointing to objects from the previous core. For example, Software Distribution actions do not have a package specified. Same with Configure Agent actions. Also any actions with scripts will have this issue." Where would I look for these drop down boxes?

       

      Thanks! I am a Landesk noob and I have no clue what I am doing