10 Replies Latest reply on Dec 10, 2015 12:29 PM by mbrevick

    Unable to capture Image LD9.6sp2

    Apprentice

      I can find a million topics on this issue but no solutions are working for me. I haven't had to do a capture in ~6 months...

       

      Provisioning fails on the Capture step when mapping the drive.

       

      maptopreferredhandler.exe: Mapping to: \\bhfs.burchamhills.local\landesk\images

      maptopreferredhandler.exe: Drive letter = e

      maptopreferredhandler.exe: Mode - Require Direct, no preferred server. - this here seems to be my problem

      maptopreferredhandler.exe: Could not get credentials for preferred server

      maptopreferredhandler.exe: End of map drive

      etc.

       

      This is a new, clean capture template. I've tried changing the UNC to use FQDN, the basic name, the IP address.. I've tried using two different preferred servers, the one shown and also the Core. I've tried changing the preferred server names to FQDN and basic names as well to match whatever I have in the capture template but it doesn't seem to matter. While in WinPE I can "net use" and map the share just fine using the same credentials.

      Capture.PNG

       

      I have no idea why it can't find my preferred servers because they're listed here. I've even set all credentials to a domain admin account and double checked permissions on the share and Sources paths and everything.

       

      I also tried redeploying my PXE server just in case. Still same error.. Is there any way around the capture template trying to auto-map the drive?? I know I had similar issues when trying to deploy images and I had to add an Action to manually map the drives....

       

      2.PNG

        • 1. Re: Unable to capture Image LD9.6sp2
          nick.evans SupportEmployee

          Hi Michael,

          Looking at the error listed ' Mode - Require Direct, no preferred server' it indicates that the preferred server that it wants to use in the template (bhfs.burchamhills.local) wasn't present in the preferredservers.dat file in WinPE (X:\ProgramData\Landesk\ManagementSuite\Sdmcache\preferredservers.dat). The preferredservers.dat is populated on demand when certain actions in provisioning are called (capture image/deploy image etc).

          Assuming your Preferred server is added the same in the template as it is in the preferred server list (your screenshot appears as though it is), the next thing you will want to check is if your preferredservers.dat file is populating with the indicated preferredservers.dat file (again, it won't be created until after specific methods are called, so you may have to let it go through and fail for it to be created).

           

          Something else to look into - what component patch level are you on? Maptopreferredhandler has modifications made regularly, so knowing what patch level you are on can provide insight into if you are running into any particular issues.

          Does your defined account utilize a password with special characters? If yes, try an account without special characters. We have seen certain instances where passwords with & or % in them have issues (these issues are re-mediated with later component patches so the previous question can help identify any potentially known issues in that regard).

          • 2. Re: Unable to capture Image LD9.6sp2
            Apprentice

            I don’t even see an X:\ProgramData folder on the WinPE. Maybe that’s my problem. Duh it's hidden, I found it right now it lists "1449528324?bhld.burchamhills.local;bhfs.burchamhills.local" I don't know what the numbers are? But it does list my servers as they are in the template..


            I’m on 9.60.0.244 SP2

            • 3. Re: Unable to capture Image LD9.6sp2
              nick.evans SupportEmployee

              Hi Michael,

              Can you post a screenshot from your core under Help | About | More Info, with the columns expanded so the patch names are visible. I know of a couple possible issues depending on which patch you're on so we want to rule those out.

               

              Also, does the account you are using utilize a password with special characters? If yes, did you have an opportunity to try an account as a test without special characters?

              • 4. Re: Unable to capture Image LD9.6sp2
                Apprentice

                I tried with a different account and it didn't help

                 

                adf.PNG

                • 5. Re: Unable to capture Image LD9.6sp2
                  JoeDrwiega SupportEmployee

                  What is the version of your LDMS Core?

                  • 6. Re: Unable to capture Image LD9.6sp2
                    Apprentice

                    My last comment has a screenshot...

                    • 7. Re: Unable to capture Image LD9.6sp2
                      JoeDrwiega SupportEmployee

                      In WINPE does it have to correct LANDesk certificate for LANDesk? I had the mapping issue where I had to open my WIM and update my certificate for it to map using those credentials to validate.

                      • 8. Re: Unable to capture Image LD9.6sp2
                        Apprentice

                        How would I find out?

                         

                        I have a support ticket open right now and Jay was trying to get me to patch my Core server but it just errors out. Still waiting on response to that...

                        • 9. Re: Unable to capture Image LD9.6sp2
                          JoeDrwiega SupportEmployee

                          I don't have my lab in front of me but I believe these are the directions I used:

                          Use DISM:

                          1 - Copy boot.wim to C:\TEMP on your local workstation

                          2 - Make a temporary directory to mount the boot.wim image. (I use C:\TEMP\winpe)

                          3 - Open a command prompt and browse to the C:\TEMP

                          4 - Run the command dism.exe /mount-wim /wimfile:boot.wim /index:1 /mountdir:c:\TEMP\winpe

                          5 - Go to C:\TEMP\WINPE and find the cbaroot\certs folder and copy the cert from the CORE C:\Program Files (x86)\LANDesk\Shared Files\cbaroot\certs to the WINPE

                          6 - At the command prompt run the command dism.exe /unmount-wim /mountdir:c:\TEMP\winpe /commit

                          7 - rename the old wim to boot.wim.old on the core (or PXE rep that you are testing) and then copy the new boot.wim you are updating

                          7 - AFTER YOU TEST THE NEW WIM: Make sure the boot.wim file is replicated to all your PXE reps

                          • 10. Re: Unable to capture Image LD9.6sp2
                            Apprentice

                            I did all that and now I just get a bunch of errors when booting to it. No Corename set in corename.txt, Fail to get Driver Inf File List, no available hard disk or driver not loaded... I grabbed the boot.wim straight from the core, not sure why it would have all these issues. It didn't have a certificate file at all in the cbaroot\cert folder to begin with either.

                             

                            Still waiting on reply to my Support ticket...

                             

                            edit: trying the boot.wim from my PXE rep instead now

                             

                            edit2: IT WORKED! There was no cert file in the folder at all, I have no idea why that is. But it seemed to have fixed it and I can now capture again. Thank you!