4 Replies Latest reply on Aug 8, 2016 11:35 AM by phoffmann

    Going to Sleep During Provisioning...?

    jebolick Rookie

      How do I keep a computer from going to sleep 2/3 through a template? The gold image has a power setting of sleep in 30 minutes by default due to sysprep. I have to log back in the laptop and the template continues.

        • 1. Re: Going to Sleep During Provisioning...?
          JoeDrwiega SupportEmployee

          You can set it via registry:

          HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power

          "HibernateEnabled"=dword:00000000

          HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Power\PowerSettings\abfc2519-3608-4c2a-94ea-171b0ed546ab]

          "ACSettingIndex"=dword:00000000

          "DCSettingIndex"=dword:00000000

           

          Or command line: Powercfg Command-Line Options

           

          Be sure to add a task to enable it all after all provisioning is done.

          • 2. Re: Going to Sleep During Provisioning...?
            phoffmann SupportEmployee

            Uh - that old thing rearing its head again ... somehow Microsoft manages to not see our process from time to time & decides to go snoozing (because power saving is enabled by default). Given that our processes "do stuff" it's not like there's much reason for it to believe the OS is actually idle.

             

            Meh.

             

            It's one of the key reasons why I try to remind people to disable power saving on their gold image and only re-enable power saving at the end of provisioning.

             

            Something to add / point out for the next revision to the gold image?

            1 of 1 people found this helpful
            • 3. Re: Going to Sleep During Provisioning...?
              ecoidan Specialist

              Powercfg commands I use as one of the first steps:

               

              c:\windows\system32\powercfg.exe -change -standby-timeout-ac 0

              c:\windows\system32\powercfg.exe -change -monitor-timeout-ac 0

              c:\windows\system32\powercfg.exe -change -standby-timeout-dc 0

              c:\windows\system32\powercfg.exe -change -monitor-timeout-dc 0

               

              I actually created a separate template just for these commands. 

              1 of 1 people found this helpful
              • 4. Re: Going to Sleep During Provisioning...?
                phoffmann SupportEmployee

                That's a very good idea & great safeguard against an image where people forgot to turn off powersaving features... thanks for sharing!