6 Replies Latest reply on Dec 22, 2015 2:33 AM by kleong

    H.I.I. cannot find network drivers for Dell T7910

    mkfobian Apprentice

      Hello all,


      Still a bit new to LANDesk provisioning (especially the nitty-gritty of HII).

      We're deploying a sysprepped (OOBE, generalized) image to a lab full of Dell Precision T7910 devices.


      We downloaded the Dell driver cab and unpackaged it into the \\CORE\ldmain\landesk\files\drivers\HIIDell\T7910 folder and rebuild the HII database.


      On the endpoint device, it APPEARS to be downloading the correct (I've tried it both assigned and unassigned) driver, but it will not install the driver (doesn't seem to find it?)


      The devices (there are two NICs) are:




      Anyone have any clues?


      Apologies in advance if I FUBAR the appropriate formatting for logs, here.


      source path to download: http://CORE/landesk/files/drivers/drivers.db3

      dest path for download: c:\Windows\LDDriverStore\drivers.db3

      Opening SQLite3 database at location: c:\Windows\LDDriverStore\drivers.db3



      Device manufacturer discovered as: Dell Inc.

      Device model discovered as: Precision Tower 7910

      Found MakeModel_Idn 4


      source path to download: http://CORE/landesk/files/drivers/HIIDell/T7910/win7/x64/network/JGGHH_A00-00/production/Windows7-x64/E1D62x64.inf

      dest path for download: c:\Windows\LDDriverStore\HIIDell\T7910\win7\x64\network\JGGHH_A00-00\production\Windows7-x64\E1D62x64.inf

      source path to download: http://CORE/landesk/files/drivers/HIIDell/T7910/win7/x64/network/JGGHH_A00-00/production/Windows7-x64/e1d62x64.cat

      dest path for download: c:\Windows\LDDriverStore\HIIDell\T7910\win7\x64\network\JGGHH_A00-00\production\Windows7-x64\e1d62x64.cat

      source path to download: http://CORE/landesk/files/drivers/HIIDell/T7910/win7/x64/network/JGGHH_A00-00/production/Windows7-x64/e1dmsg.dll

      dest path for download: c:\Windows\LDDriverStore\HIIDell\T7910\win7\x64\network\JGGHH_A00-00\production\Windows7-x64\e1dmsg.dll

      source path to download: http://CORE/landesk/files/drivers/HIIDell/T7910/win7/x64/network/JGGHH_A00-00/production/Windows7-x64/NicInstD.dll

      dest path for download: c:\Windows\LDDriverStore\HIIDell\T7910\win7\x64\network\JGGHH_A00-00\production\Windows7-x64\NicInstD.dll

      source path to download: http://CORE/landesk/files/drivers/HIIDell/T7910/win7/x64/network/JGGHH_A00-00/production/Windows7-x64/NicCo4.dll

      dest path for download: c:\Windows\LDDriverStore\HIIDell\T7910\win7\x64\network\JGGHH_A00-00\production\Windows7-x64\NicCo4.dll

      source path to download: http://CORE/landesk/files/drivers/HIIDell/T7910/win7/x64/network/JGGHH_A00-00/production/Windows7-x64/e1d62x64.din

      dest path for download: c:\Windows\LDDriverStore\HIIDell\T7910\win7\x64\network\JGGHH_A00-00\production\Windows7-x64\e1d62x64.din

      source path to download: http://CORE/landesk/files/drivers/HIIDell/T7910/win7/x64/network/JGGHH_A00-00/production/Windows7-x64/e1d62x64.sys

      dest path for download: c:\Windows\LDDriverStore\HIIDell\T7910\win7\x64\network\JGGHH_A00-00\production\Windows7-x64\e1d62x64.sys


      Download return count: 464

      OS Version: 6.1

      Force unsigned drivers option detected.  Will add /forceunsigned flag to DISM command.

      DISM path and command line: x:\windows\system32\dism.exe /image:c:\ /add-driver /driver:"c:\Windows\LDDriverStore" /recurse /forceunsigned

      DISM returned code: 2

      ProcessDrivers failed.

      GetImageSystemDirectory: c:\Windows



      >>>  [Setup online Device Install (Hardware initiated) - pci\ven_8086&dev_1533&subsys_06191028&rev_03\4&4e29425&0&00e1]

      >>>  Section start 2015/12/16 16:38:53.670

           ump: Creating Install Process: DrvInst.exe 16:38:53.670

           ndv: Retrieving device info...

           ndv: Setting device parameters...

           ndv: Searching Driver Store and Device Path...

           dvi: {Build Driver List} 16:38:53.759

           dvi:      Searching for hardware ID(s):

           dvi:           pci\ven_8086&dev_1533&subsys_06191028&rev_03

           dvi:           pci\ven_8086&dev_1533&subsys_06191028

           dvi:           pci\ven_8086&dev_1533&cc_020000

           dvi:           pci\ven_8086&dev_1533&cc_0200

           dvi:      Searching for compatible ID(s):

           dvi:           pci\ven_8086&dev_1533&rev_03

           dvi:           pci\ven_8086&dev_1533

           dvi:           pci\ven_8086&cc_020000

           dvi:           pci\ven_8086&cc_0200

           dvi:           pci\ven_8086

           dvi:           pci\cc_020000

           dvi:           pci\cc_0200

           cpy:      Policy is set to make all digital signatures equal.

           dvi:      Enumerating INFs from path list 'C:\Windows\inf'

           inf:      Searched 0 potential matches in published INF directory

           inf:      Searched 36 INFs in directory: 'C:\Windows\inf'

           dvi: {Build Driver List - exit(0x00000000)} 16:38:54.228

           ndv: Selecting best match from Driver Store (including Device Path)...

           dvi: {DIF_SELECTBESTCOMPATDRV} 16:38:54.229

           dvi:      No class installer for 'Ethernet Controller'

           dvi:      No CoInstallers found

           dvi:      Default installer: Enter 16:38:54.231

           dvi:           {Select Best Driver}

      !    dvi:                Selecting driver failed(0xe0000228)

           dvi:           {Select Best Driver - exit(0xe0000228)}

      !    dvi:      Default installer: failed!

      !    dvi:      Error 0xe0000228: There are no compatible drivers for this device.

           dvi: {DIF_SELECTBESTCOMPATDRV - exit(0xe0000228)} 16:38:54.235

           ndv: Waiting for previous device install to complete. 16:38:54.236

           ndv: {Core Device Install} 16:39:24.853

      !    ndv:      Installing NULL driver!

           dvi:      Set selected driver complete.

           dvi:      {DIF_ALLOW_INSTALL} 16:39:24.874

           dvi:           No class installer for 'Ethernet Controller'

           dvi:           Default installer: Enter 16:39:24.875

           dvi:           Default installer: Exit

           dvi:      {DIF_ALLOW_INSTALL - exit(0xe000020e)} 16:39:24.876

           dvi:      {DIF_INSTALLDEVICE} 16:39:24.876

           dvi:           No class installer for 'Ethernet Controller'

           dvi:           Default installer: Enter 16:39:24.877

      !    dvi:                Installing NULL driver!

           dvi:                Writing common driver property settings.

           dvi:                {Restarting Devices} 16:39:24.887

           dvi:                     Restart: PCI\VEN_8086&DEV_1533&SUBSYS_06191028&REV_03\4&4E29425&0&00E1

           dvi:                     Restart complete.

           dvi:                {Restarting Devices exit} 16:39:24.947

           dvi:           Default installer: Exit

           dvi:      {DIF_INSTALLDEVICE - exit(0x00000000)} 16:39:24.948

           dvi:      {DIF_NEWDEVICEWIZARD_FINISHINSTALL} 16:39:24.949

           dvi:           No class installer for 'Ethernet Controller'

           dvi:           Default installer: Enter 16:39:24.951

           dvi:           Default installer: Exit

           dvi:      {DIF_NEWDEVICEWIZARD_FINISHINSTALL - exit(0xe000020e)} 16:39:24.952

           ndv:      Device install status=0x00000000

           ndv:      Performing device install final cleanup...

           ndv: {Core Device Install - exit(0x00000000)} 16:39:24.955

           ump: Server install process exited with code 0x00000000 16:39:24.961

      <<<  Section end 2015/12/16 16:39:24.962

      <<<  [Exit status: SUCCESS]

        • 1. Re: H.I.I. cannot find network drivers for Dell T7910
          JoeDrwiega SupportEmployee

          I am wondering if in the INF the REV_05 or REV_03 are missing! Thanks Dell!

          • 2. Re: H.I.I. cannot find network drivers for Dell T7910
            mkfobian Apprentice

            Does the INF have to match the HardwareId string exactly? The device is marked "PCI\VEN_8086&DEV_1533&SUBSYS_06191028&REV_03"


            The .INF file contains the lines:

            %E153ANC.DeviceDesc%            = E153A.6.1.1,       PCI\VEN_8086&DEV_153A&SUBSYS_06191028

            %E153ANC.DeviceDesc%            = E153A,       PCI\VEN_8086&DEV_153A&SUBSYS_06191028

            • 3. Re: H.I.I. cannot find network drivers for Dell T7910
              JoeDrwiega SupportEmployee

              Have you tried Manually assigning it in HII Tool? How to manage drivers Using the HII Tool

              • 4. Re: H.I.I. cannot find network drivers for Dell T7910
                mkfobian Apprentice


                I have the drivers assigned currently. These drivers should work no problem -- if you copy these drivers to a flash drive and point Device Manager at that directory after imaging, it will install these drivers without issue.

                • 5. Re: H.I.I. cannot find network drivers for Dell T7910
                  JoeDrwiega SupportEmployee

                  Can you test something, I used this in the past to see if it was a driver stuck in my image, create a provision task before HII to delete this directory c:\Windows\LDDriverStore.

                  • 6. Re: H.I.I. cannot find network drivers for Dell T7910
                    kleong Apprentice

                    We have ran into something similar after we upgraded from LDMS 9.5 SP2 to LDMS 9.6 SP2 where our driver set was no different to prior to the upgrade.


                    We initially compared the driver contents in C:\Windows\LDDriverStore\ to the CoreServer / Preferred Server and noticed that some driver dll files were missing. eg: 102 files under C:\Windows\LDDriverStore\Video\Intel_X_Blah but there were 106 files under C:\Program Files (x86)\LANDESK\ManagementSuite\LANDESK\files\drivers\Video\Intel_X_Blah


                    Our issue was that WinPE X:\ scratch space was now no longer large enough to cater for the drivers downloaded from the Core/Preferred Server. By default it's set to 32MB and you can use DISM tool to increase it to 64MB, 128MB, 256MB and 512MB via the following command, however we were already at 512MB and we had to manually tweak it and force it to 1024MB (1GB);


                    Creating a temporarily Directory/Folder for the WIM to be mounted

                    MKDIR C:\Mounted_WIM

                    Creating a Backup of the WIM File before modification

                    COPY "C:\Program Files (x86)\LANDesk\ManagementSuite\LANDESK\vBoot\BOOT.WIM" "C:\Program Files (x86)\LANDesk\ManagementSuite\LANDESK\vBoot\BOOT_BAK.WIM"

                    Mounting the WIM file for editing

                    DISM.EXE /Mount-Wim /WimFile:"C:\Program Files (x86)\LANDesk\ManagementSuite\LANDESK\vBoot\BOOT.WIM" /Index:1 /MountDir:"C:\Mounted_WIM"

                    Find the current setting of the Scratch Space

                    DISM.EXE /Image:"C:\Mounted_WIM" /Get-ScratchSpace

                    Set the Scratch Space

                    Source Reference:

                    Add an Application to a Windows PE Image

                    DISM.EXE /Image:"C:\Mounted_WIM" /Set-ScratchSpace:512


                    If 512MB does not solve your problem, you will need to manually force it to 1024MB under the registry with the following;

                    DISM will not set scratch space larger than 512.

                    Source Reference:

                    Sizing PE's RAM Drive — Internals.io


                    REG.EXE LOAD "HKLM\WinPE_WIM" "C:\Mounted_WIM\Windows\System32\CONFIG\SYSTEM"

                    REG.EXE ADD "HKLM\WinPE_WIM\ControlSet001\Services\FBWF" /v "WinPECacheThreshold" /t REG_DWORD /d "1024" /F

                    REG.EXE UNLOAD "HKLM\WinPE_WIM"


                    Validate the Scratch Space

                    DISM.EXE /Image:"C:\Mounted_WIM" /Get-ScratchSpace


                    Comitting the change and unmounting the WIM

                    DISM.EXE /Unmount-Wim /MountDir:C:\Mounted_WIM /Commit

                    Once this is done, you will need to re-distribute/update your PXE rep to have the new WIM or manually copy the BOOT.WIM and replace it on the PXE Rep (C:\Program Files (x86)\LANDESK\PXE\System\images\Boot\BOOT.WIM)

                    Good Luck : )