1 Reply Latest reply on Jan 11, 2016 8:00 AM by nick.evans

    Another template with this name already exists (LDMS 9.60.2.48)

    Rick.Smith1 Specialist

      I am having an issue where I delete a template. Then I condense a different template and try to give it the name of the old template I deleted.

      LANDESK keeps flagging that another template with the name already exists. I have searched All Public area, I have gone through every folder and sub folder. NO template exists with the name I am trying to give it.

      I've tried to close and re-open LANDESK thinking maybe something was just locked in the console, but still no luck.

       

      For us this is critical since we call the exact template name from powershell\MBSDK through a shortcut built into our VDI images. This allows us to open a maint image and then use provisiong to automate the sealing\shutdown process. So simply using a different name isn't a solution for us.

       

      Rick

        • 1. Re: Another template with this name already exists (LDMS 9.60.2.48)
          nick.evans SupportEmployee

          Hi Rick,

          What version of LDMS are you using, and with what component patches?

          A couple things I'm seeing in my environment on this matter -

          The templates are listed in the DB under the PROV_TEMPLATE_DEF table.

          When I go look at my table, there are a handful of template names listed that are no longer listed within my provisioning list view.

          If I copy the name from the NAME column of one that I can't see in my view, and go try to make a new template with that name it will give the same error you are seeing.


          The reason I ask what version, is I think at one point there may have been an issue with deleted templates not removing from that table, meaning you can't re-use the name.

          You could validate if you're having this type of issue by creating a new template, name it, save it, delete the template, and immediately try to create it again with an identical name. Does it work or no?

          In my environment it works, and I can query the DB to see that the entry is added and then deleted when I add then remove the table from the GUI.


          Because of the dependencies I couldn't delete the old record using a query, but I was able to rename it which allows me to then use the original name on a new template. Please bare in mind, this is not really a supported operation, and I can't say with total certainty what might be impacted by tweaking the originals name in the DB. If any Provisioning history records reference that name, it could get messy.