4 Replies Latest reply on Dec 2, 2011 3:52 AM by iaann

    PXE error that I haven't seen before.

    Rookie

      Just this afternoon we started having a new error come up when trying to boot to WINPE menu. These three PXE errors appear:

       

      PXE-E32: TFTP open timeout

       

      PXE-E35: TFTP read timeout

       

      PXE-E39: TFTP cannot read from connection.

       

      Then exits PXE, and boots to local.

       

      I have looked at the MTU values on the PXE server and the core, none are set for all interfaces. Also I have tried to redeploy the PXE Representative, with no luck. Thank you for the help.

       

      -S

        • 1. Re: PXE error that I haven't seen before.
          phoffmann SupportEmployee

          Bear in mind that if you haven't set MTU values, then whatever the driver regards as default will be used ... which may or may not be a good thing (as this purely depends on the NIC/driver, and there's quite a lot of variation out there)..

           

          Try setting an MTU ... see if that helps.

           

          IMPORTANT NOTE:

          The Pxe Proxy's MTU does NOT get set in the usual place (i.e. - HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfac

          es\ ) but a different one alltogether (we added a place when we found out that the "normal" setting doesn't change this).

           

          You set the PXE Proxy's MTU here:

          HKEY_LOCAL_MACHINE\SOFTWARE\INTEL\PXE\Mtftpd\MTFTP_HIGH_PERFORMANCE

           

          By default, it is set as 1, the packet size is 1456. If you can set it as 0, the packet size will be 512.

           

          You can set the registry manually or using our tool "PXE\System\PXEConfig.exe", right click on "Boot Server"-"Configure Boot Server.."-"MTFTP Options"-"Transimit MTFTP Large Packets".

           

          Paul Hoffmann

          LANDesk EMEA Technical Lead

          • 2. Re: PXE error that I haven't seen before.
            Rookie

            Thank you worked great, used the pxeconfig.exe and selected "Transmit MTFTP Large Packets".

             

            After thinking about it, we have decided to use a new dedicated server as our PXE Rep. We are deploying it right now, question is though how do we copy the configuation from our current representative to the new rep?

             

            Thanks

            • 3. Re: PXE error that I haven't seen before.
              phoffmann SupportEmployee

              There's not a lot involved.

               

              Should be just a matter of running the install PXE Rep script against the dedicated machine, and making sure the MTU is set fine (this is primarily a factor if it has the same NIC).

               

              There's no "settings" really other than MTU that are of any relevance to the PXE Rep, as most of what it does consists of talking to the Core (and that's the part that needs to know what it's doing).

               

              I suspect you might be thinking it to be more complex than it is :).

               

              Paul Hoffmann

              LANDesk EMEA Technical Lead.

              • 4. Re: PXE error that I haven't seen before.
                Rookie

                Hi,

                 

                Sorry to reopen this call but.. I'm having the same issue...

                We have a pxe seating on a different network / domain / subnet as the client. and we had this pxe error.

                 

                I decided to creat a new pxe server on the same subnet as the client, everything is setup properly , but we still have the TFTP time out...

                 

                Any help would be nice..

                 

                Thanks

                Yann

                 

                PS: Already tried Paul's possible answer rgrdaing the MTU, no joy.