1 2 Previous Next 19 Replies Latest reply on Mar 7, 2016 12:16 AM by hp14

    Workspaces not working on my LDMS2016 instance

    Apprentice

      I tossed up an LDMS2016 test box yesterday and pushed out a few agents. So far, it looks nice, but the first thing I attempted to try was Workspaces and it's not functioning properly.

       

      I loaded up the ConfigurationCenter and discovered that instead of using sa/administrator you now have to change IIS authentication to Anonymous Auth disabled and Forms Auth disabled. Once that was done, Configuration Center lets me right in.

       

      Since I am only using LDMS, I verified the settings here: https://community.landesk.com/support/docs/DOC-34966

       

      Configuration Parameter

      Value

      Name

      <instance name>.BridgeIT

      Application Pool

      select from the list, usually ‘My AppPool1’

      Logon Policy

      Token Only

      LDSD Web API URL

      Leave this field blank

      LDMS Web API URL

      https://<core server name>/ldapi/api

      STS Issue Token URL

      https://<core server name>/STS/IssueToken

      Avalanche Enterprise Server URL

      Leave this field blank

      Avalanche Smart Device Server URL

      Leave this field blank

      Avalanche Company ID

      Leave this field blank

      Enable LDMS Agent Integration

      True

       

      On a Windows 10 box with the agent installed, launching Workspaces prompts me for a login. When I try my AD account with http://coreName/my.bridgeIT it kicks me back out. If I manually browse to the page and login, it works.

       

      Am I missing something here?

       

      Side note - After making any necessary changes in Configuration Center, you should probably turn Anonymous Auth and Forms Auth back to enabled to prevent anyone from getting into it.

       

       

       

      Also, this is part of the diagnostics log from the Configuration Center - I've highlighted in red things that look like an issue:

       

       

      <message>

       

       

      <title>IIS admin folder is C:\inetpub\wwwroot\</title>

       

      <timesent>2016-02-11 16:40:28.898</timesent>

      </message>

       

      <message>

       

       

      <title>Virtual directory is My.BridgeIT</title>

       

      <timesent>2016-02-11 16:40:28.904</timesent>

      </message>

       

      <message>

       

       

      <title>Base class commit...</title>

       

      <timesent>2016-02-11 16:40:28.905</timesent>

      </message>

       

      <message>

       

       

      <title>Extracting virtual directory entry...</title>

       

      <timesent>2016-02-11 16:40:28.907</timesent>

      </message>

       

      <message>

       

       

      <title>No directory entry for My.BridgeIT</title>

       

      <timesent>2016-02-11 16:40:29.288</timesent>

      </message>

       

      <message>

       

       

      <title>Applying security for virtual directory...</title>

       

      <timesent>2016-02-11 16:40:29.290</timesent>

      </message>

       

      <message>

       

       

      <title>

       

      Failed to set security for virtual directory My.BridgeIT. Exception My.BridgeIT

      </title>

      <timesent>2016-02-11 16:40:29.332</timesent>

      </message>

       

      <message>

       

       

      <title>Exception thrown creating application</title>

       

      <timesent>2016-02-11 16:40:29.334</timesent>

      </message>

       

      <message>

       

       

      <title>Commit completed.</title>

       

      <timesent>2016-02-11 16:40:32.771</timesent>

      </message>

       

      <message>

       

       

      <title>Permissions - Account Name = NETWORK SERVICE</title>

       

      <timesent>2016-02-12 08:43:45.204</timesent>

      </message>

       

      <message>

       

       

      <title>

       

      Permissions - Directory = C:\ProgramData\LANDesk\ServiceDesk\

      </title>

      <timesent>2016-02-12 08:43:45.220</timesent>

      </message>

       

      <message>

       

       

      <title>

       

      Updating Config file for Virtual Directory My.BridgeIT

      </title>

      <timesent>2016-02-12 08:43:45.673</timesent>

      </message>

      </Messages>

        1 2 Previous Next