4 Replies Latest reply on Feb 19, 2016 8:42 AM by karenpeacock

    Result : policy has been made available status: waiting

    HermiM Apprentice

      Hello,

       

      All target devices that were added to a schedule task had this status (waiting and return the same result (policy has been made available).

       

      I have tried to add 2 devices (devices that are assigned to the task which has the status waiting) to another task and the installation was done successfully. This why I think that the problem may came from the scheduled task (both tasks have the same task settings and both tasks are using some agent settings)

       

      I have checked the policysync.exe.log file and it seems that there are no error message. In addition, I can't find the policy xml file under C:\ProgramData\LANDesk\Policies

       

      For this reason, I think that the client has started a policy synchronization, but for some reason the core is not detecting that there are a task assigned to this device.

       

      I used wireshark on the client and I traced the HTTP traffic and what I understood is the following:

       

      The client start by testing if the HTTP server is available on the core server. If it is the case (HTTP server available on the core) it sends some inventory data (like GUID, device name, etc). Based on this inventory data the core server will find out if there are available policies for this device and send it (CP.<TASKIDN>.RUNNOW.xml) back.

      Here come my questions:

      - Does the IIS server installed with the core server will be used to provide devices with policy xml file? is it what they called an APM Web service?

      - Where does the core server search target devices for a specific task? in policy xml file there is no information about target devices. Does the core server uses information from the LANDESK database?

      - Is there a log file on the core server that trace how does policy sync request from client are handled? for example policy sync is coming from device X / check file Y (or table in database) / N tasks to which the device X is assigned are found 

       

      P.S: I know that if I create a new task may be it will resolve the problem, but I would like to have a deep knowledge of the reason of this issue since I found many guys are facing very often this issue.

       

      Best regards

      Hermi