6 Replies Latest reply on Nov 2, 2009 8:15 AM by ruudb

    WINPE Multicasting Troubles

    Rookie

      I am trying to Multicast with WINPE and it downloads the image from the server to my Multicast Representative but i don't think it ever sends the image to the clients for reimaging. The clients sit at a screen saying "Receiving 11534068, need 4210896 resent" and stay like that for hours on end with nothing happening or hard drive activity. I check the current status on the LANDesk script to see where it is progressing or if it failed and it says:

       

      "Machine","CbaStatus","ExitCode","Duration","Begin","End","Command"

      "COMPUTER1","OK",0,0:00:00,8/28/2008 10:28:12 AM,8/28/2008 10:28:12 AM,"WINPE, TIMEOUT=1800"

      "COMPUTER1","OK",0,0:00:05,8/28/2008 10:28:12 AM,8/28/2008 10:28:17 AM,"X:\LDClient\diskinfo new_temp_partition 3593, STATUS"

      "COMPUTER1","OK",0,0:00:03,8/28/2008 10:28:17 AM,8/28/2008 10:28:20 AM,"X:\LDClient\wpemcast.exe g:, ASYNC"

      "COMPUTER1","OK",0,0:00:15,8/28/2008 10:28:20 AM,8/28/2008 10:28:35 AM,"SLEEP"

       

       

      And again it just sits at Sleep for Hours and then finally fails with a:

      "Machine","CbaStatus","ExitCode","Duration","Begin","End","Command"
      "COMPUTER1","OK",0,0:00:00,8/28/2008 8:16:14 AM,8/28/2008 8:16:14 AM,"WINPE, TIMEOUT=1800"
      "COMPUTER1","OK",0,0:00:05,8/28/2008 8:16:14 AM,8/28/2008 8:16:19 AM,"X:\LDClient\diskinfo new_temp_partition 3593, STATUS"
      "COMPUTER1","OK",0,0:00:04,8/28/2008 8:16:19 AM,8/28/2008 8:16:23 AM,"X:\LDClient\wpemcast.exe g:, ASYNC"
      "COMPUTER1","OK",0,0:00:15,8/28/2008 8:16:23 AM,8/28/2008 8:16:38 AM,"SLEEP"
      "(FAILED) ADTDA123533","FAILED",1306,"0:00:00","8/28/2008 8:16:51 AM","8/28/2008 8:16:51 AM","Targeted Multicast"
      ; "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"

       

       

      Attached is my Multicast script so please help were you can or provide any information necessary, i am willing to try anything. Thanks.

       

      **Computer names, domains, server names, usernames, and passwords have been changed to protect the innocent **

        • 1. Re: WINPE Multicasting Troubles
          MarXtar ITSMMVPGroup

          Are you doing more than one multicast simultaneously?  If so, don't.

           

          Have you got the latest drivers for your network card in the WinPE image?  If so, have your tried a revision earlier (may affect multicast support).

           

          Could something be interfering with multicast transmission (such as a switch setting)?

           

          Do you really need multicast?  If you are doing fewer than 10 machines, then it will probably be quicker if you use unicast from a location that has a decent network card and not acting as a main file server.

           

          Mark Star - MarXtar LANDesk Enhancements

           

          Home of Power State Notifier & Wake-On-WAN for LANDesk

          • 2. Re: WINPE Multicasting Troubles
            Rookie

            Only one multicast at a time, i know doing more then one multicast in the same subnet simultaneously causes issues. I don't think its a drivers issue as i can PXE through WINPE on this exact same computer and the TMC starts it just sits at "Receiving 11534068, need 4210896 resent", but you might be right about a revision earlier but thats a pain to go through especially if i need to multicast 20-30 different models.....but i'll see.

             

            I don't think its a switch setting as i'm able to multicast DOS based on this same machine just not WINPE. I am testing Multicasting to try and get it to work, i know PXE goes quicker in this instance of one machine but when i'm against the wire and really need to Multicast i'd like for it to work rather then going through these errors and days working on it when i need it immediately.....hence me trying it out now.

             

            Is it possible maybe for someone to post there WORKING TMC scripts and i can compare to mine and make changes as necessary and report back if it works and which line fixed my problems?

            • 3. Re: WINPE Multicasting Troubles
              MarXtar ITSMMVPGroup

              PXE boot doesn't use the drivers in WinPE, it is using the universal drivers built into the card.  DOS is using 16 bit drivers whereas it sounds like WinPE is using default drivers.  If it works in one environment (DOS) but not the other (WinPE) then it is likely to be driver related so try finding the actual 32bit drivers for your network card and inject them.

               

              Mark Star - MarXtar LANDesk Enhancements

               

              Home of Power State Notifier & Wake-On-WAN for LANDesk

               

              • 4. Re: WINPE Multicasting Troubles
                Rookie

                i know PXE DOS uses different drivers then PXE WINPE......i am able to PXE with WINPE just not Multicast with WINPE.  The drivers are built into the WINPE image so the drivers are the same from WINPE PXE and WINPE Multicast.  I will still look into drivers since maybe this revision doesn't allow Multicasting but i doubt it.  Will post back.

                • 5. Re: WINPE Multicasting Troubles
                  Rookie

                  Did you ever resolve? I am having the same issue

                  • 6. Re: WINPE Multicasting Troubles
                    Specialist

                    We are having the same issue. Has anyone ever resolved this?

                     

                    Our system: LANDesk Management Suite 8.8 SP3 + Rollup 07-09

                     

                    The logfile:

                    "Machine","CbaStatus","ExitCode","Duration","Begin","End","Command"
                    "RC10049","OK",0,0:00:00,11/2/2009 4:00:31 PM,11/2/2009 4:00:31 PM,"WINPE, TIMEOUT=1800"
                    "RC10049","OK",0,0:00:01,11/2/2009 4:00:31 PM,11/2/2009 4:00:32 PM,"NET USE H: /d /y"
                    "RC10049","OK",230227968,0:00:00,11/2/2009 4:00:32 PM,11/2/2009 4:00:32 PM,"drvmap.exe lan\ldms_install_user 12545767YDGHW H: <qt/>\\distributie.lan.nhl.nl\osdimages$\XPSP3_07_PE<qt/>, STATUS FACILITY=3513"
                    "RC10049","OK",0,0:00:01,11/2/2009 4:00:32 PM,11/2/2009 4:00:33 PM,"diskpart /s h:\tools\RemovePartitions.txt"
                    "RC10049","OK",0,0:00:27,11/2/2009 4:00:33 PM,11/2/2009 4:01:00 PM,"h:\tools\gdiskcmd_mcast.cmd"
                    "RC10049","OK",0,0:00:01,11/2/2009 4:01:00 PM,11/2/2009 4:01:01 PM,"diskpart /s h:\tools\mountG.txt"
                    "RC10049","OK",0,0:00:00,11/2/2009 4:01:01 PM,11/2/2009 4:01:01 PM,"X:\LDClient\wpemcast.exe g:, ASYNC"
                    "RC10049","OK",0,0:00:15,11/2/2009 4:01:01 PM,11/2/2009 4:01:16 PM,"SLEEP"
                    "(FAILED) RC10049","FAILED",1306,"0:00:00","11/2/2009 4:01:28 PM","11/2/2009 4:01:28 PM","Targeted Multicast"
                    ; "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"

                     

                    The WinPE client has a XPSP3_07.GHO file on it's G:\ drive but it's a 0 bytes file. (The image is 888 MB). The G:\ drive is a 2,2 GB FAT32 partition.

                     

                    The Multicast Domain Representative is not getting the XPSP3_07.GHO file in the local sdmcache folder. We've tried using a NULL session share and a http share but this didn't solve the problem.