5 Replies Latest reply on Apr 1, 2016 1:30 AM by RobLent

    Uninstall Visio 2010 not working

    RobLent Specialist

      So I have an install package working fine for Visio 2010 Standard.

       

      Runs the setup.exe with no issues and silently installs using the MSP file in updates folder.

       

      I am now trying to create an uninstall package to go with it but I cannot get it to work.

       

      The commands work fine if I run them manually on my test PC but not through LDMS.

       

      Any reason why this would be?

       

      Using LDMS 9.5 SP3.

       

      Uninstall command is:

      setup.exe

      Then in command line options /uninstall Visio /config “\\Sharepath\Microsoft\Visio Standard 2010 - RML Test\SilentUninstallConfig.xml”

        • 1. Re: Uninstall Visio 2010 not working
          Markus.Gonser ITSMMVPGroup

          Hi RobLent,

           

          please check if you are able to can access the share with a system account.

          I think this should be the problem.

          Otherwise add the xml file to the package and change the commandline tot the sdmcache folder of LANDESK.

           

          best regards

          Markus

          • 2. Re: Uninstall Visio 2010 not working
            RobLent Specialist

            Hi Markus,

             

            Thanks for the quick reply.

             

            If the package deploys from the same share I would have thought the account would have the access required?

             

            I get an error code of 30023 on the Failed task.

             

            I might try your option of using the sdmcache folder though just to see.

             

            Thanks again.


            Rob.

            • 3. Re: Uninstall Visio 2010 not working
              Markus.Gonser ITSMMVPGroup

              Hi Rob,

               

              yes i think so.

              The error means that you have a general installation source problem.

              So I think that the xml-file would be the problem.

               

              best regards

              Markus

              • 4. Re: Uninstall Visio 2010 not working
                jaysmith SupportEmployee

                I concur that you should add the xml file as an Additional File in your distribution package and then change your cmd options to reference the sdmcache.  You can use this variable :

                "%LDMS_LOCAL_DIR%\..\SDMCACHE"

                 

                If that still doesn't work, check the \ldclient\data folder and see what the sdclient_taskxxx.log says.  This should give more info on the cause of the failure. 

                • 5. Re: Uninstall Visio 2010 not working
                  RobLent Specialist

                  I have added the xml file to the package and used the variable you provided above.  (Thanks for that!)

                   

                  This still does not work though and returns the same error.

                   

                  Task log seems to look OK until it gets to running the setup.exe and config file.

                  Fri, 01 Apr 2016 08:15:46 Launched application 'C:\Program Files\LANDesk\LDClient\sdmcache\ldms\HO\Microsoft\Visio Standard 2010\setup.exe' ('/uninstall Visio /config “C:\Program Files\LANDesk\LDClient\Data\..\SDMCACHE\ldms\HO\Microsoft\Visio Standard 2010\SilentUninstallConfig.xml”') result 30023

                   

                  I know it is a long path but it is correct.

                   

                  Any other thoughts why this would not work?