1 Reply Latest reply on Apr 3, 2016 11:17 AM by patricklaforte

    Confused with HII and Drivers install


      Hello, I've been trying to get OS Provisioning up and running and I must say this is time consuming and frustrating.


      I'd like to know how do you deploy your drivers?

      I was hoping I would extract the needed drivers and make them available for Plug & Play detection. Nothing seems to work properly for me.

      FYI, I'm starting fresh and just trying to get a HP ProBook 450 G3 properly setup. I've extracted the drivers for that device and confirmed they are working properly when I use Windows Device Manager to scan and install them.


      ISSUE #1.

      Just having the Intel Management Engine and Synaptic Touchpad drivers present in the drivers.db3 library is completely breaking the install. I seems ok when HII is executed during the Post-OS Installation phase but when boot later on I get the following error message from Windows : "Windows could not configure one or more system components. To install Windows, restart the computer and then restart the installation" AND "The Computer restarted unexpectedly or encountered an unexpected error. Windows installation cannot proceed. To install Windows, click "OK" to restart the computer, and then restart the installation."


      ISSUE #2

      How do you make Intel USB3.0 drivers work?

      I've followed the guides about adding drivers to WinPE and it doesn't work for me. Even worse, I've realized that I can't do anything with our ProDesk 600 Mini which only has USB3.0 ports... once deployed I can't do anything since the USB keyboard and mouse are unusable!



      So let me know how you make OS Provisioning work for Drivers install...

        • 1. Re: Confused with HII and Drivers install

          Fixed both issues... spent way too much time on this


          Please note that this is for Windows 7 x64 SP1


          ISSUE #1 - Drivers halting the Windows Install

          RESOLUTION: Integrate update KB2685811 [KMDF - Kernel Mode Driver Framework] early in the deployment process.

               My first test was conducted with MDT [Microsoft Deployment Tool] instead of LANDesk OS Provisioning to add the package under WinPE prior to the reboot in the final OS were the hardware is detected and drivers are installed.

               I believe this can also be accomplished with Microsoft DISM tool to integrate permanently into the .WIM image of your OS

                 I'll need to find a way to do this under LANDesk.. not sure exactly how yet.



          ISSUE #2 - USB3.0 drivers not detected or installed during

          RESOLUTION: Integrate the USB3.0 drivers in my .WIM image (to make it available for hardware detection at the right moment)

               I've added both Intel drivers iusb3xhc.inf and iusb3hub.inf with Microsoft DISM tool to make them permanent into my .WIM image of my OS.

               According to my reading, eventually this could get ugly in the future if we keep adding drivers this way. Using system profiles and forcing the drivers might be a better solution in the long run... not there yet.


          I hope this can help others