5 Replies Latest reply on Apr 27, 2016 1:49 PM by mbrevick

    LD2016 Provisioning can't load templates?


      Just upgraded our 9.6sp2 to LD2016 yesterday, and today I redeployed our PXE rep. I can PXE boot a machine and can login and pick a template, but it just retries 40 times and then brings up the template window again. Initially it was giving me "an unknown error occurred" message after a few retries but I restarted some services and the COM applications but I still get nowhere. I also deleted the machine from All Devices and tried creating it as a Bare Metal Device but when I click 'Add' nothing happens, the created device never shows up.


      Provisioning.log on the core is just filled with this


      DEBUGGINGProvisioningWebService4/8/2016 2:49:13 PM : GetTaskXmlInternal
      VERBOSEProvisioningWebService4/8/2016 2:49:13 PM : GetTaskXML, SIDS:
      VERBOSEProvisioningWebService4/8/2016 2:49:13 PM :     MACAddress: ECF4BB4CCD3A
      VERBOSEProvisioningWebService4/8/2016 2:49:13 PM :     SerialNumber: FYGKG12
      ERRORProvisioningWebService4/8/2016 2:49:13 PM : Unable to find computer


      This is the right machine. ldProvision.log on the machine is mostly this


      2016-04-08 22:51:45(904-924) ldProvision:Retry count 40 of 40

      2016-04-08 22:51:45(904-924) ldProvision:Call web service GetTemplatesForUser()

      2016-04-08 22:51:45(904-924) ldProvision:Start TryallWebService Attempt:0.

      2016-04-08 22:51:47(904-924) ldProvision:Calling Program:x:\cba8\httpclient.exe  -b ncs -H"X:\ldprovision\header.txt" -o"X:\ldprovision\body.txt" -f"X:\ldprovision\result.xml" https://BHLD/LANDesk/ManagementSuite/Core/Provisioning.Secure/ProvisioningSecure.asmx

      2016-04-08 22:51:47(904-924) ldProvision:End TryallWebService Attempt:0. ExitCode:0

      2016-04-08 22:51:47(904-924) ldProvision:Download template menu OK

      2016-04-08 22:51:47(904-924) ldProvision:Starting background thread to check for tasks.

      2016-04-08 22:51:47(904-1352) ldProvision:Provision Mode = PROVISION_MODE_CORE_SID

      2016-04-08 22:51:47(904-1352) ldProvision:Copy the headers off

      2016-04-08 22:51:47(904-1352) ldProvision:Start TryallWebService Attempt:0.

      2016-04-08 22:51:48(904-1352) ldProvision:Calling Program:x:\cba8\httpclient.exe  -b ncs -H"X:\ldprovision\header.txt" -o"X:\ldprovision\body.txt" -f"X:\ldprovision\result.xml" https://BHLD/LANDesk/ManagementSuite/Core/ProvisioningWebService/WebService.asmx

      2016-04-08 22:51:48(904-1352) ldProvision:End TryallWebService Attempt:0. ExitCode:0

      2016-04-08 22:51:48(904-1352) ldProvision:Computer ID: -1


      I'm not sure that really tells me anything. Full log attached.

        • 1. Re: LD2016 Provisioning can't load templates?

          So I restarted my whole server and I was able to get farther one time, it actually got to mapping drives but it was all messed up. The maptopreferredhandlers.log showed it was trying to map the UNC path K:\image.tbi to drive letter f: for some reason, nowhere in my template is it set like that.


          But I haven't gotten that again, now I'm back to getting "an unknown error occurred"


          I did find a new line in my ldProvision.log that says "Not able to obtain a client certificate. Aborting provisioning." Googling this specific error gives me no results. There is a cert file in cba8\cbaroot\certs. Not sure what it could mean though.


          edit: The Bare Metal machine I created finally showed up in LANDESK, I have no idea what happened there. I was able to get the Template to actually start deploying by creating a scheduled task first and then PXE booting. I'll have to keep trying to see if I can just PXE boot without a task already there because that's how I normally do it.

          Then I was able to find out the mapping error is due to the fact that the Deploy Image action in the template now maps a UNC path by itself, which it did not do before. I had to remove my Map Drive action and add the UNC path to the Deploy Image Action. Currently have an image deploying, will have to see if the rest of my template finishes out because I did add some Conditional stuff to help with naming machines. Will update on Monday when I get back.

          • 2. Re: LD2016 Provisioning can't load templates?
            acocimano Rookie

            Do have resolved your issue? We are facing the same problem.

            In the ldprovisioning.log the following lines attract me attention:

            2016-04-09 00:28:24(1704-1672) ldprovision.exe:Entering downloadbyproxy.

            2016-04-09 00:28:24(1704-1672) ldprovision.exe:Create process (x:\cba8\httpclient.exe) with args (  -f "x:\CBA8\cbaroot\alert\provisioning.ruleset.xml" http://BHLD/LdLogon/alertrules/provisioning.ruleset.xml)

            2016-04-09 00:28:24(1704-1672) ldprovision.exe:Waiting for process result: 0.

            2016-04-09 00:28:24(1704-1672) ldprovision.exe:Process exit code:1


            I have got the same events in my log-files. It looks like the download of the provisioning.ruleset.xml fails due to the missing "alert" subfolder in the x-Drive within the PXE-boot-image.

            Could you resolve the client certificate issue?

            Executing \cba8\brokerconfig.exe let me receive an client certificate and starting an provisioning template, which fails later on.

            • 3. Re: LD2016 Provisioning can't load templates?
              masterpetz ITSMMVPGroup



              just an idea, open "Configure - Client Access" in the console on the core and see if your device shows up in the "Unapproved" section. If so, approve the device and try provisioning again.


              Kind regards


              • 4. Re: LD2016 Provisioning can't load templates?
                acocimano Rookie

                Thanks for the advice. This doesn´t resolve the issue. There are no Unapproved devices. After consulting the Landesk Helpdesl they recomended me to automtically approve all new certificates. But anyway I did not turn on the client certificate based security feature. So this should not be part of resolving this issue.

                • 5. Re: LD2016 Provisioning can't load templates?

                  Help Desk had me go through this document (again) Issue: Provisioning task failing after try 40 of 40 and I pretty much just tried every resolution there, along with restarting my server, and then deleting all old templates and creating new ones from scratch and it started working. I'm not entirely sure what it is that fixed it in the end.