8 Replies Latest reply on Apr 3, 2018 9:08 AM by Frankie0323

    Reboot Actions in Prov Template Provagent cant load after reboot...

    MHO Apprentice

      Hi Guys,

       

      we have a big Issue since some month.

       

      We have in our Provisioning Templates some Reboot Actions in System Configuration Phase

      (After Join Domain, Patching System, Installing SW, System Settings and so on)

       

      since some month....   After Reboot...  The Provisioning Agent cant find his Template/Task and stop working...

       

      Clientside Log say:  LDPROVISION.LOG

       

      • ldProvision.exe:Copy the headers off
      • ldProvision.exe:Start TryallWebService Attempt:0.
      • ldProvision.exe:Calling Program:C:\Program Files (x86)\LANDesk\Shared Files\httpclient.exe  -b ncs -H"C:\ldprovisioning\header.txt" -o"C:\ldprovisioning\body.txt" -f"C:\ldprovisioning\result.xml" https://<core>/LANDesk/ManagementSuite/Core/ProvisioningWebService/WebService.asmx
      • ldProvision.exe:End TryallWebService Attempt:0. ExitCode:0
      • ldProvision.exe:Computer ID: -1
      • ldProvision.exe:Retry count n of 20

       

      Coresponding Provisioning Log on Coreserver say:

      • DEBUGGING ProvisioningWebService  xxxxx: GetTaskXmlInternal
      • VERBOSE ProvisioningWebService  xxxxx: GetTaskXML, SIDS:
      • VERBOSE ProvisioningWebService  xxxxx  :     MACAddress: 1234567891234
      • VERBOSE ProvisioningWebService  xxxxx  :     SerialNumber: C456FH67TN
      • WARNING ProvisioningWebService  xxxxx  : Unable to find template for computer IDN uvwxy

       

      Affected in LDMS 9.6   AND  LDMS 2016  and all Operatingsystems

       

      We have no clue......       Any Ideas?

       

      LDSupport have no ideas

       

      Thank you so much for ANY Response

      Markus

        • 1. Re: Reboot Actions in Prov Template Provagent cant load after reboot...
          phoffmann SupportEmployee

          I would suggest getting this one raised with LD support to be honest. This will require looking at your stuff in detail.

           

          First off - request the latest BASE component patch from support (as I'm not sure how old your 9.6 instance is) / the latest software update package for LD 2016.

           

          So - the "good" news - is that I *HAVE* seen this sort of thing in the past. What happened was that "obscure software package X" sent a return code that actually had provisioning think "Oh - I've finished my template now" (when it wasn't) - which is possibly the same thing that is happening to you here.

           

          It took quite a bit of figuring out a the time (and eventually a special debug version of the relevant install handler to prove that trail of thought).

           

          It's possible that you've got something similar (we'd need to check if the Core "thinks" that your provisioning template is "finished" even though it isn't) ... so that'll require some close examination.

           

          The fact that it seems to happen consistently over both version 9.6 and 2016 suggests that it is something that is consistently acting inside your templates (so no "random I feel like screwing you over" factor here), which makes this easier to troubleshoot at least. Nothing as painful as randomly (not) occurring stuff .

           

          As an aside - be aware that you *CAN* enable debug-logging (and that'll probably be request by support) inside WinPE as well (you'll just need to grab the logs before you reboot as they'll get lost otherwise).

           

          You could import a .REG file or alter your WIM if you prefer to have debug logging enabled by default (not the worst idea) and add an additional WAIT type command before you reboot to copy the logs off (or an action, as you prefer). See the information here -- How to enable Xtrace Diagnostic Logging -- to help you along.

           

          Hope this helps .

          • 2. Re: Reboot Actions in Prov Template Provagent cant load after reboot...
            MHO Apprentice

            Hi Paul,

            good to hear iam not alone... 

             

            In fact it is so that the Scheduled-task in the console is in Status "successfull" when the client reboots.

            An other thing...   when i dont install the LDMS Agent in Provisioning...

             

            All reboots (and continue after booting ) running fine.

             

            However, once the Full LDMS Agent is installed....   no continue after Reboot.

            And Core LDPROVISION LOG say: Unable to find template for computer IDN uvwxy....

             

            Still the same Client ID for all the time in database.

             

            Is there a filter in Query (Coreserverside):  Show only Templates they stay in "active" Tasks?   Provisioning TaskStatus (<> SchedTask)  is already Running

             

             

            Best Regards from Germany

             

            Markus

            • 3. Re: Reboot Actions in Prov Template Provagent cant load after reboot...
              phoffmann SupportEmployee

              OK - let's break this down to sensible questions.

               

              • Does the COMPUTER_IDN (in the COMPUTER table) stay the same for the device or does a new record get created after you install the LD agent?

               

              • I (also) don't think it's necessarily the LD agent itself - but more likely to be something "in that reboot sequence" that causes the problem...

               

              What I had to do to confirm my problem was enable debug logging & add WAIT actions after each provisioning action & examine logs during each action to see what's what. In my case, "one package" returned the "provisioning template is finished" return code (weird software installer), but the current reboot section would still work through, and only the continuing reboot sections would not work down because they're actually done.

               

              If you're not confident in trawling through those logs, then you could get in touch with support. My *guess* at the moment is that there's "something" in that whole stage of your last successful reboot loop that comes back with this "hey - template is done" return code, which makes the Core think that (upon next reboot) it doesn't need to throw any more Provisioning actions at it.

              • 4. Re: Reboot Actions in Prov Template Provagent cant load after reboot...
                MHO Apprentice

                Hi Paul,

                Support requested a lot of Provisioning Logfiles (Client & Serverside) I have delivered them today.

                 

                and we have made following discovery:

                 

                After installing LDMS Agent in Provisioning without Actions above like Distribute SW, Vulscan etc....  we can have a lot of Reboots without any issues....

                 

                Since i have a distribute SW Action  and this one was successfull...  The Scheduled Task Status will change to "successfull  -  done"

                 

                during the  Reboot  the scheduled Task Status is already "successfull  -  done"

                 

                AND the Client cant find his Task to fullfill them....

                 

                in case i change the (MAC) Status in DB (LD_TASK_MACHINE)  from  2  to  1  and restart ldprovision from Client  (ldprovision.exe -c corename)

                The Client will resume the Provisioning ....

                 

                I think this is the main issue....

                 

                What do you think about?

                Regards

                Markus

                 

                • 5. Re: Reboot Actions in Prov Template Provagent cant load after reboot...
                  phoffmann SupportEmployee

                  Yes - symptomatically that's the situation I was describing & ran into myself.

                   

                  "A package" sends a return code via Provisioning that the Core interprets as "the provisioning template is done" - the "current set" of actions still get worked down though. It's just that "on the following reboot" the Core (logically consistently) says "Hey - you said you're done, so no more provisioning for you" in effect.

                   

                  I've been able to work around the issue (while the relevant package in question was being looked at" by moving the "bothersome install" into the last set of provisioning actions (i.e. - before the final reboot), that way it doesn't cause as much of a disturbance.

                  • 6. Re: Reboot Actions in Prov Template Provagent cant load after reboot...
                    Frankie0323 Rookie

                    I'm having the same issue from your experience would you suggest making a new package? What did you discover after looking at the installer package that was causing your issue?

                     

                    Thanks

                    • 7. Re: Reboot Actions in Prov Template Provagent cant load after reboot...
                      phoffmann SupportEmployee

                      Depends on whom you are addressing via "you", exactly, Frankie0323 .

                       

                      If you're asking me -- no, I didn't need to rebuild a package in THAT particular case. Just moving bothersome things towards the end did the trick for me (if memory serves, that package was a bit of a mess that did "unexpected" stuff shall we say with drivers).

                       

                      That said, I *have* seen messy packages that cause all manner of false positives (or false negatives!) over the years. One particular favourite being an exe wrapped in an MSI, wrapped in a batch, wrapped in an MSI, wrapped in a batch (no joke!), with no documentation (of course), calling MSI switches that have never existed and everyone being scared of even touching that thing.

                       

                      ... we eventually got that thing rebuilt by someone who actually CAN package things properly, which helped, so ... yeah - depending on what kind of a mess / state your package(s) is/are in, that MAY be needed.

                       

                      This sort of stuff tends to involve checking out installer logs & hunting down exit codes (we started with "well, the install reports a success, but the software doesn't work...) ... which is how we slowly had that "oh dear" moment of the multi-layered wrapping (for reasons I can't guess at still), none of whom were handing over proper exit codes "up the chain".

                       

                      So - yeah ... "bad packages" can (and will) cause you trouble.

                       

                      I hope it's not common -- but that lesson taught me that having a competent packaging person is REALLY important. And that there's a lot more to packaging than "just" buildig an MSI on the side (one of 2 main learning moments for me around packaging). I've tried hard not to underestimate the amount of trouble you can get yourself into with bad packages since then .

                      • 8. Re: Reboot Actions in Prov Template Provagent cant load after reboot...
                        Frankie0323 Rookie

                        Thanks phoffman your post always offer some insight. Our packages are fine the issue started happening after updating to Service Update 6 may be related may not.

                         

                        Yesterday I left a provisioning task running overnight it was hung up on the first reboot.  I came back today to find out it continued provisioning after 4 hours or so. It initiated another reboot and continued without issue.

                         

                        I'm going to open a ticket with support and send in this log.