7 Replies Latest reply on Jun 28, 2016 6:37 AM by Joel.Olson

    VM-Ware VM's not reporting to LD96 SP2 Core

    Joel.Olson Rookie

      We are in the process of completely moving over from LD95 SP2 to LD96 SP2 and plan on that at the end of the summer. In the mean time we are running both cores.

      I am having issues getting my VM's to communicate to the 96 core but have success when I run the same install on a live machine.

      When running a inventory scan I get the following error: LDISCN32: The inventory server **** did not respond.

      I was wondering if anyone has experienced this issue as the searches I have found on the community are old and unanswered. Any assistance is appreciated and thank you in advance.

        • 1. Re: VM-Ware VM's not reporting to LD96 SP2 Core
          MarXtar ITSMMVPGroup

          First thing to check will be networking. Can the VM clients ping the core server by name successfully? Do they manage just by name or do they need the FQDN?

           

          Mark McGinn

          MarXtar Ltd/MarXtar Corporation

          http://landeskone.marxtar.co.uk

          LANDESK One Development Partner

           

          Try MarXtar State Management for LANDESK to Better Understand and Manage your Assets

          • 2. Re: VM-Ware VM's not reporting to LD96 SP2 Core
            Joel.Olson Rookie

            Marxtar,

            They are all able to ping/communicate directly with the core via hostname and IP. After looking some more I have found a possible solution being restarting the inventory service.
            I just reinstalled the client on a VM and it actually showed up on the core but not with any information.

            Other machines are reporting on the new core so I am not sure if restarting the inventory service will resolve the issue.

            • 3. Re: VM-Ware VM's not reporting to LD96 SP2 Core
              Joel.Olson Rookie

              Restarted the Inventory Services on the core and still have machines not able to report in and receiving the
              LDISCN32: The inventory server error.

              • 4. Re: VM-Ware VM's not reporting to LD96 SP2 Core
                Ironbike Apprentice

                I run into similar issues when I upgrade cores. Did you copy the core certificate from the 9.5 core to the 9.6 core?  I’ve also found using the /F- switch (disables the software scan) allows the inventory scan to be accepted by the core.  You can copy then edit the inventoryscanner script in the distribution, managed scripts module on the 9.5 core.  Change the %server% to the FQDN or IP address of the 9.6 core and add the /F- switch to the end of the string.  Push the script to a few devices that have the 9.5 agent you should see them appear in the 9.6 core.  This is the link to the inventory scanner switches https://community.landesk.com/docs/DOC-1499 in may be helpful.

                1 of 1 people found this helpful
                • 5. Re: VM-Ware VM's not reporting to LD96 SP2 Core
                  Joel.Olson Rookie

                  Thank you Andy, I will have to test this in our environment but I think this will help.

                  I was also thinking of testing the agent configuration as well, possibly create a new one to see if that allows the VM's to report.


                  • 6. Re: VM-Ware VM's not reporting to LD96 SP2 Core
                    phoffmann SupportEmployee

                    As an aside - the Core cert isn't needed for inventory scans (the Core has to accept inventory scans from unknown devices, as otherwise we can't know if a device is legitimate or not. Furthermore, you won't have anything resembling a "full" inventory scan when in a PXE environment as well ).

                     

                    If you run the inventory scan with "/V" on the client, you'll get a visual window & see what the client is trying to contact (old hostname?). Usually it should be something like "MyCore.FQDN.Com:5007" (the port 5007 is important).

                     

                    If you check the clients' log(s) you may also see what's going on. The logs are under - %PROGRAMDATA%\LANDesk\Logs\ - just sort by time & have a look at the most recent ones. Probably of most interest will be:

                    - ldiscn32.log

                     

                    The following log may also help:

                    - C:\Program Files (x86)\LANDesk\Shared Files\Proxyhost.log

                     

                    All LD processes "go through proxyhost" - because proxyhost determines whether we can talk to the Core directly or need to go through the CSA as it were. So you may find some useful references to hostnames and/or IP's that are being attempted there.

                     

                    Hope that helps.

                    1 of 1 people found this helpful
                    • 7. Re: VM-Ware VM's not reporting to LD96 SP2 Core
                      Joel.Olson Rookie

                      Andy, After getting the client transferred over from the 95 core to the 96 core I noticed that some of the VM's started showing up on the core as well.

                      After a reboot of both the CSA and the core they started reporting and are able to receive remote. Oddly though serial numbers are not showing up on the new core for any machines yet.