0 Replies Latest reply on Jun 10, 2016 10:04 AM by NickCK

    Console and XenApp 7.6 (Object reference not set to an instance of an object)

    Rookie

      We have the LDMS console installed in our Citrix XenApp 6.5 environment and it's been working very well. The console also works without issue on the LD core itself. We're in the process of transitioning to XenApp 7.6, so I installed the console on the appropriate servers there. Only in the 7.6 farm through an ICA connection, we receive this error when attempting to open the properties dialog of a scheduled task. I applied SP2 and our current patch (1223i) to the console. Also of interest, I had to modify the application path to C:\Progra~1\etc etc. %ProgramFiles% and the full path including spaces reports that the application failed to launch (Can't find C:\Program). Other applications launch without issue using the environment variable. This might be the root cause some how.

       

      Anyone else running the console in XenApp 7.6?

       

      9.6 SP2 1223i

      Core is Server 2012 R2 (Working)

      XA 6.5 is Server 2008 R2 (Working)

      XA 7.6 is Server 2012 R2 (Working in RDP, Described error over ICA when launched from C:\Progra~1\. Won't launch at all with C:\Program Files)

       

       

      Details of error below:

      System.NullReferenceException: Object reference not set to an instance of an object.

         at LANDesk.ManagementSuite.SoftwareDistribution.WinUI.TaskScheduler.ScheduledTaskFolder.DistributionPackage.get_PreliminaryPackage()

         at LANDesk.ManagementSuite.SoftwareDistribution.WinUI.TaskScheduler.ScheduledTaskFolder.DistributionPackage.SetPackageNames()

         at LANDesk.ManagementSuite.SoftwareDistribution.WinUI.TaskScheduler.ScheduledTaskFolder.DistributionPackage.SetPackageNamesAndLabels()

         at LANDesk.ManagementSuite.SoftwareDistribution.WinUI.TaskScheduler.ScheduledTaskFolder.DistributionPackage.OnLoad()