6 Replies Latest reply on Jul 12, 2016 10:16 AM by josh.howard

    LANDesk Data Analytics 10 - Data Translation Services

    Rookie

      Rule Group executes perfectly when started manually, but it does not work when executed via scheduled task, even though task shows successful completion. Running on Server 2012 R2.   Any ideas?

       

      More information on what we are doing.  Starting with Landesk 9.5, we use data analytics to do Discovery Services SNMP scans on our network address ranges in which printers reside.  Special Data Map and Data List Rules are then run daily to manipulate the raw collected data into a Standard Form.  A special view was created in the LDMS data base to collect the resulting Data Asset data, and then this is automatically imported into LANDesk Service desk where we have created a Printer Manager Application.  We have over 350 networked printers statewide, and this process has enabled to better keep track when new printers are added, when old ones are retired, or when a printer has been replaced, and made it easier for Admin Assistants to verify we are not paying for leases or maintenance on printers we do not have.

       

      When we went to Landesk 9.6, DA Discovery Services had too many bugs to move this process off of the LANDesk 9.5 Server.   We are now in process of moving to LANDesk 10 (2016), and I am happy the report the problems with 9.6 Discovery Services have been fixed.   However, so far, I have been unable to get the Data Map and Data List rules to run as a scheduled task.

       

      I do notice that each time the schedule tasks are started on in LD 10, there is an ERROR entry in the System Event log on the server, Event ID 7023. The Interactive Services Detection service terminated with the following error:  Incorrect Function.   My thinking that maybe that when the rules are run as a scheduled task they are trying to produce the same interactive popup that manual run of the rules produces, and this is not being allowed, thus killing the process.

       

      For those who have LANDESK 10, can you successful schedule in Data Map, or Data List rule to run successfully?   By successful, I do not mean the schedule task show success, but that results produced by the rule are actually carried out.  I am trying to figure out if this is a LANDesk bug, or a configuration issue.

        • 1. Re: LANDesk Data Analytics 10 - Data Translation Services
          Alex.Richardson SSMMVPGroup

          When you run the rules manually they execute as the logged in user. Scheduled tasks run as local system by default

           

          You need to set the Managed Planet Core Scan service to run as a user that has rights locally to the server and try again.

          • 2. Re: LANDesk Data Analytics 10 - Data Translation Services
            Frank Wils ITSMMVPGroup

            What rules are you trying to run?

             

            Frank

            • 3. Re: LANDesk Data Analytics 10 - Data Translation Services
              Rookie

              Thanks for input.  I checked, and the same Data Map, and Data Rule sets were running via the system account, on my old LANDesk 9.5 server.   However, I nevertheless tried running them using a domain account that has elevated privileges on the server, and I got the same result as before.  Whatever the source of the problem is, it has nothing tdo with my specific rules.  I can run of one of the rules that LD supplies as a scheduled task, I will get the same result: rule does not produce result.

              • 4. Re: LANDesk Data Analytics 10 - Data Translation Services
                Frank Wils ITSMMVPGroup

                When you schedule a rule or rule group, a Custom Script is created (Via the Toolbox - Manage Scripts). This script runs a LOCALEXEC meaning it will start a command on the Core Server, in this case the MPRUNSCHED.EXE followed by the custom ID of the rule or the group. As any other custom script, this is run under the local system account. The Interactive Services Detection Service on the Core Server will generate a popup asking if you want to see what's running in the background. However, in Windows Server2012, this service has changed behavior. It is stopped and set to Manual by default. If you try to start is, you will get the error about the incorrect function like the one in your log.

                 

                To be able to start the service, try setting this registry key:

                Hive: HKLM 
                Path: SYSTEM\CurrentControlSet\Control\Windows 
                DWORD: NoInteractiveServices

                Change the value “1” to “0”

                 

                I'm not sure if this will actually solve the problem of the outcome of the rules, but at least you will be able to see better if the rule starts and get rid of that specific error.

                 

                If the rule starts, you might also want to check the logs in the MP_Logs map in the ManagementSuite map on the Core for more information.

                 

                Frank

                2 of 2 people found this helpful
                • 5. Re: LANDesk Data Analytics 10 - Data Translation Services
                  Rookie

                  Frank Wils's response on Jun 27 did indeed resolve the  error log entry every time a Data_Map rule was run via scheduled task.  However, some of the rules were still not accomplishing their intended purpose when running as scheduled tasks.   But, with the error log entry out of the way, I was able to isolate the cause.  The rules that were not working were written to run on All Targets.   When they rules are run inactively, that is the default when no targets are provided.   However, that turns out not to be the case when run via scheduled tasks.  So, the final part of the solution was to provide explicit targets for each rule, and if the targets were indeed All, then a simple query that resulted in All Targets being selected met the need.

                  • 6. Re: LANDesk Data Analytics 10 - Data Translation Services
                    josh.howard SupportEmployee

                    Hi @hparker, have you filed a case for this issue yet? Technically these rules should work, when scheduled, and with or without a target. The reason I ask is because I believe that this would be a bug that should get filed through our frontline support team.

                     

                    Thanks!