3 Replies Latest reply on Oct 12, 2016 5:09 AM by phoffmann

    Manual Inventory Scan issue

    Apprentice

      Hi Everyone !

       

      I am using LDMS 2016 and all the clients are checking into the core server through the CSA.

       

      Since last 15 days, around 80+ devices out of 500+ devices are not updating their inventory records, I noticed this two days back on the core.

       

      So I decided to run manual inventory scan on some of those devices, the moment I run manual inventory scan on the client, it shows me blank GUI for around 10 seconds and then it becomes invisible. Though when I check running processes it shows me that inventory scan process is running and it does not do anything and stays there for a long time, after all that when I check on the core server none of the inventory records time / date etc gets updated, it remains old (meaning inventory scan is not working / that's why it's not reflecting the last new date / time on the core)

       

      Blank inventory scan GUI:

      inv1.PNG

      Though running the process:

      inv11.PNG

      This is what it shows me in Programdata\LANDESK\log\LDIScn32 file:

      Capture2.PNG

       

      When I run Manual inventory scan on a healthy client that is already reporting updated information to the core server.

       

      This is how good inventory scan GUI looks like:

      inv3.PNG

      I cannot guess what is causing this issue, 80+ devices have the same issue and behavior as shown in top 3 screenshots. I called to landesk support and they looked into it for hours and said that

      it seems your Agent has got corrupted, they also checked Agent configuration and there is no issue with agent and inventory configuration, as all the devices are using the same agent / agent configuration.

       

      I asked them what caused agent to got corrupted on 80+ devices on the same date 5th July (last run inventory scan as per core), they said it could be AV / HIPS blocking it or may be any GPO changes / and all sorts of stuff. They said that some change might have happened in your environment that I am not aware of and that resulted corruption of agents.

       

      It does not make sense to me that how come same day 80+ servers agent got corrupted, as I am aware of all the changes that happens in our environment / and these servers have different owners not all owners are going to make changes to these on the same day, one more thing is that we perform changes in our environment only during weekends and last run inventory scan for these servers is 5th July (Tuesday), so there is no possibility of that we did any change in our server environment.

       

      I also checked event viewer logs on the core as well as on clients but nothing significant info found there by me / support person.

       

      Could you please explain a bit, that what is causing this issue / are agents really got corrupted, if yes then what could be the possible reasons for corruption.

       

      In future what can I do to make sure that agents don't get corrupt, shall I consider using something known as "agent watcher / agent health settings" for my devices.

       

      Kindly assist me to resolve this issue.

       

      Thank you,

      Neeraj Kumar

        • 1. Re: Manual Inventory Scan issue
          phoffmann SupportEmployee

          Interesting. Never seen something like that.

           

          So here's a couple of things you can try to get a better understand of the issue:

          • Get in touch with support and request the latest update for LD 2016 - at the moment, the latest stable release version is SU3 to the best of my knowledge. This isn't a "we fixed stuff there" expectation, it's just normal "see if the latest files do anything for you" type of thing.
          • (Start to) Keep track of the devices that have this issue. See if they have some commonality (like - "a video driver" / "a specific video card") or something like that. Not required, but if all of your failures are on "one specific model of hardware", it makes root-causing easier.

           

          And then:

          • ... raise a case with support - this sort of thing will need to be trouble shot with them & dev. To help you along here, run LDISCN32 on an affected device with the following switches:

          LDISCN32.EXE /V /F /SYNC /DEBUG /L- /O=MyOutput.txt

           

          • /V - enables visual / verbose mode.
          • /F - forces a software scan ("good habit" in those situations)
          • /SYNC - forces the send of a non-delta inventory file (again a "good habit" type affair - I don't expect this to become a factor if things hang).
          • /O=path/file - forces an output file to be written.
          • /L- - the "slash L minus" tells the scanner to not talk to the Core. Just in case the problem is around comms with the Core?
          • /DEBUG - causes the inventory scanner to become VERY chatty in logs (for debug purposes, such as this situation). The two logs are:
            • (...)\LDCLIENT\LDISCN32.LOG
            • (...)\LDCLIENT\DATA\LDISCN32.LOG

           

          ... support will probably want both (the DATA\LDISCN32.LOG will probably grow by over 5 MB due to the use of /DEBUG - so be careful).

           

          Other switches you may want to try, to see where the problem lies:

          /F-  ==> Force a "no Software" Scan

          /NH  ==> Force a "No Hardware" scan

           

          Information on command-line options can be found here - About Inventory Scanner Switches  - ... mainly playing around with / disabling hardware/software scans tends to be useful around finding out where the component is that's causing you grief.

           

          That should be plenty to help you get the ball rolling.

          1 of 1 people found this helpful
          • 2. Re: Manual Inventory Scan issue
            Apprentice

            Thanks Paul,

             

            I played around with command line inventory scan switches disabling hardware and software scan one by one, tried /V, /F and /L, but somehow it did not help.

            While playing with all these options when nothing worked, I just deleted all the log files and policies, C:\ProgramData\LANDesk\Log and then started manual security scan and inventory scan.

            inventory scan did not run and was showing the behavior as it was before, I left that server and to my surprise from next day that server started reporting to LANDesk and manual inventory started running well.

            I don't know what fixed that issue, but somehow it worked not immediately but after one day, I tried the same thing on many server and most of them started reporting after one day, few this method did not work, so I reinstalled agent on them.

             

            Thank you,

            Neeraj

            • 3. Re: Manual Inventory Scan issue
              phoffmann SupportEmployee

              ... mysterious IT Gremlins at work then.

               

              Oh well ... at least it works now .