7 Replies Latest reply on Aug 1, 2016 3:23 PM by dmshimself

    2016.2 Process Approver URL not working in SLA Response Level Alerts

    Apprentice

      On 2016.2 under Administration --> Administration --> Service Level Management --> Agreements --> Request Management --> Request --> Response Levels --> Priority # --> Delivery  we have alerts going out at 75% and 100% breach levels.  We attempted to place the Process ApproverURL string into the alert body and it grabs the link from system settings verbatim.  It does not pickup the placeholders as they appear to not exist as options when attempting to manually construct the link in the alert body (that was the second thing I tried).  Placeholder options are {Class/Title}, no module name, or class name, no GUID either.  These variables in the process approver url are not populating: class_name={Class/Module/Name}.{Class/Name}&key={Guid}.

       

      Example:

       

      Process Approver Url from System Settings:  https://ldsdprod/ServiceDesk.WebAccess/object/open.rails?class_name={Class/Module/Name}.{Class/Name}&key={Guid}

       

      Alert Email Template:

      This Request has breached its delivery response level.
      Raised by: {Raise User/Title} at
      {Creation Date}
      Title: {Title}
      Response Level: {Response Level/Title}

       

      Link to Request: {$ApplicationSetting.ProcessApprover.WebAccessApproverURL$}

       

      Alert Email Example:

       

      This Request has breached its response level.
      Raised by: Jane Doe at
      7/25/2016 2:13:00 PM [Pacific Daylight Time (GMT-07:00)]
      Title: Adobe Acrobat
      Response Level: Priority 2 Automatic Alert

      Link to Request: https://ldsdprod/ServiceDesk.WebAccess/object/open.rails?class_name={Class/Module/Name}.{Class/Name}&key={Guid}