6 Replies Latest reply on Dec 12, 2016 1:55 PM by Jeremy.Shupick

    Deploy AppX files via LANDesk

    Rookie

      Hi

      We're working on a Windows 10 SOE and have 3 applications we'd like to install that are from the Microsoft Store. I was able to download the source AppX files online using http://woshub.com/how-to-download-appx-installation-file-for-any-windows-store-app/. I'm currently having issues figuring out how to deploy them though. I've found 2 different methods to deploy but so far neither method works. Has anyone got a working method? We're currently running LANDesk 9.6 with Service Pack 2.

      Method 1) Powershell

      The below Powershell command works when run locally but only for the logged in user. If you want to have this command apply for all users they need to be logged off.

       

      Import-Module dism

      Add-AppxProvisionedPackage -Online -PackagePath "\\fakepathname\fakeappname.appxbundle" -DependencyPath "\\fakepathname\FakeVirtualCRunTimes.appx" -SkipLicense

       

      I've checked the execution policy and changed it but still no luck. Also tried what was suggested here Issue: PowerShell Script Fails (Run From Source)  but no luck.

       

      Method 2) Command Line

      The below command lines work but only in an elevated Command Prompt. I've tried using the System and a named Admin account for the deployment but no luck

      c:\windows\system32\DISM.EXE /Online /Add-ProvisionedAppxPackage /PackagePath:"\\fakepathname\VCLibs.appx" /SkipLicense

      c:\windows\system32\DISM.EXE /Online /Add-ProvisionedAppxPackage /PackagePath:"\\fakepathname\fakeappname.appxbundle" /SkipLicense

       

      Does anyone have any ideas/experiencing deploying AppX programs through LANDesk? Is there a better way to do this?