1 2 Previous Next 15 Replies Latest reply on May 16, 2017 3:52 PM by zeke.contreras

    HII issue with Dell Precision 5510

    MikeForg Apprentice

      We are using LDMS 2016 in our company and we are trying to implement Provisioning. We are using mostly Dell. This works fine for most of the models, but I struggeled with the Precision 7510 because of the NVMe. I could resolve the issue thanks to this thread :Windows 7 Image on a NVMe Solid State Drive

       

      But now I am stuck with a Dell Precision 5510. The deployment in itself runs ok ( the wim file gets installed, HII is running and Windows installs drivers) BUT the drivers for USB 3.0 and 3.1 play up - the drivers for the controllers get installed correctly, but those for the hosts are not installed. This is fatal, because the 5510 has only a USB network connector which is not recognized and thus the whole template fails as the machine is not connected to the network.

       

      I already injected the drivers for USB 3.0 and 3.1 in my boot_64.wim, but the drivers don't get copied over.

      usb.png

      As you can see, I assigned the drivers in HII.

       

      Maybe someone has found a solution.

       

      I use UEFI and AHCI mode for this computer.

       

      Thanks for your help !

        • 1. Re: HII issue with Dell Precision 5510
          Kenyon Expert

          I just worked on the drivers for the 5510 a couple of months ago. It was a tricky machine. The device I worked on had two hard drives. One 1TB mechanical drive and one 256MB NVMe drive. The mechanical drive was drive 0 so I had to configure provisioning to deploy the image to drive 1 for the OS to be on the NVMe drive.

           

          As to your issue. I am assuming you are deploying Windows 7? If I remember correctly I had to play around quite a bit with the USB 3.1. Make sure to get the latest drivers from Dell. This is my working driver set files details for the USB 3.1;

          • 2. Re: HII issue with Dell Precision 5510
            MikeForg Apprentice

            You are right, I'm deploying Windows 7x64.

             

            My versions are even more recent than yours, taken directly from Dell :

             

            usb3.png

            I will give it a go with your drivers.

             

            I would be very interested in the solution you used to get the issue with the two hard drives sorted out, I have exactly the same configuration as you.

            • 3. Re: HII issue with Dell Precision 5510
              MikeForg Apprentice

              Still not working. What I notice is that when I look in c:\Windows\LDDriverStore, I can see that the drivers for the USB 3.0 and 3.1 Controllers were downloaded and installed, but not those for the respective hubs.

              • 4. Re: HII issue with Dell Precision 5510
                Kenyon Expert

                I think I remember that we used the driver from the Realtek site instead of the Dell for the dongle as well.

                 

                I had to make a specific provisioning template for the 5510 because of the drive configuration. Drive 1 needs to be specified in each action that references the OS drive. If imagew is used for the image deployment the typical "d:0" switch will need to be changed to "d:1"

                • 6. Re: HII issue with Dell Precision 5510
                  MikeForg Apprentice

                  Thanks for your efforts.

                   

                  I uploaded all your drivers into my driver repository and linked it to the M5510 - it is still the same issue.

                   

                  The host controller doesn't get detected.

                   

                  I will add a step in my template which copies the driver files for the host controller to c:\Windows\LDDriverStore. Maybe Windows can pick it up from there...

                  • 7. Re: HII issue with Dell Precision 5510
                    JoeDrwiega SupportEmployee

                    Have it actually copy the drivers to C:\Windows\Inf and then it will get auto-detected by Plug and Play.

                    • 8. Re: HII issue with Dell Precision 5510
                      Cryan Rookie

                      Mike,

                       

                      I recently dealt with the same issue.

                       

                      I downloaded the Precision 5510 driver pack from Dell's site and added the drivers to my HII Driver database:

                       

                      Precision 5510 Windows 7 Driver Pack - Enterprise Client - Wiki - Client and Mobile Solutions - Dell Community

                       

                       

                      After bringing down the Dell Precision 5510 image, the following five devices within Device Manager will need to have their drivers installed from an SD Card or copied to the PC during the Provisioning process:

                       

                      • 3D Video Controller
                      • PCI Device
                      • Unknown Device (1)
                      • Unknown Device (2)
                      • Intel® USB 3.0 Root Hub

                       

                       

                       

                       

                      In this example I've outlined the process using an SD Card.

                       

                      I copied the below drivers to my SD Card (Note: I copied all the CAB file drivers to the SD card as well):

                       

                       

                      For each of the four unresolved devices listed below, right click the device and select Update Driver Software:

                       

                      • 3D Video Controller
                      • Unknown Device (1)
                      • Unknown Device (2)
                      • Intel® USB 3.0 Root Hub

                       

                      Choose the option to Browse for driver software on your computer.

                       

                        Browse to Precision 5510 directory on the SD Card and the drivers for the four devices shown below will automatically be installed (Note: If prompted to reboot, please do so).

                       

                       

                       

                      3D Video Controller - NVIDIA Quadro M10001

                       

                       

                      Unknown Device (1) - Intel(R) USB 3.1 Hub (dongle port)

                       

                      Unknown Device (2) - Dell Radio Control Device

                       

                      Intel(R) USB 3.0 Root Hub - Intel(R) USB 3.0 Root Hub

                       

                      Installing the PCI Device Driver

                       

                      The Dell Precision 5110 laptop utilizes two separate vendors for their NVM Express Controller (PCI Device).

                       

                        You will first need to determine which vendor is associated with the installed PCI Device through implementing the below steps:

                       

                       

                      Right click the unresolved PCI Device (within Device Manager) and select Properties

                       

                      Below are screenshots to assist with identifying which of the two PCI Devices is installed. Once you have identified the manufacturer of the PCI Device, proceed to follow the installation instruction associated with that vendor.

                       

                       

                      Samsung

                       

                      If the vendor is identified as being Samsung, run  Samsung NVM Express Driver 1.1.exe (located within the “Samsung_NVMExpress_Driver (Official)” directory)

                       

                       

                      If the vendor is identified as being Samsung, run  Samsung NVM Express Driver 1.1.exe (located within the “Samsung_NVMExpress_Driver (Official)” directory)

                       

                       

                       

                      Click Yes to proceed with the reboot

                       

                      Following the reboot, the PCI Device will be resolved to reflect the Samsung NVM Controller as being installed

                       

                       

                       

                       

                      Toshiba

                       

                      If the vendor is identified as being Toshiba, run  Microsoft HotFix 2990941 (located within the “Microsoft HotFix 2990941” directory)

                       

                      Click Yes to proceed with the install

                       

                      Select Restart Now

                       

                      Following the reboot, the PCI Device will be resolved to reflect the Standard NVM Express Controller as being installed

                      • 9. Re: HII issue with Dell Precision 5510
                        MikeForg Apprentice

                        Thanks Joe,

                         

                        as you suggested I copied the drivers for USB 3.0 and 3.1 directly into the c:\Windows\inf folder after the deployment of the wim file.

                         

                        This time Windows picked up correctly the drivers and installed them so that the network connection was available and the template ran through successfully !

                         

                        Many thanks also to Kenyon who invested a lot of time.

                        • 10. Re: HII issue with Dell Precision 5510
                          Rookie

                          We started using the Precision 5510 a while back. I had the USB 3.1 root hub driver problem, which is responsible for the Realtek USB NIC not installing; thus causing provisioning to stop once it booted to Windows. While the answer above that is flagged as "correct" technically fixes the problem,  it caused multiple other computer models in my environment to have a BSOD either during first boot, or during HII in Windows.

                           

                          I wanted to share my solution for anyone else that is struggling with one of the newer models that can only be provisioned with a USB NIC. We are running LDMS 2016.

                           

                          1. Add the Windows 10 Realtek USB 3.0 NIC driver to the WinPE boot image from the location below. You will need to extract the installer contents and grab the drivers from the WIN10 folder.
                            1. Realtek Drivers
                          2. Add a provisioning step to copy the USB 3.1 driver files to the C:\Windows\LDDriverStore directory... NOT C:\Windows\INF
                            1. Use the Download from Preferred Server action to do this.
                            2. Place this action just after image deploy but prior to HII in WinPE.

                           

                          I first tried copying only the USB 3.1 drivers, which did work to some extent. However, once booted to Windows and the NIC appeared, it was using a different MAC than it had used in the PE environment. I'm not sure why this is the case, I'm sure it is something to do with the "built in" device vs the device on the dongle. Honestly, I really don't know, but the fact remains that if you end up with 2 different MACs during provisioning, the job will certainly fail. By putting in the correct manufacturer provided driver for the Realtek NIC in the WinPE image, it uses the same MAC all the way through the provisioning process and it completes with no problems.

                           

                          Copying the USB 3.1 drivers to the LDDriverstore directory also solved the problem of the BSOD on other systems.

                           

                          I hope this makes sense and someone else can make use of this information!

                          2 of 2 people found this helpful
                          • 11. Re: HII issue with Dell Precision 5510
                            MikeForg Apprentice

                            Hi slingblade,

                             

                            thanks for your comment, much appreciated.

                             

                            USB 3 was really driving me crazy recently, but a couple of days I learnt an essential thing which I didn't realize beforehand :

                             

                            There are TWO different sets of USB drivers, one compatible with Intel's chipset 7 - C216, and another one for the chipset 8 - C220/C610. If you have both drivers in your inf folder, Windows will install the later version also on a Intel series 7 chipset which causes a BSOD.

                             

                            So now I assign the USB 3.0 series drivers to my Latitude's E6430, Precision M4700, Optiplex 7010 & 9010, and the other drivers to the more recent models.

                             

                            For USB 3.1, I followed your advice above.

                             

                            I never encountered the issue with the MAC address you relate, maybe it is because I installed the WinPE drivers from Dell.

                             

                            I just did a test with 10 different models, and now everything is working fine ! No more BSOD.

                            • 12. Re: HII issue with Dell Precision 5510
                              jlentine Rookie

                              Is there anyway to only have this done for one model?

                              • 13. Re: HII issue with Dell Precision 5510
                                zeke.contreras Rookie

                                I also had problems imaging Dell's Precision 5510 on Windows 7.  The template would just stop after booting into Windows the first time.  I was not able to find any details of the error in any of the provisioning logs either.  I could see that all drivers were installed and I had an IP address too.

                                I was having problems using a Dell USB-C to Ethernet dongle that we purchased with it.

                                When I imaged this laptop with my Startech USB to Ethernet dongle, it worked just fine.  This was a workaround until I found your solution online.  Thanks for sharing.

                                 

                                After injecting the Realtek Windows 10 driver into WinPE, I was finally able to deploy Windows 7 successfully on this laptop.

                                • 14. Re: HII issue with Dell Precision 5510
                                  gmb019-Bucknell Apprentice

                                  We've switched to TII with Dell's new models this year due to the issues you describe, and have had no issues since doing so, insofar as drivers are concerned...

                                   

                                  https://community.ivanti.com/docs/DOC-40159

                                  1 2 Previous Next