3 Replies Latest reply on Sep 13, 2016 9:38 AM by Casity.chris

    After Running CP 0419 Updates, cannot get CSA certificate

    GJHorn Apprentice

      As far as I know, before the CP 0419 updates were performed, the clients were scanning and patching correctly for the CSA certificates. Now I try to run the Create Management Gateway Client Certificate script, I receive access denied message.

       

      Would anyone know why this occurs now?

        • 1. Re: After Running CP 0419 Updates, cannot get CSA certificate
          Casity.chris SupportEmployee

          I would take a look at the results of running 'test' in brokerconfig.exe on a client machine. Are you able to manually receive a certificate on a client? The \ProgramData\LANDesk\Log\BrokerConfig.log on the client might be helpful in determining why this is happening.

           

          Are you having any trouble pushing out any software or patches to your clients? If so, I would make sure your scheduler account has the needed permissions.

          • 2. Re: After Running CP 0419 Updates, cannot get CSA certificate
            GJHorn Apprentice

            Currently we are not able to manually receive a certificate either. We can push software or patches out with no issue over the corporate network.

             

            Here is the log file information. What is the 406 error or the 401 error? Does this help?

             

            Tue, 13 Sep 2016 10:57:09 PostCertificate() posting cert to host coreserver, proxy

            Tue, 13 Sep 2016 10:57:09 PostCertificate() StartSession returned 0

            Tue, 13 Sep 2016 10:57:09 PostCertificate() request returned 0

            Tue, 13 Sep 2016 10:57:09 PostCertificate() Write returned 0

            Tue, 13 Sep 2016 10:57:09 PostCertificate() Response returned 0, status of 406

            Tue, 13 Sep 2016 10:57:09 PostSoapRequest() Starting with host coreserver, user

            Tue, 13 Sep 2016 10:57:09 PostSoapRequest() StartSession returned 0

            Tue, 13 Sep 2016 10:57:09 PostSoapRequest() Request returned 0

            Tue, 13 Sep 2016 10:57:09 PostSoapRequest() Write returned 0

            Tue, 13 Sep 2016 10:57:09 ReadSoapResponseToFile() StartSession returned 0, and status 401

            Tue, 13 Sep 2016 10:57:09 GetCertificate() Neither post method succeeded

            Tue, 13 Sep 2016 10:57:13 PostCertificate() posting cert to host coreserver, proxy

            Tue, 13 Sep 2016 10:57:13 PostCertificate() StartSession returned 0

            Tue, 13 Sep 2016 10:57:13 PostCertificate() request returned 0

            Tue, 13 Sep 2016 10:57:13 PostCertificate() Write returned 0

            Tue, 13 Sep 2016 10:57:13 PostCertificate() Response returned 0, status of 406

            Tue, 13 Sep 2016 10:57:13 PostSoapRequest() Starting with host coreserver, user

            Tue, 13 Sep 2016 10:57:13 PostSoapRequest() StartSession returned 0

            Tue, 13 Sep 2016 10:57:13 PostSoapRequest() Request returned 0

            Tue, 13 Sep 2016 10:57:13 PostSoapRequest() Write returned 0

            Tue, 13 Sep 2016 10:57:13 ReadSoapResponseToFile() StartSession returned 0, and status 401

            Tue, 13 Sep 2016 10:57:13 GetCertificate() Neither post method succeeded

            • 3. Re: After Running CP 0419 Updates, cannot get CSA certificate
              Casity.chris SupportEmployee

              401 means that the user was unauthorized for that action.

              406 means unacceptable post. 

               

              Please make sure that the core server has the CSA configured properly under Configure>Manage Cloud Services Appliances. Restarting the "LANDesk management gateway" service might help.

               

              You can also validate the CSA configuration using this quick setup guide: Quick Guide - Gateway (Cloud Service Appliance) Configuration

               

              This could also be an IIS issue. I would advise to create a support case and have one of our technicians take a deeper look into this.