1 2 Previous Next 21 Replies Latest reply on Feb 24, 2017 9:39 AM by jabramson

    Task failed on client due to pending reboot

    davidg5700 Specialist

      I have been trying to push an Acrobat task to a computer in a remote location for the past week, and it keeps failing saying that the task has not started due to a pending reboot.  I've checked in inventory and the reboot needed shows as 0.  I've check for PendingFileRenameOperations in the registry, but nothing is set.  I've checked the vulscanreboot key and nothing is set there as well.

       

      I have successfully resent the agent to the machine, but still no joy.  The return code is 16447 in the completed stage with failed status and result "Stopped due to pending reboot".  The computer was last rebooted yesterday at around 11 am per the last start up time in inventory.

       

      Any ideas where the agent is looking that it thinks a reboot is pending?  Any idea how to get this task to install?

       

      Thanks.

       

      LD 2016 SU4

        • 1. Re: Task failed on client due to pending reboot
          Tom.Phillips Apprentice

          We are having the exact same issue on 2016 SU3.

          • 2. Re: Task failed on client due to pending reboot
            dgonzalez Apprentice

            Posted this on another similar post.

            I ran into the same problem after the su4 update, only solution from support was to uninstall the agent and then reinstall it.  Ended up setting up a script to run the uninstall on all the impacted workstations and reinstalling agent through landesk console.

            ----------

            You will have to uninstall using UninstallWinClient.exe /FORCECLEAN (under ldmain directory)  restart the workstation and then then reinstall your agent.

             

            I had this issue on over 80 workstations so I had to make use of scripts to fix it, if it's just a few you can just run it manually.

            1 of 1 people found this helpful
            • 3. Re: Task failed on client due to pending reboot
              wcoffey SupportEmployee

              Thanks for starting a conversation around this issue. A few things you've already reviewed (registry reboot keys), shows to some degree, the device doesn't require a reboot.A few other things you can do is run the following from "run" prompt or admin cmd prompt just navigate to the ldclient dir:

               

              Vulscan /rebootifneeded /showui

               

              This will let you know if vulscan sees the need for a reboot (it won't reboot the device). SDClient checks the reg keys you've identified and also the actions.ini file (client side file under Landesk\Shared Files\CBAroot).

               

              Check for the existence for an entry in the sdclientreconnect section. That section has to be blank. If there's an entry pointing to the execution of a previous client policy file, no future software dist task will execute. A reboot should clear this section as well, if not check the corresponding client policy .stat file (programdata\landesk\policies) and look at the "status" attribute. For a translation of what the status code means review: How to Interpret Client Policy .Stat file Status Codes. Let me know if there are any further questions.

              2 of 2 people found this helpful
              • 4. Re: Task failed on client due to pending reboot
                JenDay Rookie

                Thanks wcoffey, that was helpful for showing that the client does NOT think it needs a reboot. Yet any task I try regardless of distribution method or package type (msi, exe, bat, ps1) fails with "Stopped due to pending reboot" and return code 16447. Seems excessive that I have to rip out the agent and re-install so I hope that LANDesk addresses this soon.

                • 5. Re: Task failed on client due to pending reboot
                  dgonzalez Apprentice

                  I agree JenDay, I wish support had another solution besides reinstalling the agent.

                  • 6. Re: Task failed on client due to pending reboot
                    wcoffey SupportEmployee

                    I unmarked this thread as "answered". An agent reinstall is not required, (it'll work but not entirely necessary). If both reg keys are not present and vulscan /rebootifneeded /showui is not stating you need to reboot, the reboot can also be "required" in the actions.ini file. This file resides on the client (shared files\cbaroot). The important part of the ini file is the entry for SDClientReconnect. If it's present with no entry, no reboot is required, however, if it reflects something like the following, you will need to review the sdclient_task#.log file for the entry it's looking at troubleshoot from there or manually delete the entry:

                     

                    SDCLIENTRECONNECT=C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe /policyfile="C:\ProgramData\LANDesk\Policies\CP.1.RunNow._IcL86OjHEP8lnExq&#47sQkmJEr+5k=.xml" /reconnect

                     

                    The good news is, this issue has been fixed LD2016-SU4_2016-0628. Please review the attach ReadMe (particularly 319045). This patch is publicly available and accessible through Patch and Compliance.

                     

                     

                    https://community.landesk.com/downloads/Readme/Pages/LD2016-SU_2016-0628.html

                     

                     

                    We have also added an option to ignore the pending reboot all together for SWD, this is already an option for Patching. This feature, however, is not public facing but will be introduced when LDMS2016.3 SU2 is released.

                    • 7. Re: Task failed on client due to pending reboot
                      dgonzalez Apprentice

                      It's frustrating to have to deal with stuff like this and resorting to having to reinstall the agent, if only support would of recommended I try something like this at the time instead of redeploying the agents. Also I was on su4 when this occurred currently on 2016.3

                       

                      If I run into another computer with the pending reboot issue I will give this a try.

                       

                      Is there any documentation on the community that mentions to check the actions.ini file for pending reboot when using software distribution?

                       

                      I really appropriated you providing a solution other than reinstalling the agent, appreciate your help.

                      • 8. Re: Task failed on client due to pending reboot
                        wcoffey SupportEmployee

                        I will document "How to troubleshoot Task failed on client due to pending reboot". The solution provided in LD2016-SU4_2016-0628 was partly due to after "rebooting" the device, the SDClientReconnect entry was not being cleared. If your client is also on the LD2016-SU4_2016-0628 or newer build and you continue to run into this behavior please let us know.

                        • 9. Re: Task failed on client due to pending reboot
                          JenDay Rookie

                          Thanks guys, that is some great troubleshooting info, much appreciated.

                           

                          We are on a brand new 2016.3 build (new W2K12R2 with fresh 2016, then upgraded to 2016.3) as we prepare to migrate from 9.6 SP2. Having a variety of problems as I start to test agent upgrades, SWD and patching. Beginning to think I may want to scrap this server, wait for 2016.3 SU2 and start anew from there. I'll persevere for a few more tests before I make that drastic decision.

                          • 10. Re: Task failed on client due to pending reboot
                            JenDay Rookie

                            I took a look at the "actions.ini" file and sure enough there is an entry for the SDClientReconnect. Vulscan doesn't show a reboot needed and I have rebooted the computer a couple times. I have also already done the uninstall forceclean and agent re-install on this machine.

                             

                            Wcoffey - is it your understanding that if we are on 2016.3 that this problem with the actions.ini should NOT be happening?

                             

                            The task shown in:  "SDCLIENTRECONNECT=C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe /policyfile="C:\ProgramData\LANDesk\Policies\CP.1059.RunNow._KRh591i&#47fApdGbNHZxtMpLi3eSQ=.xml" /reconnect" appears to be a policy rather than a task I have tried to deploy. We are using "Policy-Supported Push" for software distribution.  I will explore to find out what this policy is and see if I can determine why it is failing. Additionally, editing this file is restricted (thank you Windows 7) and is resisting being editied. Running the editor as Administrator or as "Another User" and using my DA account produces an error that the file is open by something else.

                            • 11. Re: Task failed on client due to pending reboot
                              mmajeres Apprentice

                              What about scenarios where there is an entry in the SDCLIENTRECONNECT= line but it doesn't point to a specific stat file?  i.e. C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe /policyfile=" " /reconnect

                               

                              Can we safely remove that line in the actions.ini?  Does the identified update address this scenario?

                              • 12. Re: Task failed on client due to pending reboot
                                JenDay Rookie

                                I believe so. We have had to do it several times in our environment and have not found any downside. We have gone so far as to write a powershell script to use per computer or all of them to clear that line. We are on 2016.3 and this is is still a problem. Looking forward to the next service pack or a good fix for this frustrating issue.

                                • 13. Re: Task failed on client due to pending reboot
                                  davidg5700 Specialist

                                  We have had many computers we've had to clear the SDCLIENTRECONNECT line to get pushes to go through.  We also have many tasks that have computers hanging in the task status as active for days and not seeming to have their status change.

                                   

                                  What is this line actually doing?  Does it somehow start a process to update the task status on the core after a reboot?  Does removing this line result in a computer hanging in the tasks active list?

                                   

                                  We are on 2016.3 and still seeing this happen.

                                  • 14. Re: Task failed on client due to pending reboot
                                    MarXtar ITSMMVPGroup

                                    There is a note in 2016.3 SU1 that may be of interest: https://community.ivanti.com/downloads/Readme/Pages/LD2016.3-SU_1.html

                                     

                                    356907 Software distribution may be unable to push a deployment if a reboot is pending

                                    • Added a new setting to the Distribution only panel to ignore pending reboot during an install. Also check and obey the ignore pending reboot flag in sdclient.

                                     

                                    Mark McGinn

                                    MarXtar Ltd/MarXtar Corporation

                                    http://ivantione.marxtar.com

                                    Ivanti One Development Partner

                                     

                                    Try MarXtar State Management for Ivanti to Better Understand and Manage your Assets

                                    1 2 Previous Next