7 Replies Latest reply on Oct 31, 2016 11:10 AM by quinton.greenhagen

    Trouble Deploying LANDesk Agent to Unmanaged Devices

    Rookie

      Hello LANDesk Community,

       

      I have been trying to deploy our latest landesk agent in LDMS 2016 to some unmanaged devices, but am hitting a wall and I am not sure where the issue lies!

      Some initial information about what I have so far:

      1. We have Group Policy set up to allow the LANDesk service account to access the computers from the network, and it is in the BUILTIN\Administrators group
      2. We set up firewall exceptions for the Windows Agent as specified in the LANDesk Firewall Ports Community Documentation. We also have "Allow Inbound remote administration exception" set up to allow unsolicited incoming messages from the core's IP address.
      3. I have File and Printer sharing on
      4. I am able to successfully browse to \\computername\c$

       

      I run an unmanaged device discovery, and add the machine I desire to push the task to to a scheduled task for Agent Deployment. I start the task, and it starts and successfully copies the temp file over to C:\$ldcfg$ on the remote computer

      From there the task stays stalled out on that return code for about an hour, then returns the failed error code 1165 - "The agent setup program started but communication was lost."

      When I browse to C:\Windows\Temp on the remote computer, I see the $LDTmp$ folder, and all the contents look correct - It just seems it is not able to install it. I do not see any log folders in C:\ProgramData - the only log files I see are in C:\Windows\Temp 

       

       

      I see a process for "header application" running and using cpu resources, but it seems constant and I don't see anything else running that seems to be landesk related.

      I am perplexed at this point as to where to go from here to troubleshoot - if anyone has any help they can provide it would be greatly appreciated!!

       

      I can attach more pictures and files if it helps locate the issues - just let me know!

        • 1. Re: Trouble Deploying LANDesk Agent to Unmanaged Devices
          phoffmann SupportEmployee

          So ... in short - please read my response to this thread here:

          - Agent deployment task timeout

           

          The "agent push" is something that is still in the product (as a "just in case"), but it's 20-odd years old tech - and we've got FAR better and easier ways to get agents deployed.

           

          The "agent push" is an RPC call (Remote Procedure Call) that often gets killed off by Firewall settings alone, not to mention it doesn't do peer download & all that stuff, so is quite inefficient from a network point of view. If possible, go for the advanced agent instead - you can hook that into the GPO as well (my response in the thread I've linked has links to the relevant how-to documents), so anything that's connected to your domain will download & install it.

           

          Makes life much easier .

          • 2. Re: Trouble Deploying LANDesk Agent to Unmanaged Devices
            phoffmann SupportEmployee

            To add to this - the "push" mechanic tends to fall victim to any sort of network hiccups - anything that would kill a network connection causes trouble.

             

            Another reason why the advanced agent is much more reliable, as the "mini" agent pulls down the entire installer down locally first - and does so reliably across reboots, network disconnects (because - byte level checkpoint restart), has all of the preferred server / peer download tech, etc. etc... just LOTS better.

            • 3. Re: Trouble Deploying LANDesk Agent to Unmanaged Devices
              Rookie

              Hey phoffmann,

               

              Thanks for the information! I set up an Advance Agent and did a test deployment and it looks like it is deploying fine. I see a "TEMPldtemp.exe *32" process running on the machine, which looks like the agent executable trying to install. It is eating up a lot of CPU and some Memory, but it appears to have also stalled out.

               

              I see the it properly created the folder in "C:\Program Files (x86)\LANDesk", but it doesn't appear to be doing anything past that. It has been running for a little over an hour now with no noticeable changes. I have been reviewing a troubleshooting tips document on the LANDesk Community - I do not see the AdvanceAgent.log in C:\Program Files (x86)\LANDesk\LDClient so the EXE should have downloaded fine. It appears I have an issue that is causing the EXE to not install, but I am not sure what it is!

               

              Would you have any suggestions or ideas on what might be causing this?

              • 4. Re: Trouble Deploying LANDesk Agent to Unmanaged Devices
                phoffmann SupportEmployee

                Errr - your "full agent" is 1 GB in size? That's quite hefty (and I'd argue - a little too big). Are you including AV + AV definitions in it?

                 

                If the agent starts installing, it should start with a (debug)-log of the installer called "wscfg32.log" in "C:\ProgramData\LANDesk\Log\". If the install starts, that should have some activity in it - does it?

                 

                If that log does NOT get created, the advanced agent log itself might have some information (like "download rates" and such) ... can't double-check what that's called as my lab's locked up in doing other stuff, but I can check tomorrow if need be (if memory serves, it'll log to the same location - been a while. Either way, not hard to find it's logs by and large).

                 

                Let's start with that.

                 

                Also - try to build a smaller agent to begin with? 1 GB seems a bit OTT ... exclude AV + AV definitions to begin with? And/or are you including .NET (which should add about 100 MB) ... do smaller steps to begin with, 'til we can understand what's causing you grief here?

                • 5. Re: Trouble Deploying LANDesk Agent to Unmanaged Devices
                  Rookie

                  I have updated my Agent Configuration to not include .NET and have chosen the option to exclude Antivirus setup files - that was a BIG help, as the Agent executable is now only 113MB.

                  I run the standalone executable with status on my testing machine, and it does look like it gets further than before. It looks like it gets all the way to installing LANDESK Antivirus, and from there it stalls out a bit. I do see that there is now a LANDesk folder in ProgramData, and there are indeed logs, including wscfg32, so it is getting further than before! When I open the wscfg32 log, the last line states "Starting process: C:\Program Files (x86)\LANDesk\LDClient\vulscan.exe /installkavClient /removeOldAV /noupdate /nosync /ob:RebootBehavior=UM-LDMS_v2573 /rebootaction=never /showui=false

                  After an hour and a half of sitting on the above screen, it did finish and prompt for a reboot to complete the install!  Thank you for all your help in troubleshooting! Out of curiosity does your agent install take a long time too? an hour and a half seems a little ridiculous just to install the antivirus portion.

                   

                  Once again thank you for your assistance on this! it is greatly appreciated!

                  • 6. Re: Trouble Deploying LANDesk Agent to Unmanaged Devices
                    phoffmann SupportEmployee

                    Yeah - 1.5 hours is definitely odd. As is the 1 GB odd of stuff.

                     

                    Which version of 2016 are you on? I seem to recall that there was an AV-signatures "bloat" bug that was fixed a while back. If you're on 2016.3 you should have it ... so depending on the version of your Core, you may need to consider upgrading to the latest service pack, or (if it's duplicable) opening a ticket with support.

                     

                    There may be more factors here (such as which old AV needs to be removed, etc) -- having nailed this down to "just the AV" is already going to help you out a fair bit here I hope / think. .

                     

                    An agent install shouldn't take very long - 5-10 minutes on a slow device (assuming you don't have to install .NET - THAT can take a LONG time). The AV is a "how long is a piece of string" type question around install duration -- too many factors. For comparison purposes, just build an agent without AV and install it on a box that has .NET already installed (or run with "full UI" on the patch) ... the longest stage by far is the .NET install.

                     

                    Certainly nothing in the range of the 90-odd minutes you've been seeing.

                    • 7. Re: Trouble Deploying LANDesk Agent to Unmanaged Devices
                      Rookie

                      I checked and we are still on version 10.0.0.271 - we do have our test server on the latest update (SU5), and upon making an agent there with the AV files included, it was only 400MB which is still big but definitely a lot more manageable. I am working with the managers of that server to get that update squared away and deployed. The install still takes longer than I would like, but at this point it seems like something I need to work out with them and see if they are also experiencing it.

                       

                      Thanks again for all your help!