4 Replies Latest reply on Apr 21, 2015 1:37 PM by J.D

    Oracle VirtualBox

    J.D Rookie
      Hi Guys,

      I'm having trouble with EM (no config) blocking VirtualBox from running VMs. In short, removing EM client from the laptop resolves this issue, but this isn't an option! ;)

      Stuffed I've tried:
      • I've tried granting VirtualBox executables and install directory with full access via AM. Didn't work.
      • I've granted the user with ability to elevate applications. - Didn't work.
      • Added Oracle certificate as a trusted. - Didn't work.
      I'm fairly sure this is driver or kernel related. Can't see any Access Denied in Procmon. I thought by granting VirtualBox full access in AM would resole the issue.

      Any help is appreciated!

      System Info:
      AppSense 8.3
      Windows 7 x64 OS
      AppSense services & configs are installed and updating correctly
      AV is disabled. Removing EM client resolves issue!

      Thanks
      JD
        • 1. Re: Oracle VirtualBox
          Landon Winburn ITSMMVPGroup
          Do you have data collection turned on? If so turn it off and try again. This will keep PVC.dll from being loaded into the virtual box exes.

          If that doesn't work then try adding the virtual box exes into the Exceptions and ProcessWhiteList values in the registry. This will prevent EMLoader.dll from being loaded in the processes.
          • 2. Re: Oracle VirtualBox
            J.D Rookie
            Hi,

            Thanks for your suggestions.

            Data Collection was disabled and I've added the main (parent) executables to the ProcessWhiteList. This URL (last comment on : http://www.itninja.com/blog/view/camtasia-studio-8) will explain to users on how to add executables to the ProcessWhiteList.
            The updated config was pushed out and for good measure the laptop was rebooted. I could see the entries in the registry. Unfortunately this did not resolve the issue.

            I should point out that if I look at the process running in Process Explorer, I can see the binaries are highlighted in purple, which states they have packed code. It maybe nothing, but most AV see this as potentially virus code.

            I have enable logging to the Event Viewer. I didn't see EM or AM blocking any binaries, but thats because the users has elevated rights and I've added the application binaries and install directory to the Accessible Items list. In AM I've also set the group as Unrestricted.

            Again thanks for you help, any other suggestions are welcome.

            Regards
            JD
            • 3. Re: Oracle VirtualBox
              Landon Winburn ITSMMVPGroup
              https://www.myappsense.com/Knowledgebase/TN-150728.aspx

              This is the tech note on the excludes. If these are set then AppSense isn't touching the application in any way.
              • 4. Re: Oracle VirtualBox
                J.D Rookie
                Thanks Landon,

                Unfortunately I'll need access to www.myappsense.com to read those tech notes. As soon as I get access and try out a few other options, I'll report back. I'm sure there are other people  with similar issues.

                Again, thanks. :D

                Regards
                JD