6 Replies Latest reply on Nov 18, 2016 7:07 AM by MrGadget

    Imaging Windows 10 UEFI Computer Fails HII

    MrGadget Expert

      I'm running LD 9.6 SP3

      There was a article about replacing the Dism folder and the Dism.exe inside the Boot_x64.wim to fix the Hii Failure. I tried this and I still get failure. I put a pause in my template and looked at the Dism log and noticed it is trying to call up files in the X:\windows\system32\dism folder that are not there, however after looking in the old Dism folder in the boot_x64.wim I had replaced, it has the files that are being looked for.

      What is the best way to fix the Hii failure when imaging a Windows 10 UEFI computer?

        • 1. Re: Imaging Windows 10 UEFI Computer Fails HII
          phoffmann SupportEmployee

          Just to confirm - you're talking about this article here - Issue: HII Fails Deploying Windows 10 - , right? Always helps to include links / references so that there's certainty.


          That article has been updated - advising not to use DISM, but rather the ADK. Also, there's a few comments to the article that may be of use (in case you tripped up on something that someone else did)?


          Or are you talking about a situation like this one - Issue: HII action fails with error code 80001803H - which may (also?) affect your setup?


          (Hope this helps).

          1 of 1 people found this helpful
          • 2. Re: Imaging Windows 10 UEFI Computer Fails HII
            MrGadget Expert

            Yes that is the article "Hii Fails Deploying Windows 10".  I got the Dism folder and .exe from downloading the Windows 10 ADK.

            I am not having the problem in the 2nd article.

            This is a cut from the dism log.

            file not found System32\Dism\SiloedPackageProvider.dll

            Getting the collection of Providers fram a local Providerstore type CDISMProviderstore::GetProviderCollection

            The system cannot find the file specified.

            • 3. Re: Imaging Windows 10 UEFI Computer Fails HII
              phoffmann SupportEmployee

              Hrm ... so with LD 2016, they've bumped up the WIM's to be Windows-10 based ... which should really resolve that issue for you.


              There's some reluctance to bump up 9.6 to the newer WIM's as the testing / validation effort around is MASSIVE (WIM "version bumps" tend to be a "full version" thing because of that).


              Would it be worth you setting up a 2016.3 test system to check whether you still have that issue there? (Other benefits include having Powershell and .NET included in the WIM with the 2016 stuff, as well as conditionals & such)?


              I understand if you're not willing to do that - just trying to see if we can get an "easy win" here. The 9.6 WIM's are/were Win-8 based, if I'm not mistaken ... would make for a smoother experience perhaps, as Win 10 is throwing enough spanners by its own self as is.


              Having a test system like that should at least give you a (relatively quick) confirmation whether it's worth looking into with your image deployment?



              Quick addition ... these should help:

              - What's New for Provisioning in LANDESK Management Suite 2016

              - Whats new in OS Provisioning in LANDESK 2016.3


              ... there .

              • 4. Re: Imaging Windows 10 UEFI Computer Fails HII
                MrGadget Expert

                I haven't moved to 2016 because we are still running XP and there were some 2000 and 2003 servers that are being updated as soon as the Server department can get to it.

                Since the Dism log indicated it was looking for files that were in the old Dism folder , I'm going to combine them and try it.

                Update, I tried combining the Dism folder contents in boot_x64.wim with the contents of the dism folder from Windows 10 ADK and HII failed. The errors in the X:\windows\logs\dism folder seam to be the same no matter what I do.

                • 5. Re: Imaging Windows 10 UEFI Computer Fails HII
                  phoffmann SupportEmployee

                  Ouch - I feel your pain .


                  Hmm ... rather than upgrading your production Core - do you happen to have a VM / test-lab? Even if you can just install a 2016.3 test Core, that should be a good proof of concept whether the fixes & changes that I'm hoping will resolve things for you, will actually do so?


                  That'll at least give you some options if need be for your newer devices if that works?

                  • 6. Re: Imaging Windows 10 UEFI Computer Fails HII
                    MrGadget Expert

                    I had a test server set up already with 2016. After setting it up to run a template for my Windows 10 UEFI computer it showed the HII as successful but could never get past CTOS. One problem for another.

                    I have exhausted every possibility on my 9.6 SP3 Production server. I added the Dism folder to boot_x64 and dism.exe from the windows 10 adk.

                    I read a discussion on another site where they said to add the Dism folder to the root of winpe, the dism.exe to the windows\system32 folder and put a line to run wimmountadksetupamd64.exe in the Startnet.cmd file, nothing works I even tried substituting the boot_x64.wim file from 2016 to this one in 9.6 sp3 but it seems other things are needed to work correctly.

                    Since upgrading to 9.6 sP3 and having so many problems besides this I have been fixing I will not upgrade to 2016.3 soon.

                    I'm marking your reply as correct as I assume moving to 2016.3 will fix the Hii problem.

                    I will open another discussion on if anyone is provisioning Windows 10 UEFI with 9.6.