1 2 Previous Next 21 Replies Latest reply on Aug 23, 2017 7:25 AM by Vinny

    LDMS 2016.3 Upgrade Failure

    RobLent Specialist

      I have a test server in my lab which I have previously upgraded from 9.5 SP3 to 2016 with no problems.

       

      I am now trying to upgrade that to the 2016.3 version and all was going well until it got to the workspaces part on which it failed.

       

      Trying to follow this document How to use Configuration Center to set up a Workspaces Database  does not work as when I open the Configuration Centre there are no default instances listed and the Configure a Workspaces Database window does not open.

       

      Anyone else had this issue?

       

      Is there a way I can create a Workspaces database manually?

        • 1. Re: LDMS 2016.3 Upgrade Failure
          phoffmann SupportEmployee

          Yes - you can create a Config-Center instance yourself.

           

          The steps for it can be found here ... *digs* ... BridgeIT Error During LANDESK 2016 Install or LDMS 9.6 SP2 ... there - that should get you unstuck.

           

          Once you've created the instance, you can then follow the "upgrade path" stuff for 2016.3 .

          • 2. Re: LDMS 2016.3 Upgrade Failure
            Markus.Gonser ITSMMVPGroup

            Hi Rob,

             

            could you please add more information:

            - which server?

            - which version of .NET Framework?

            - Screenshot of the error

             

            thx

            Markus

            • 3. Re: LDMS 2016.3 Upgrade Failure
              RobLent Specialist

              Hmmm.  Almost got there.  It was looking good up until I clicked OK after the successful DB connection.

               

              Then I got an Server error '/ConfigurationCenter' Application

               

              Looking at the error it is looking for a path that does not exist.  C:\Program Files (x86)\LANDESK\Service Desk\WebApp\etc.

               

              I don't have Service Desk installed on this server so it will never find that path.

              • 4. Re: LDMS 2016.3 Upgrade Failure
                RobLent Specialist

                Hi Markus,

                 

                Not sure what you mean by which server?  It is a 2012 R2 Server running SQL 2012 and I am upgrading 2016.0 to 2016.3

                 

                .NET 4 but all prerequisites pasted in the installation routine.

                 

                • 5. Re: LDMS 2016.3 Upgrade Failure
                  phoffmann SupportEmployee

                  I suspect the .NET related comment was to make sure that you do NOT have .NET 4.6 installed (as that can cause various issues).

                   

                  This may be useful to confirm - one way or another - How To: Tell What Version of .NET Framework Is Installed

                   

                  .

                  • 6. Re: LDMS 2016.3 Upgrade Failure
                    RobLent Specialist

                    Thanks for that.  So I have 4.5.1 installed of .Net.

                     

                    So currently I am still not able to get the workspaces web app working as I don't have Service desk installed.

                     

                    So now I am stuck with a semi upgraded server in my LAB.

                    • 7. Re: LDMS 2016.3 Upgrade Failure
                      phoffmann SupportEmployee

                      You don't need Service Desk installed.

                       

                      Why do you think you need that? Or do you mean "I need a ServiceDesk database" (which you'd need/get with 2016 SU4 / SU5 / 2016.3) to configure it correctly?

                       

                      That you do ... but that's available as a free download. If you read this page - https://help.landesk.com/docs/help/en_US/LDMS/10.0/Content/Windows/workspace-t-install.htm - that lists download links for importable DB backups (you just need to select your language) that'll do the trick.

                       

                      Is that the part you're stuck on?

                      • 8. Re: LDMS 2016.3 Upgrade Failure
                        RobLent Specialist

                        Well I followed the link you gave me earlier to create the workspaces DB but when I got to the Configuration Center bit I got this error:

                         

                        It is looking for an installation of service desk by the looks of it?  Or am I wrong?

                        • 9. Re: LDMS 2016.3 Upgrade Failure
                          RobLent Specialist

                          That last link you sent looks like the business.  I will give that a go thanks.  :-)

                          • 10. Re: LDMS 2016.3 Upgrade Failure
                            phoffmann SupportEmployee

                            THAT is mighty peculiar.

                             

                            As it so happens, I've upgraded recently a 9.0 to 9.5 => 9.6 => 2016.3 ... so basically, a 2008 R2 based Core with similar setup to you. So the fact that it references "Program Files (x86)" makes sense because you've upgraded from 9.5.

                             

                            I don't get why it would look for a ServiceDesk directory ... that hasn't existed (and still won't exist) as part of a "just LANDesk Management Suite" install / upgrade path. So yeah - it's odd that it's looking for a path that doesn't exist / work. So the error message is "fine" from that perspective. Just confused why it's looking for that (as my 9.0 to 2016.3 Core doesn't have that issue).

                             

                            Once I restored the language specific workspaces DB (and configured users for it), I ...

                            • ... launched Config Center
                            • ... switched the authentication mode from "Token Only" to "Explicit Only" (as per instructions)
                            • ... entered the Workspaces DB credentials,
                            • ... hit the upgrade button and it did its thing.
                            • That was all that there was to it. So - "it does work" ... just no idea why it'd be looking for service-desk'y stuff on your lab core.
                            • ... once the upgrade was complete, I changed the authentication mode back to "Token only".

                             

                            Silly question, but are you sure you don't have (and never had) service desk installed on that box? On a Core that's "only known LANDesk Management Suite" that stuff certainly doesn't appear ...?

                            • 11. Re: LDMS 2016.3 Upgrade Failure
                              RobLent Specialist

                              Well I can't guarantee that someone hasn't installed or tried to install service desk but I don't ever recall this happening.

                               

                              ON another note I thought I would just see if LDMS would run and it does and is also upgraded.  Obviously there is going to be something that is not right here somewhere so I think going back to square one and running the whole process again might be a good option here so I can work out where things went wrong.

                               

                              At least this was in a LAB and not on live.  I will have to take all this into consideration though about the Workspaces bit as we do use Service Desk in live and I believe they have already upgraded to 2016 so I need to find out if we are linking LDMS and Service Desk together now.

                               

                              Thanks for all your help and the pointers.

                              • 12. Re: LDMS 2016.3 Upgrade Failure
                                phoffmann SupportEmployee

                                No problem. It's why people HAVE labs / backups / rollbackpoints / snapshots.

                                 

                                Personally, I've never seen the sort of thing you're seeing in any of my upgrades. I'd suspect it's more related to what is / was on the Core before the upgrade to 2016.3 (since I've upgraded a few 9.5 Cores & never had that).

                                 

                                As an aside - I'd also suggest considering migrating away from 2008 R2 (which I'm guessing you're on at the moment since you're on 9.5?), as 2012 is better in pretty much every regard (ignoring the metro surface nonsense) and isn't in its twilight years as it were (2008 is in extended support at the moment, if memory serves).

                                 

                                And with Server 2016 having been release, I don't expect too much effort / maintenance to go into 2008 at this point.

                                 

                                Good luck & let us know if you get stuck or whatnot.

                                • 13. Re: LDMS 2016.3 Upgrade Failure
                                  RobLent Specialist

                                  Thanks for the help.

                                   

                                  Indeed it is.  I always try to do everything in the LAB first here but not always possible due to reliance on other applications.

                                   

                                  I am moving to 2012 R2 throughout all our servers at the moment.  Not ready for 2016 just yet. 

                                  • 14. Re: LDMS 2016.3 Upgrade Failure
                                    Rookie

                                    Hi RobLent,

                                     

                                    Did you get to fix the workspaces web service Error you were getting? I am currently facing the same issue when trying to upgrade from 2016 to 2016.3, on a server 2012 R2. Wierdly enough going into the configuration center within the core server, i do not have any instances.

                                    1 2 Previous Next