5 Replies Latest reply on Jan 6, 2009 9:27 AM by technobabble

    Windows is not booting after provisioned Lenovo x200

    Johann Apprentice

      Hello everybody,


      just yesterday we received the new Lenovo X200 Notebook. After downloading all the drivers and putting them into the drivers-directory from our Image I tried to install the image on the x200. It all worked fine (BIOS Sata-Settings were set to Compability; MBR was cleaned to erase all possible RnR stuff from Lenovo). The installation went through all steps and copied the image to the notebook. After that it rebooted and should load Windows. Unfortunately it didn't. Even before the loadingscreen the machine stops with a black screen and is doing nothing at all.

      I thought it could be a driver or something, so I tried to boot in Safe Mode. In Safe Mode some drivers begin to load but suddenly the loading stops and only a cursor in the top left corner is blinking.

      Could this be caused by a SATA-Controller driver or something?


      Thanks in advance for your help!



        • 1. Re: Windows is not booting after provisioned Lenovo x200
          phoffmann SupportEmployee

          If your SATA driver is still set to compatibility, this shouldn't be caused by that (I'd imagine).


          Normally, if you boot in safe mode, you should get view as to what drivers get loaded ... I'm surprised that it's "enough" of a driver issue to even take the OS down in safe mode ... but it shouldn't be the storage driver - quite possible to be something else in the driver department...


          Paul Hoffmann

          LANDesK EMEA Technical Lead

          • 2. Re: Windows is not booting after provisioned Lenovo x200
            ahe Expert

            Hello Jo,


            if you start your WinPE, can you see something stored on drive C:\ ?


            If yes, try to change the SATA settings from AHCI to ATA or ATA to AHCI...


            I've had a similar problem on some special DELL Precision workstations.




            • 3. Re: Windows is not booting after provisioned Lenovo x200
              Johann Apprentice



              thanks for your hints. I tried out several things. 


              First I installed a clean Windows XP SP2 on the X200 (without any SATA-Drivers etc.). It worked fine.

              Then I tried to install our "Master-Image" (The one with all the Driver-Folders on C:, no installed Driver and not Syspreped). Even with this it doesn't work. I am really confused about that. On all other systems the Master-Image works fine, because there is no single driver installed except one NIC-Driver. How is this possible?


              @Axel: The Image-Deployment is working fine. When I check C:\ there is everything allright.

              I also tried to change the SATA-Settings, but this didn't work either.




              • 4. Re: Windows is not booting after provisioned Lenovo x200
                Johann Apprentice



                the problem was the same as discussed in the following thread.






                • 5. Re: Windows is not booting after provisioned Lenovo x200
                  technobabble Apprentice

                  There is a known inherent problem with HALs and Plug and Play. First, make sure that your using the correct HAL for the machine. If you are confident tat the correct HAL is being used, try inserting the correct HAL into the image after it has been put down. This can be done using via a batch file or any other means during the provisioning process.


                  Windows XP supports 6 out-of-the-box HALs. Be sure to use the one that is relative to the servicpack that is installed on your image.


                    HAL name                          hal.dll original filename                     HAL name in hal.inf
                  ACPI Multiprocessor PC        halmacpi.dll                                         ACPIAPIC_MP
                  ACPI Uniprocessor PC          halaacpi.dll                                           ACPIAPIC_UP
                  Advanced Configuration and
                  Power Interface (ACPI) PC     halacpi.dll                                             ACPIPIC_UP
                  MPS Multiprocessor PC        halmps.dll                                             MPS_MP
                  MPS Uniprocessor PC          halapic.dll                                             MPS_UP
                  Standard PC                         hal.dll                                                  E_ISA_UP



                  This can be a more common a problem on newer machines with newer CPUs and chipsets. What happens is that the OS is not able to detect the CPU type in time for correct HAL detection to ocurr. This is the reason Microsoft does not support slipstreaming HALs into the OS.


                  There are 2 more files that, like hal.dll, may be renamed copies of HAL-dependent files: ntkrnlpa.exe and ntoskrnl.exe. Two versions exist of these files: halacpi and halaacpi use the “true” ntkrnlpa.exe and ntoskrnl.exe. On halmacpi systems, ntkrnlpa.exe and ntoskrnl.exe are renamed copies of ntkrpamp.exe and ntkrnlmp.exe.