10 Replies Latest reply on Feb 2, 2017 7:02 AM by Ricardo_Almeida

    Error when selecting "Save & close" on the opening of a Change

    Ricardo_Almeida Specialist

      Hi Community,

       

      I have a specific user that, when trying to log a Change on webaccess and clicks "Save and Close", he is prompted with the below error message:

       

      SBT.png

       

      I am unable to replicate the issue. The user has tested with a different web browser and the issue still occurs.

       

      I have replicated the change with the exact same fields and i am able to save the change correctly.

       

      Any ideas on why this error message is appearing?

       

      Any further questions please let me know.

       

      Best Regards,

       

      Ricardo Almeida

        • 1. Re: Error when selecting "Save & close" on the opening of a Change
          Ricardo_Almeida Specialist

          Hi All,

           

          I am able to replicate the issue. This is occurring across all users.

           

          Can this be related to the category that is selected?

           

          Best Regards,

           

          Ricardo Almeida

          • 2. Re: Error when selecting "Save & close" on the opening of a Change
            Peter Weighill Specialist

            If you can replicate in dev, go into ConfigurationCenter and enable all the degugging diagnositics. Then replicate the issue again and then look at the log files on the server to see what the logs say and if you can then narrow down where the issue is.

             

            See Diagnostic logging using Configuration Center

            • 3. Re: Error when selecting "Save & close" on the opening of a Change
              ITSMMVPGroup

              Look at the process to see what happens when you save.  There may be a Window copy rule that copies data or an automatic action that uses value type of similar to copy data from one place to another.  I suspect that if this varies wit hthe user it will be something like their name being copied or group they are in or a string in the category being copied.  If the destination is shorter than the source, you will get this error.

              • 4. Re: Error when selecting "Save & close" on the opening of a Change
                Motaz ITSMMVPGroup

                Hi,

                 

                This could be related to a process configuration where it is trying to get a run time value or copying a value from another window/field. It could also be related to a query or a filter on one of the collections. Try to figure out any changes that have been done lately and try to revert back to find the root cause.

                • 5. Re: Error when selecting "Save & close" on the opening of a Change
                  Ricardo_Almeida Specialist

                  Hi dmshimself,

                   

                  I am able to bypass the error if on the change, i place only "-" on the summary and details and select "Save". I can then go back to the Change once saved and change the information again to the requested, save and close, and it works.

                   

                  It seems the change does not like alot of Characters upon opening,  But if i edit after  creation, i am able to without errors.

                   

                  Any ideas?

                   

                  Thanks!

                   

                  Best Regards,

                   

                  Ricardo Almeida

                  • 6. Re: Error when selecting "Save & close" on the opening of a Change
                    Ricardo_Almeida Specialist

                    dmshimself

                     

                    Hi motaz.alqaissi

                     

                    I am able to bypass the error if on the change, i place only "-" on the summary and details and select "Save". I can then go back to the Change once saved and change the information again to the requested, save and close, and it works.

                     

                    It seems the change does not like alot of Characters upon opening,  But if i edit after  creation, i am able to without errors.

                     

                    Any ideas?

                     

                    Thanks!

                     

                    Best Regards,

                     

                    Ricardo Almeida

                    • 7. Re: Error when selecting "Save & close" on the opening of a Change
                      Ricardo_Almeida Specialist

                      Hello,

                       

                      This is occurring when i copy/paste information to the "Details" field.

                       

                      Only if i copy/paste on that field, thats when i receive an error mesage.

                       

                      Below are the properties for the "Details" field. Hope it helps:

                       

                       

                      jhj.png

                       

                      Best Regards,

                       

                      Ricardo Almeida

                      • 8. Re: Error when selecting "Save & close" on the opening of a Change
                        Ricardo_Almeida Specialist

                        Hi peterweighill

                         

                        I have ran the diagnostics for this error.

                         

                        The error is the following on the description field:

                         

                         

                        DatabaseAccess

                        Statement Executed at 2017-02-02 07:27:10.819

                        UPDATE pm_process_assignment SET pm_title=@0,pm_description=@1,ubr_description_html=@2 WHERE pm_guid=@3

                            Parameters:

                            @0 = [AMPLEXOR Service Desk] Change :1109 is open <p style="position: relative;"><span style="color:#1F497D">May I ask to test the

                        notifications later on today?<o:p></o:p></span></p>

                         

                         

                        <p style="position: relative;"><span style="color:#1F497D"> </span></p>

                         

                         

                        <p style="position: relative;"><span style="color:#1F497D">I am trying to fix this issue

                        with LANDesk support and I believe it is also affecting the other environments.<o:p></o:p></span></p>

                         

                         

                        <p style="position: relative;"><span style="color:#1F497D"> </span></p>

                         

                         

                        <p style="position: relative;"><span style="color:#1F497D">If this specific test could be

                        tested later, that would be great.<o:p></o:p></span></p>

                         

                         

                        <p style="position: relative;"><span style="color:#1F497D"> </span></p>

                         

                         

                        <p style="position: relative;"><span style="color:#1F497D">Best Regards,<o:p></o:p></span></p>

                         

                         

                        <p style="position: relative;"><span style="color:#1F497D"> </span></p>

                         

                         

                        <p style="position: relative;"><span style="color:#1F497D"> </span></p>

                         

                         

                        <table border="0" cellspacing="0" cellpadding="0" style="border-collapse: collapse; position: relative;">

                        <tbody><tr style="mso-yfti-irow:0;mso-yfti-firstrow:yes;mso-yfti-lastrow:yes;

                          height:7.55pt">

                          <td width="149" valign="top" style="width:112.0pt;border:none;border-right:solid #50276E 1.0pt;

                          padding:0in 5.4pt 0in 5.4pt;height:7.55pt">

                          <p style="line-height:105%"><span style="font-size:9.0pt;

                          line-height:105%;color:#1F497D"><!--[if gte vml 1]><v:shapetype id="_x0000_t75"

                           coordsize="21600,21600" o:spt="75" o:preferrelative="t" path="m@4@5l@4@11@9@11@9@5xe"

                           filled="f" stroked="f">

                           <v:stroke joinstyle="miter"/>

                           <v:formulas>

                            <v:f eqn="if lineDrawn pixelLineWidth 0"/>

                            <v:f eqn="sum @0 1 0"/>

                            <v:f eqn="sum 0 0 @1"/>

                            <v:f eqn="prod @2 1 2"/>

                            <v:f eqn="prod @3 21600 pixelWidth"/>

                            <v:f eqn="prod @3 21600 pixelHeight"/>

                            <v:f eqn="sum @0 0 1"/>

                            <v:f eqn="prod @6 1 2"/>

                            <v:f eqn="prod @7 21600 pixelWidth"/>

                            <v:f eqn="sum @8 21600 0"/>

                            <v:f eqn="prod @7 21600 pixelHeight"/>

                            <v:f eqn="sum @10 21600 0"/>

                           </v:formulas>

                           <v:path o:extrusionok="f" gradientshapeok="t" o:connecttype="rect"/>

                           <o:lock v:ext="edit" aspectratio="t"/>

                          </v:shapetype><v:shape id="Picture_x0020_1" o:spid="_x0000_i1025" type="#_x0000_t75"

                           alt="" style='width:120pt;height:54.75pt'>

                           <v:imagedata src="file:///C:\Users\ALmeidaR\AppData\Local\Temp\msohtmlclip1\01\clip_image001.jpg"

                            o:href="cid:image006.jpg@01D2723B.1B08BC80"/>

                          </v:shape><![endif]--><!--[if !vml]--><img width="160" height="73" src="file:///C:\Users\ALmeidaR\AppData\Local\Temp\msohtmlclip1\01\clip_image001.jpg" border="0" v:shapes="Picture_x0020_1"><!--[endif]--></span><span lang="SL" style="font-size:9.0pt;line-height:105%;color:#1F497D;mso-ansi-language:SL;

                          mso-fareast-language:SL"><o:p></o:p></span></p>

                          </td>

                          <td width="455" valign="top" style="width:341.6pt;padding:0in 5.4pt 0in 5.4pt;

                          height:7.55pt">

                          <p style="line-height:105%"><b><span lang="PT" style="font-family:&quot;Franklin Gothic Book&quot;,&quot;sans-serif&quot;;color:#50276E;

                          mso-ansi-language:PT;mso-fareast-language:SL">Ricardo Almeida | Helpdesk

                          Analyst</span></b><b><span lang="SL" style="font-family:&quot;Franklin Gothic Book&quot;,&quot;sans-serif&quot;;

                          color:#50276E;mso-ansi-language:SL;mso-fareast-language:SL"><o:p></o:p></span></b></p>

                          <p style="line-height:105%"><span lang="PT" style="font-size:

                          8.0pt;line-height:105%;color:#1F497D;mso-ansi-language:PT;mso-fareast-language:

                          SL"> </span></p>

                          <p style="line-height:105%"><span lang="PT" style="font-size:

                          8.0pt;line-height:105%;font-family:&quot;Franklin Gothic Book&quot;,&quot;sans-serif&quot;;

                          color:#767171;mso-ansi-language:PT;mso-fareast-language:SL">AMPLEXOR <o:p></o:p></span></p>

                          <p style="line-height:105%"><span lang="PT" style="font-size:

                          8.0pt;line-height:105%;font-family:&quot;Franklin Gothic Book&quot;,&quot;sans-serif&quot;;

                          color:#767171;mso-ansi-language:PT;mso-fareast-language:SL">Quinta da Fonte,

                          Edidício D. Diniz Q55, Piso 0 | 2770-071 Paço de Arcos | Portugal<o:p></o:p></span></p>

                          <p style="line-height:105%"><span style="font-size:8.0pt;

                          line-height:105%;font-family:&quot;Franklin Gothic Book&quot;,&quot;sans-serif&quot;;color:#767171;

                          mso-fareast-language:SL">T: +351 21 936 87 39 M: +351 92 638 65 52   F:

                          +351 21 936 87 04<o:p></o:p></span></p>

                          <p style="line-height:105%"><span style="color:#1F497D"><a href="http://www.amplexor.com/"><span style="font-size:8.0pt;line-height:

                          105%;font-family:&quot;Franklin Gothic Book&quot;,&quot;sans-serif&quot;;color:#73C8DC;

                          mso-fareast-language:SL">www.amplexor.com</span></a></span><span style="font-size:9.0pt;line-height:105%;color:#73C8DC;mso-fareast-language:

                          SL"> </span><span lang="SL" style="font-size:8.0pt;line-height:105%;color:#73C8DC;

                          mso-ansi-language:SL;mso-fareast-language:SL"><o:p></o:p></span></p>

                          </td>

                        </tr>

                        </tbody></table>

                            @1 = Please find the details bellow

                        May I ask to test the

                        notifications later on today?

                         

                        I am trying to fix this issue

                        with LANDesk support and I believe it is also affecting the other environments.

                         

                        If this specific test could be

                        tested later, that would be great.

                         

                        Best Regards,

                         

                         

                         

                         

                        Ricardo Almeida | Helpdesk

                          Analyst

                         

                        AMPLEXOR

                        Quinta da Fonte,

                          Edidício D. Diniz Q55, Piso 0 | 2770-071 Paço de Arcos | Portugal

                        T: +351 21 936 87 39 M: +351 92 638 65 52   F:

                          +351 21 936 87 04

                        1. www.amplexor.com

                         

                         

                         

                         

                         

                         

                            @2 =

                        <p style="margin-top:0pt;margin-bottom:0pt;">Please find the details bellow</p>

                        <p style="margin-top:0pt;margin-bottom:0pt;"><p style="position: relative;"><span style="color:#1F497D">May I ask to test the

                        notifications later on today?<o:p></o:p></span></p>

                         

                         

                        <p style="position: relative;"><span style="color:#1F497D"> </span></p>

                         

                         

                        <p style="position: relative;"><span style="color:#1F497D">I am trying to fix this issue

                        with LANDesk support and I believe it is also affecting the other environments.<o:p></o:p></span></p>

                         

                         

                        <p style="position: relative;"><span style="color:#1F497D"> </span></p>

                         

                         

                        <p style="position: relative;"><span style="color:#1F497D">If this specific test could be

                        tested later, that would be great.<o:p></o:p></span></p>

                         

                         

                        <p style="position: relative;"><span style="color:#1F497D"> </span></p>

                         

                         

                        <p style="position: relative;"><span style="color:#1F497D">Best Regards,<o:p></o:p></span></p>

                         

                         

                        <p style="position: relative;"><span style="color:#1F497D"> </span></p>

                         

                         

                        <p style="position: relative;"><span style="color:#1F497D"> </span></p>

                         

                         

                        <table border="0" cellspacing="0" cellpadding="0" style="border-collapse: collapse; position: relative;">

                        <tbody><tr style="mso-yfti-irow:0;mso-yfti-firstrow:yes;mso-yfti-lastrow:yes;

                          height:7.55pt">

                          <td width="149" valign="top" style="width:112.0pt;border:none;border-right:solid #50276E 1.0pt;

                          padding:0in 5.4pt 0in 5.4pt;height:7.55pt">

                          <p style="line-height:105%"><span style="font-size:9.0pt;

                          line-height:105%;color:#1F497D"><!--[if gte vml 1]><v:shapetype id="_x0000_t75"

                           coordsize="21600,21600" o:spt="75" o:preferrelative="t" path="m@4@5l@4@11@9@11@9@5xe"

                           filled="f" stroked="f">

                           <v:stroke joinstyle="miter"/>

                           <v:formulas>

                            <v:f eqn="if lineDrawn pixelLineWidth 0"/>

                            <v:f eqn="sum @0 1 0"/>

                            <v:f eqn="sum 0 0 @1"/>

                            <v:f eqn="prod @2 1 2"/>

                            <v:f eqn="prod @3 21600 pixelWidth"/>

                            <v:f eqn="prod @3 21600 pixelHeight"/>

                            <v:f eqn="sum @0 0 1"/>

                            <v:f eqn="prod @6 1 2"/>

                            <v:f eqn="prod @7 21600 pixelWidth"/>

                            <v:f eqn="sum @8 21600 0"/>

                            <v:f eqn="prod @7 21600 pixelHeight"/>

                            <v:f eqn="sum @10 21600 0"/>

                           </v:formulas>

                           <v:path o:extrusionok="f" gradientshapeok="t" o:connecttype="rect"/>

                           <o:lock v:ext="edit" aspectratio="t"/>

                          </v:shapetype><v:shape id="Picture_x0020_1" o:spid="_x0000_i1025" type="#_x0000_t75"

                           alt="" style='width:120pt;height:54.75pt'>

                           <v:imagedata src="file:///C:\Users\ALmeidaR\AppData\Local\Temp\msohtmlclip1\01\clip_image001.jpg"

                            o:href="cid:image006.jpg@01D2723B.1B08BC80"/>

                          </v:shape><![endif]--><!--[if !vml]--><img width="160" height="73" src="file:///C:\Users\ALmeidaR\AppData\Local\Temp\msohtmlclip1\01\clip_image001.jpg" border="0" v:shapes="Picture_x0020_1"><!--[endif]--></span><span lang="SL" style="font-size:9.0pt;line-height:105%;color:#1F497D;mso-ansi-language:SL;

                          mso-fareast-language:SL"><o:p></o:p></span></p>

                          </td>

                          <td width="455" valign="top" style="width:341.6pt;padding:0in 5.4pt 0in 5.4pt;

                          height:7.55pt">

                          <p style="line-height:105%"><b><span lang="PT" style="font-family:&quot;Franklin Gothic Book&quot;,&quot;sans-serif&quot;;color:#50276E;

                          mso-ansi-language:PT;mso-fareast-language:SL">Ricardo Almeida | Helpdesk

                          Analyst</span></b><b><span lang="SL" style="font-family:&quot;Franklin Gothic Book&quot;,&quot;sans-serif&quot;;

                          color:#50276E;mso-ansi-language:SL;mso-fareast-language:SL"><o:p></o:p></span></b></p>

                          <p style="line-height:105%"><span lang="PT" style="font-size:

                          8.0pt;line-height:105%;color:#1F497D;mso-ansi-language:PT;mso-fareast-language:

                          SL"> </span></p>

                          <p style="line-height:105%"><span lang="PT" style="font-size:

                          8.0pt;line-height:105%;font-family:&quot;Franklin Gothic Book&quot;,&quot;sans-serif&quot;;

                          color:#767171;mso-ansi-language:PT;mso-fareast-language:SL">AMPLEXOR <o:p></o:p></span></p>

                          <p style="line-height:105%"><span lang="PT" style="font-size:

                          8.0pt;line-height:105%;font-family:&quot;Franklin Gothic Book&quot;,&quot;sans-serif&quot;;

                          color:#767171;mso-ansi-language:PT;mso-fareast-language:SL">Quinta da Fonte,

                          Edidício D. Diniz Q55, Piso 0 | 2770-071 Paço de Arcos | Portugal<o:p></o:p></span></p>

                          <p style="line-height:105%"><span style="font-size:8.0pt;

                          line-height:105%;font-family:&quot;Franklin Gothic Book&quot;,&quot;sans-serif&quot;;color:#767171;

                          mso-fareast-language:SL">T: +351 21 936 87 39 M: +351 92 638 65 52   F:

                          +351 21 936 87 04<o:p></o:p></span></p>

                          <p style="line-height:105%"><span style="color:#1F497D"><a href="http://www.amplexor.com/"><span style="font-size:8.0pt;line-height:

                          105%;font-family:&quot;Franklin Gothic Book&quot;,&quot;sans-serif&quot;;color:#73C8DC;

                          mso-fareast-language:SL">www.amplexor.com</span></a></span><span style="font-size:9.0pt;line-height:105%;color:#73C8DC;mso-fareast-language:

                          SL"> </span><span lang="SL" style="font-size:8.0pt;line-height:105%;color:#73C8DC;

                          mso-ansi-language:SL;mso-fareast-language:SL"><o:p></o:p></span></p>

                          </td>

                        </tr>

                        </tbody></table></p>

                        <p style="margin-top:0pt;margin-bottom:0pt;">

                         

                         

                            @3 = b0b543b3-fe2f-4900-a5c1-e7a1c62de624

                        FAILED

                        String or binary data would be truncated.

                        The statement has been terminated.

                         

                         

                        I am having a few dificulties verifying the exact error. Any sugestions.

                         

                        Many thanks in advance.

                         

                        Best Regards,

                         

                        Ricardo Almeida

                        • 9. Re: Error when selecting "Save & close" on the opening of a Change
                          Peter Weighill Specialist

                          From that, I can see that you are trying to add a lot of text in the Assignment action in your process into the Title field.

                           

                          So, in the process, check all the Assignment actions and see what is going into the Title field.

                           

                           

                          and try changing it to jusat some fixed text or something shorter.

                           

                          • 10. Re: Error when selecting "Save & close" on the opening of a Change
                            Ricardo_Almeida Specialist

                            Thanks peterweighill

                             

                            That was it!

                             

                            On the 1st assignment after selecting "save & close", the assignment title had a placeholder {Description} plus the rest of the title and id of the record. This would also pull all the details of the description onto the title.

                             

                            As the assignment title had limited characters, if the whole title of the assignment exceeded 255 characters (which it would with the description on the create change window), the system would error.

                             

                            I removed the placeholder {Description} from the Assignment window title and was able to bypass the issue.

                             

                            Many thanks for the support.

                             

                            Best Regards,

                             

                            Ricardo Almeida