7 Replies Latest reply on Mar 13, 2017 3:21 PM by ajenkins21

    Dell Lat 5480 Driver issues - related to the new driver inf formats?

    gmb019-Bucknell Apprentice

      Okay, so I'm aware that there is a new inf format that HII really doesn't like, such that with graphics drivers it throws the array out of bounds error, which you can work around by omitting those drivers/folders.  In doing so, I made the assumption that no error = success with other drivers, but is the issue actually more pervasive?

       

      I have the Latitude 5480 drivers in HII; this was one such driver pack that I had to omit the video drivers to avoid the HII array out of bounds error during the rebuilding HII db process, and there were no errors from that process, but when I try to deploy to that model, it gives me the "Setup has restarted" error during sysprep with my dual HII deploy (once in PE, once after sysprep).  I troubleshooted the error to a driver issue, and waiting until after sysprep to inject HII drivers got me beyond that sysprep error, but I then get the stop code error during the HII inject process in windows (as expected).

       

      Thinking I just had to work around that using the Assign option in HII, I started down that path only to find that the autodetect option only finds 3 system devices automatically (despite it actually downloading many drivers during HII - about 100, none of which from the model's driver folder), only one of which is from the model's driver folder.  Am I expecting too much out of HII in terms of being able to point it to that folder and have it identify the correct drivers and assign them, in or out of the Assign option, or is this perhaps an extension of the new inf format issue where some of the other drivers may perhaps not throw the error during HII db rebuild, but still not actually populating the correct information to make them discoverable in the HII db?

       

      HII has worked 100% on all test models up to now, but this is one of the first with a driver pack with the new, evil inf video drivers (at least as far as HII is concerned).  Other models tested so far, successfully, are 7010, 7020, 7040, 3040, 6430, 3050, 790, 5250, M83 (lenovo).  Anyone have success with the new Lat 5480?  Date of driver pack if so?  Ideas?

       

      I was told that sometime this week 2016.3 SU 3 should be released, so hopefully it will cover this issue as well, but I wanted to see if anyone else is seeing this behavior.  Thanks!

       

       

      Update - 3/6/2017

       

      I've addressed the issue by switching to the TII driver management/deployment option offered as a ShareIT resource by Renner Brown.  That's not our ideal route, but it works.  We'll use HII for legacy devices and TII for all newer models.  I may circle back once HII works again, and just move the TII folder within the HII folder to cover both bases once it can accept the newer driver formats and detect/assign properly again for the drivers/models...  Good luck out there...

       

      https://community.ivanti.com/docs/DOC-40159

       

      Update 3/13/2017

       

      2016.3 SU3 resolved the error, but it still isn't assigning drivers properly with HII, so TII it is...  If someone identifies a fix, please post a reply.  Cute how they mark it "Assumed Answered", guess that beats actually checking into things or letting us manage whether our post is answered or not...

       

      Message was edited by: Jey Bailey