5 Replies Latest reply on Mar 14, 2017 1:33 PM by Jon Miller

    Windows LANDesk Antivirus not installing?

    rmoorenv Rookie

      I am writing here to confirm whether this is an issue with Ivanti 2016.3 SU3 (and macav fix) or some odd update best practice that I did not perform. I would prefer to roll back our instance after getting a second opinion, rather than jumping to a conclusion too soon.

       

      What is the problem?

      No LANDesk Antivirus installed after installing a new built self-contained exe. This has been tested on a VM and physical device with Windows 7 SP1 OS. I have run a vulscan and although the AV is not installed, the AV.key is still downloaded.

       

      What troubleshooting?

      • rebooting
      • Rebuilt the agent multiple times
      • Installed a different agent
      • Deployed using an Advanced agent
      • Created an agent config from scratch
      • Ran unisntallclient.exe /forceclean before trying the installation
      • Elevated cmd: vulscan.exe /installav

       

      Log Files

      Mon, 13 Mar 2017 15:01:41 Failed to get the windefender auto protect state

      Mon, 13 Mar 2017 15:01:41 Last status: Done

      Mon, 13 Mar 2017 15:01:41 Installing LANDESK Antivirus client

      Mon, 13 Mar 2017 15:01:44 Exit Code: -2147467259 (0x80004005)

      Mon, 13 Mar 2017 15:01:44 ERROR: Installation failed. C:\Program Files (x86)\LANDesk\LDClient\antivirus\LDAV.exe /install (0x80004005)

      Mon, 13 Mar 2017 15:01:44 Last status: Failed: LANDESK Antivirus msi failed (0x80004005)

      Mon, 13 Mar 2017 15:01:44 AV: Failed to install Kav client.

      Mon, 13 Mar 2017 15:01:44 Reboot is needed.  Will reboot and try again...

      Mon, 13 Mar 2017 15:01:44 In SendRequest: Action = SOAPAction: "http://tempuri.org/SetPatchInstallStatus2"

      Mon, 13 Mar 2017 15:01:44 SendRequest: SOAPAction: "http://tempuri.org/SetPatchInstallStatus2"

      Mon, 13 Mar 2017 15:01:45 Success

      Mon, 13 Mar 2017 15:01:45 Adding installav command to START section in actions.ini: /installAV=InstallNewClient /noselfupdate /coreserver=NVPS-LDCORE:443 "/ob:RebootBehavior=NVPS-LDCORE_v6955" /nosync  /removeOldAV

      Mon, 13 Mar 2017 15:01:45 Actions.ini path: C:\Program Files (x86)\LANDesk\Shared Files\cbaroot\actions.ini

      Mon, 13 Mar 2017 15:01:45 vulscanreboot\ldav_install added

        • 1. Re: Windows LANDesk Antivirus not installing?
          Jon Miller Apprentice

          Couple of things- Is this a fresh Windows image or was there an AV on there prior to you attempting to install LDAV? Was there a previous install of the agent that you are trying to upgrade? Is this happening on multiple machines or just that one? I am currently experiencing an issue with installing LDAV but only because we just rolled out Cisco AMP for Endpoints and it uses the ClamAV engine that runs the quarantine function, and of course, Kaspersky will fail because ClamAV exists.

          • 2. Re: Windows LANDesk Antivirus not installing?
            rmoorenv Rookie

            Couple of things- Is this a fresh Windows image or was there an AV on there prior to you attempting to install LDAV? Was there a previous install of the agent that you are trying to upgrade? Is this happening on multiple machines or just that one? I am currently experiencing an issue with installing LDAV but only because we just rolled out Cisco AMP for Endpoints and it uses the ClamAV engine that runs the quarantine function, and of course, Kaspersky will fail because ClamAV exists.

             

            LANDesk Antivirus was installed before and removed by using the kaspersky removal tool. I needed to use the kaspersky removal tool because the uninstallclient.exe didn't remove the av. This is happening on multiple machines.

             

            Interesting issue you are having...i wish I could help you. Thank you for your questions.

            • 3. Re: Windows LANDesk Antivirus not installing?
              Jon Miller Apprentice

              Double check the install logs for it in appdata- look through the logs that begin with "kl-install-2017-......log" and see if there are any flags in there from finding incompatible software. I would also check that Windows Defender is turned off (I've had pesky issues with it in the past). You might also try running the uninstallclient.exe, rebooting, running the kav uninstaller, reboot then search the OS for any KAV/LANDesk Agent remnants and rename not delete them. Run an inventory report and sift through it looking for any other potential security software that may be interfering. I would really study the logs and pay attention to what is already installed- I only figured out the KAV/Clam issue by manually installing KAV and it then showing me the issue.

               

              Let me know what you find and I'll keep scratching my head. I actually have a developers computer to repair KAV on tomorrow so I'll keep you updated on that as well to see if there are any relations.

              • 4. Re: Windows LANDesk Antivirus not installing?
                rmoorenv Rookie

                I spoke to LANDesk Support, and they recommended :

                 

                Installing AV through an Install/Update Security Components task:

                Open the Agent Settings tool within the LDMS console.

                Select the Create a Task dropdown and select Install/Update Security Components.

                Select desired Task Type, Select LANDESK Antivirus Components to Install, select desired Task Options, and desired reboot options (Controlled through Scan and Repair Settings)

                Select the box "Troubleshoot LANDESK Antivirus installation using interactive mode" to run an Antivirus installation with a full UI available.

                 

                This was successful, so I went back and rebuilt the agent configs, and then I rebuilt the self-contained exes. I noticed the self contained and advance agent sizes changed from 465MB to 503MB.

                Very odd that this didn't occur after the multiple times I did rebuild the agent configs. The good news is that it is working now.

                • 5. Re: Windows LANDesk Antivirus not installing?
                  Jon Miller Apprentice

                  Excellent! Glad it is working now. I figured that path was a mute point because you tried other ways. Anyway, glad it is working.