2 Replies Latest reply on Mar 22, 2017 11:45 AM by tdavenport

    Map Drive Letter Action - Can't Browse, Can't use $ in path

    tdavenport Specialist

      LANDESK 2016 SU5

      Windows 2012 R2

       

      I've noticed some strange behavior in 2016 concerning MAP Drive letter actions in provisioning. I was hoping that SU5 would have fixed the problem but no love......

       

      1. When adding a mapped drive letter action, the browse button does not jump to the specified location. It simply references the core server. See Pic

      • The location, however, is accessible from explorer and a command prompt. But not from the browse button in the dialog box.
      • Even though you can't browse, you can enter a path and it will work in provisioning.
      • There's just no visual confirmation that you are in the right location.

       

      2. The real kicker I have found is that you can no longer have a $ share in your path. This always worked in the past but not in 2016.

      • I tried to trick it by exporting the template into xtp format and editing the path by using a $ symbol in the path but it failed - of course.
      • This is a major annoyance since we use several admin shares as external resources. Not a show stopper but a real hassle.

       

      If anyone has seen this I'd love to hear back from you. If you have a solution, I'd be thrilled.

       

      Thank you!

        • 1. Re: Map Drive Letter Action - Can't Browse, Can't use $ in path
          Motaz ITSMMVPGroup

          I came across this and here is what I did:

           

           

          1- For the UNC path, I just used to open the exact location with the explorer and then copy/paste the path into the provisioning template.
          2- For the $ thingy, I would say add the server where you are trying to access the share into as a preferred server. When you add it as a preferred server you will need to supply credentials to access the location.

           

          I hope this solves your issues.

           

           

          Thanks

          • 2. Re: Map Drive Letter Action - Can't Browse, Can't use $ in path
            tdavenport Specialist

            Motaz,

             

            Thank you for your suggestions.

             

            For #1, that was my solution. The question is, why can't it browse.

            For #2, It is already a preferred server. The question is, why are paths with admin shares ($) no longer valid?

             

            I see this same behavior on two different 2016 servers, so I think its in the code. I'm curious if anyone else is experiencing the same thing.