4 Replies Latest reply on Oct 13, 2008 8:58 AM by MikeCompton

    "The request failed with HTP status 401: Unauthorized"

    Apprentice

       

      When initiating an inventory scan or a security scan from the console we are received an error in the status window "The request failed with HTP status 401: Unauthorized" on any/all devices.  If I run the scan on a number of devices (5+ then my network login account becomes locked).

       

      This has happened since installing SP2.

       

      We have seen this problem before, but it has always disappeared fairly quickly without us getting to the bottom of it.

       

      I know it is almost certainly an internal setting/config as opposed to LANDesk but can anyone shed any light on it?  Its very irritating having to trigger them manually.

       

      Thanks

        • 1. Re: "The request failed with HTP status 401: Unauthorized"
          Employee

          Cause
          There usually is a drive mapped to the core server from the system the problem is happening on.

          Resolution
          Remove the mapped drive.

          • 2. Re: "The request failed with HTP status 401: Unauthorized"
            Employee

            If that is not the problemcheck the following:

             

            1) Open IIS on the core
            2) Go to Web Sites-->Default Web Site-->landesk-->ManagementSuite-->Core-->core.secure
            3) Right Click on core.secure and click on Properties
            4) Click on the Directory Security tab
            5) Under Authentication and access control click on Edit...
            6) Make sure the the box labeled Enable anonymous access is NOT checked and the box labeled integrated Windows authentication IS checked.
            7) Click Ok, Ok and close IIS
            8) Open CMD and run IISRESET

            • 3. Re: "The request failed with HTP status 401: Unauthorized"
              phoffmann SupportEmployee

              1 - Try to re-register ASP.NET via running "aspnet_regiis.exe -i" in the corresponding .NET directory (2.0 if you're on LDMS 8.8) - on the Core.

               

              2 - Check if there is a drive mapped to the Core server (on the PC you're running the remote console and the client) - this can eff-up various bits.

               

              If there is, remove the mapped drive. Redeploy the agent configuration to the box.

               

              3 - Check for this:

              3.A) Open IIS on the core
              3.B) Go to Web Sites-->Default Web Site-->landesk-->ManagementSuite-->Core-->core.secure
              3.C) Right Click on core.secure and click on Properties
              3.D) Click on the Directory Security tab
              3.E) Under Authentication and access control click on Edit...
              3.F) Make sure the the box labeled Enable anonymous access is NOT checked and the box labeled integrated Windows authentication IS checked.
              3.G) Click Ok, Ok and close IIS
              3.H) Open CMD and run IISRESET
              

               

              This is in case that anonymous access should be enabled for SSL (we've seen it happen a few times, no idea what flips that).

               

              ===

               

              See how far this gets you...

               

              Paul Hoffmann

              LANDesk EMEA Technical Lead

               

              • 4. Re: "The request failed with HTP status 401: Unauthorized"
                Apprentice

                Great Thanks!!

                 

                I have a drive mapped permanently to the packages share - i disconnected, then reconnected, problem solved.