7 Replies Latest reply on Apr 23, 2017 12:31 PM by JohnO

    Blank Service Catalog

    JohnO Rookie

      Hi Everyone!

       

      I need your help once more. I am getting a blank page for my own service catalog.

       

      I also don't see the items to publish.

      I don't know what I missed. Any help is always appreciated!

        • 1. Re: Blank Service Catalog
          andreas.lindner Expert

          Hi JohnO,

           

          there is a really simple and good troubleshooting guide, as for there are many things you have to take care of.

          Look here: Troubleshooting problems with publishing the Service Catalogue - Step by Step Guide

           

          Regards

          Andreas

          1 of 1 people found this helpful
          • 2. Re: Blank Service Catalog
            JulianWigman Expert

            A blank page when running the Service Catalogue could be one of a few things.

             

            Have you setup a network share folder to store the Knowledgebase/ServiceCatalog data?  Have you put this share into the "Free text search index path" entries on the Framework and WebAccess Web Applications?

             

            It could also be that you haven't published any catalogue items or you/system hasn't build the Service Catalogue yet.  Check the above share to see if the index files are bigger that 1K etc.

             

            Re your catalogue screenshot above,  we can see you haven't published anything BUT we cant see what items are in the Catalogue Hierarchy as you haven't expanded these folders. Normally you expend the tree to publish items or folder nodes etc.

             

            Regards


            Julian Wigman

            MarXtar Ltd

            1 of 1 people found this helpful
            • 3. Re: Blank Service Catalog
              JohnO Rookie

              Hi!

               

              I setup a local share instead of a network share. Would that affect it? Also, I could not see any items to publish under the PUBLISHING tab of Service Catalog. I noticed that the index files are less than 1K .

              • 4. Re: Blank Service Catalog
                JohnO Rookie

                Hi andreas,

                 

                Thank you for the web link. The Step by Step guide was very helpful!

                • 5. Re: Blank Service Catalog
                  JohnO Rookie

                  Hi Julian,

                   

                  Thank you for your help! The Free Text Search index path are confirmed pointing to the right local folder both for Framework and WebAccess. I published the catalog items and noticed that the index files are just less than 1k(maybe because I only have lass than 10 test items added?)

                   

                  My apologies. Here is a screenshot of the expanded Catalogue Hierarchy.

                   

                  With some extra help I was able to publish an item online as a service. Here is the screenshot.

                   

                  The strange thing is that the items only show up if "Business service" is checked. But if it is not checked, it won't show up on the Self Service side. =( Help!!!!

                  • 6. Re: Blank Service Catalog
                    JulianWigman Expert

                    Hi Johno

                     

                    Service Desk follows the ITIL3 best practice framework and by-design ONLY "Business Services" are published in the Catalogue whereas if not ticked they are assumed "Technical Services" which underpin the business Services, but are not something people would request directly as internal to IT.

                     

                    Ju

                    1 of 1 people found this helpful
                    • 7. Re: Blank Service Catalog
                      JohnO Rookie

                      Hi Julian,

                       

                      You do have a point there. Thanks for the clarification! I do have another separate question(maybe a different topic/discussion somewhere) I am also planning on setting up Asset Management. Is that a separate installation similar to Service Desk? Can it also be included with the existing Service Desk like a shortcut from console?

                       

                      I really appreciate all your help!