1 2 Previous Next 15 Replies Latest reply on Apr 23, 2009 10:01 AM by BrianG

    Landesk Security Scan error

    Rookie

      If I do an inventory scan on the client it connects to the server and completes successfully, but when I do a security scan from the client it says:"

       

      "update settings Failed  Core could not find a file"

      "Apply settings  Failed"

      "Failed"

       

      It says all tasks completed

       

      Does anyone know how to fix this ?

        • 1. Re: Landesk Security Scan error
          swant Apprentice

          I have this same exact issue on one pc w/ a fresh image (known working image)

          • 2. Re: Landesk Security Scan error
            ahe Expert

            Sometimes it is helpful to start again a full inventory scan:

            "C:\Program Files\LANDesk\LDClient\LDISCN32.EXE" /NTT=<Coreserver>:5007 /S=<Coreserver>  /I=HTTP://<Coreserver>/ldlogon/ldappl3.ldz /V /F

             

             

            <Coreserver> means your core server name full qualified.

             

            s. this too: http://community.landesk.com/support/docs/DOC-2209

             

            Regards

            Axel

            • 3. Re: Landesk Security Scan error
              BrianG Rookie

              I'm also having this problem and I've also run a full inventory scan first, but I'm still receiving the error for the Security Scan.

               

              I've also run the LANDesk UninstallWinClient.exe and reinstalled the client, but no change.  This is a new build of WinXP SP3 that did have a registry problem a couple of weeks after rebuild, but everything else seems to be working perfectly fine.

               

              My Security Scan results have always been the following:

               

              Updating settings     Failed.  Core could not find a file

              Applying settings     Done

              Failed

              • 4. Re: Landesk Security Scan error
                Apprentice

                Hi all,

                 

                Hmm something smells funny methinks - what I meant by that is I started having the same problems with scan errors as well and after 14 months of no problems with LD, however this is what we experienced and our fix;

                 

                  -  Freshly imaged PC with known good image

                  -  Advance agent is deployed via GPO so when the machine joined the domain it was automatically installed

                  -  Ran Security Scan via remote - Scan failed with "file not found" and "Core could not process data"

                  -  Ran scan manually on PC  - same results

                  -  Tried several tips found on the Community site - no joy

                  -  Logged support call with LD

                  -  Told to try re-registering .Net 2.1 and restart IIS  -  no joy

                 

                On weekend decided to  try:

                 

                  -  Uninstalled agent using WinUninstall tool

                  -  Deleted device from LD

                  -  Reimaged PC

                  -  Agent installed again automatically

                  -  Agent now works as expected  -  all scan results processed and once again can issue remote scan with no errors.

                 

                Have cup of coffee, ponder navel and wonder at the marvels of modern technology.

                 

                Go figure...?!!?!?

                 

                Perhaps this may help someone else.

                • 5. Re: Landesk Security Scan error
                  BrianG Rookie

                  Unfortunately uninstalling the agent, deleting it from the LANDesk Management Suite, then reinstalling it did not help.  This isn't a computer I can just "re-image" easily unfortunately.

                  • 6. Re: Landesk Security Scan error
                    Apprentice

                    Bugger,

                     

                    you could try this - this is what LD support suggested for our problem, unfortunately this didn't help us but it may help you.

                     

                    1. Reregister ASP.NET from the command prompt
                    For Windows 2003 execute Windows\Microsoft.net\framework\v2.0.50727\aspnet_regiis -i
                    2. Reset IIS from a command prompt execute IISRESET

                     

                    Good luck.

                    • 7. Re: Landesk Security Scan error
                      Employee

                      I think one reason for this is that one of the config files it expects (agentbehavior, custom variable override, &c) is not on the core, or not right on the core, or not delta-syncing right with the agent's own copy.

                      • 8. Re: Landesk Security Scan error
                        ahe Expert

                        Hello,

                         

                        this won't work for LD 8.7 SPx, no .net 2.x or higher supported...

                         

                        .net 2.x is used since LD 8.8

                         

                        Regards

                        Axel

                        • 9. Re: Landesk Security Scan error
                          swant Apprentice

                          So is there a way to tell or fix?

                          • 10. Re: Landesk Security Scan error
                            BrianG Rookie

                            Tried the ASP.Net reset, but no change with that option either.  And we are running LANDesk v8.8.

                             

                            Hi Jouster ,

                             

                            I'm not sure which config files you're referring to (agentbehavior, custom variable override, &c) or where they're supposed to be on the core.  I did find AgentBehavior_1.xml, but I'm not sure how I would need to change it.  Do you have any more detail on those?  How would you fix a problem with the delta-syncing with the agent's own copy?

                             

                            Thanks

                            • 11. Re: Landesk Security Scan error
                              Employee

                              yup -- just read the top of the vulscan.log and it'll mention not being able to get to files. Try to get the files while running as the same account, then see if they make sense.

                              • 12. Re: Landesk Security Scan error
                                BrianG Rookie

                                I checked the \Program Files\LANDesk\LDClient\vulscan.log file on my notebook and it only mentions the defaults.txt folder on the core server.  When I open the file on the core server (\Program Files\LANDesk\ManagementSuite\ldlogon\agentbehaviors\defaults.txt), it's blank.  So unfortunately that didn't help my situation.  Anything else?

                                • 13. Re: Landesk Security Scan error
                                  snix Rookie

                                  Had the same problem trying to download the default.txt and agent behaviors.   If you manually ran the scan, you would see the errors in the GUI.  If you used  a scheduled task, it will return a failed status of either "Unable to get scan  and repair settings from core" and "Unable to get vulnerability definitions from  core".  Support told me to run a vulscan reset.  You can either run this from a  custom script or batch file.

                                   

                                  [MACHINES_WIN]
                                  REMEXEC1=<qt/>C:\Progra~1\LANDesk\LDClient\Vulscan.exe<qt/>  /reset /noproxy, STATUS

                                   

                                  "C:\Program Files\LANDesk\LDClient\vulscan.exe" /reset /noproxy  /AutoCloseTimeout=2

                                   

                                  After you run the reset, run another vulscan.  I like to add the /showui  switch if I'm manually running the reset and scan so that I can see that the  files are actually downloading.  I have had to re-run the reset on machines  multiple times.  Not sure what's up with the actually problem, but this has  fixed the issues of not being able to download the files.  Been tied up in other  projects to go back and work with support on it.  Either way, it'll get you  by.

                                  • 14. Re: Landesk Security Scan error
                                    mrspike SSMMVPGroup

                                    Brian,

                                     

                                    LANDesk has its logs all over the place....

                                     

                                    The main vulscan logs to look at can be found in C:\Documents and Settings\All Users\Application Data\vulScan

                                     

                                    James

                                    1 2 Previous Next