8 Replies Latest reply on Feb 2, 2012 2:37 AM by SKranz

    WinPE script is not running after selecting from PXE Menu

    Rookie

      Hi everyone,

       

      I'm using WinPE to select scripts at the PXE Menu, but nothing happens after seleciting the script, the menu disappears and it sits on Landesk wallpaper with occasionaly hard drive blinking lights.

       

      Before I used to have logs of script running in the ldmain\Scripts folder but not anymore. The inventory server is running. At one time I tried running the script's commands manuallys and it did work. I have tried multiple scripts, including one just to capture hard drive using Landesk imaging client, yet still no luck.

       

      The disk is detected as well as networking equipment. I'm running Landesk 8.8 with the updates.

       

      I've tried a capture and a deploy script different computers. The script is set to Public as well. I've restarted Inventory server, the process is running. Firewall is turned off on the landesk server, IIS has been restarted.

       

      I believe the scripts are not even running as I can't even access the shares it was suppose to create like the I: and H: drives.

        • 1. Re: WinPE script is not running after selecting from PXE Menu
          ahe Expert

          Hello Serkan,

           

          if I understand right, you see the LANDesk boot menu in WinPE, so you don't have this problem:

          Blank PXE boot menu in Windows PE

           

          Did you check the rights to the shares of your user embedded in your osd script?

          How did you start your installation script manually? Did you connect to the shares with your account or with your user embedded in the osd-scriipt?

           

          Could you show us your osd logfile, stored in "coreserver\ldmain\log"?

           

          Regards

          Axel

          • 2. Re: WinPE script is not running after selecting from PXE Menu
            Rookie

            Hi Ahe,

             

            I don't have the Blank PXE Menu problem, I do see the PXE Menu and I can make changes to PXE Menu and when update, I can see the changes, so it's working great.

             

            The user I am running the scripts is the domain administrator, the highest user level.

             

            Manually, at one stage there were logs of the jobs that ran, so I looked at them and typed the script manually into the command line, such as diskpart, ghost command, net commands  etc... it works like a charm.

             

            What do you mean by my account or user embedded in the osd-script? I have used a domain user who has domain admin rights.

             

            I don't have any OSD log files being generated so I can produce a log here. I'm guessing the script is not even running and a problem lies between the PXE server and Landesk. Here is a Application Event log generated everytime I start the Landesk PXE service on PXE Server:

             

            The description for Event ID ( 2 ) in Source ( PxeServices ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: LoadParsingDlls: Failed to load Dll Library for ConfigServer.

            .

             

            Thank you for your help so far :)

            Regards,

            Serkan

            • 3. Re: WinPE script is not running after selecting from PXE Menu
              ahe Expert

              Hi Serkan,

               

              if you create a entry in the OSD boot menu you've to create a OSD-Script before... :-)

               

              In this script you'll find the embedded user account and the crypted password. This user needs rights on the share and be aware that you don't change the password of this user, otherwise you've to create the script again...

               

              (you can check the script if you open it with the menu "Advanced Edit")

               

              I don't meant to see the eventlog entries, normally every OSD start generate a log file on the core in \\coreserver\ldmain\log

               

              Regards

              Axel

              • 4. Re: WinPE script is not running after selecting from PXE Menu
                Rookie

                Hi Ahe,

                 

                Like I said earlier, i was using the Domain Admin account for the script to run. I checked the script (Advanced Edit) and yep, Administrator is the user that's being used.

                 

                Here is the script which I am running:

                 

                VALUES
                Task=7
                ScriptName=WinpeCapture
                ScriptDescription=Capture
                FallBackNIC=
                UseFallBackNIC=FALSE
                ImageUserName=administrator
                ImageDomain=xxxxxx
                ImagePassword=xxxxxx
                ImageToolType=5
                ImageUNC=
                xxxxxx\Images\Image Dumps\Landesk
                ToolUNC=
                xxxxxx\ldmain\osd\imaging\imagew.exe
                ImageToolCmd=RunBatch -1 H:\osd\imaging backall.bat 0 i:\IMAGED~1\Landesk\%Computer - Device Name%, STATUS FACILITY=3510, SYNC
                OWNER
                GUID=14b5c71a-f8f2-4cb4-921f-741577e64c16
                OSDPLUG=TRUE
                DESCRIPTION=Capture
                NAME=WinpeCapture
                TYPE=WinPE
                JOBPARAM
                ABORT_ON_CMD_FAILURE=1
                TASK_COMPLETION_ENABLED=FALSE
                MACHINES
                REMEXEC0=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/bootfile.exe"
                REMEXEC1=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/tlibr16.dll"
                REMEXEC2=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/tlibr32.dll"
                REMEXEC3=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/lddefrag.exe"
                REMEXEC4=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/cicfgmgr.vxd"
                REMEXEC5=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/cindis.vxd"
                REMEXEC6=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/copyfile.exe"
                REMEXEC7=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/winbom.ini"
                REMEXEC8=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/ldvpe0.img"
                REMEXEC9=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /dest="C:\ldvpe1.img" /p="http://%CUSTJOBHOSTIP%/landesk/vboot/ldvpe1.img"
                REMEXEC10=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/tokreplw.exe"
                REMEXEC11=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /dest="%LDMS_CLIENT_DIR%\diskinfo.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/diskinfo.exe"
                REMEXEC12=<qt/>%LDMS_CLIENT_DIR%\diskinfo.exe<qt/> update_winnt_sif <qt/>%LDMS_CLIENT_DIR%\winnt.sif.new<qt/>
                REMEXEC13=<qt/>%LDMS_CLIENT_DIR%\copyfile.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\ldvpe0.img<qt/> <qt/>%LDMS_CLIENT_DIR%\winnt.sif.new<qt/> \winnt.sif
                REMEXEC14=<qt/>%LDMS_CLIENT_DIR%\lddefrag.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\ldvpe0.img<qt/>, STATUS
                REMEXEC15=<qt/>%LDMS_CLIENT_DIR%\bootfile.exe<qt/> %LDMS_CLIENT_DIR%\ldvpe0.img /keep /bootunsafe, ASYNC
                BEGINWINPE=TRUE
                REMPING16=WINPE, TIMEOUT=1800
                REMEXEC17=diskpart /s X:\LDClient\rmvol.txt
                REMEXEC18=drvmap.exe stpauls\administrator 1088886DCD861F16256486F783F I: <qt/>
                xxxxxx<qt/>, STATUS FACILITY=3513
                REMEXEC19=drvmap.exe stpauls\administrator 1088886DCD861F16256486F783F H: <qt/>
                xxxxxx<qt/>, STATUS FACILITY=3513
                REMEXEC20=diskpart /s X:\LDClient\assvol.txt
                REMEXEC21=cmd /c del /f /q C:\ldvpe1.img
                REMEXEC22=RunBatch -1 H:\osd\imaging backall.bat 0 i:\IMAGED~1\Landesk\%Computer - Device Name
                %, STATUS FACILITY=3510, SYNC, TIMEOUT=3600
                REMEXEC23=reboot, timeout=2

                 

                I don't see any problems with the script, notice the xxxxxx, I have hidden key information from prying eyes.

                 

                I have recreated the script and re-installed the PXE server. Still nothing.

                 

                I have also recreated the network share where image gets stored and checked the permissions, it's all ok.

                • 5. Re: WinPE script is not running after selecting from PXE Menu
                  Rookie

                  I still don't have a solution... I am desperate for a solution.

                  • 6. Re: WinPE script is not running after selecting from PXE Menu
                    Rookie

                    In the end re-installed the server and it's working now.

                    • 7. Re: WinPE script is not running after selecting from PXE Menu
                      Apprentice

                      I also am running into this issue however, it is intermittent for me. I can take a new Dell 755, PXE boot it and select my image script but nothing will happen. I then reboot the machine and the second time and try, it runs perfectly. This also seems to be happening more often as time goes on. Unfortunantly we image 10 to 20 systems per day and this is really starting to become an issue.

                       

                      Another thing I run into is that sometimes the image gets laid down, but it will then fail to copy down the sysprep file. This is also intermittent as well. Usually a second try will cause it to work however just as with the previous issue.

                       

                      Any help would be appreciated and I can't really justify rebuilding the core for this issue. There must be a explanation for this.

                       

                      Thanks

                      • 8. Re: WinPE script is not running after selecting from PXE Menu
                        Rookie

                        Does anyone know if this issue has been solved? I'm experiencing similar problems.