9 Replies Latest reply on Feb 28, 2009 9:44 PM by Dthompkins

    LDISCN32.exe no longer works in WinPE

    Apprentice

      We recently upgraded to 8.8 sp2 and have found that LDISCN32.exe no longer works in WinPE.  This is causing us issues since we are using LDISCN32.exe to determine what drivers get downloaded to a PC.  No scans are going in so the script does not copy any drivers which leaves us with imaged PCs that we can't even manually install drivers on.

       

      I've also tried running LDISCN32.exe from the console in WinPE and it doesn't do anything no matter what options I put in, /? doesn't even bring up the parameters box.  Has anyone else come across this?

        • 1. Re: LDISCN32.exe no longer works in WinPE
          Apprentice

          I finally figured it out, in the comments of this document http://community.landesk.com/support/docs/DOC-1177 Paul Hoffman states that in 8.8 the mechanics of ldiscn32 were greatly changed and no longer work in a standalone mode.  I still had my 8.6 server around and was able to copy the needed files to my 8.8 server into an oldscnner directory.  I run these from PE using this command "S:\oldscanner\ldiscn32.exe /NOUI /NO16 /O=S:\ldscan\image.scn /F-".  Where S: is mapped to \\coreserver\ldmain.

          • 2. Re: LDISCN32.exe no longer works in WinPE
            Rookie

            We just upgraded from 8.8 SP1 to SP2 and had the same issue running ldiscan32.exe from WinPE, appears that the latest ldiscn32 requires the MS VC++ 2005 runtime DLL's. As we run ldiscn32 from the ldlogon share on the core server we just dropped the necessary runtime DLL's in to the ldlogon folder (anywhere in the path will do), this resolevd the problem.

             

            The following file already exists in the ldlogon folder

            msvcr80.dll Microsoft® C Runtime Library

             

            We added the following 2 files to the ldlogon folder
            msvcm80.dll - Microsoft® C Runtime Library
            msvcp80.dll - Microsoft® C++ Runtime Library

             

            They have different file dates, but all are version 8.0.50727.762

             

            The files already exist in other folders under C:\Program Files\Landesk, just do a search for them and copy them in to the ldlogon folder if you run ldiscn32 from the ldlogon share (obviously test this on your development server first before rolling out to your production server) or you could inject them anywhere in your search path in WinPE.

             

            Hope this helps someone out.

            • 3. Re: LDISCN32.exe no longer works in WinPE
              Apprentice

              Using technet's listdlls.exe utility, I found the following DLL's were also necessary for me to add to my ldlogon folder for HII in WinPE to work.  For me, ldiscn32.exe broke in WinPE after an upgrade from LDMS 8.7 SP5 to LDMS 8.8 SP2A.  I copied these files from my own working Vista workstation.  Always test first!

               

              Version 1.00.0003.0005  C:\Windows\System32\PMXCOMM.dll

              Version 6.00.6001.18000  C:\Windows\system32\MSCTF.dll

              Version 6.00.6001.18000  C:\Windows\system32\NSI.dll

              Version 6.00.6001.18000  C:\Windows\system32\VERSION.dll

              Version 1.00.0009.0009  C:\Windows\System32\pmxscrll.dll

              • 4. Re: LDISCN32.exe no longer works in WinPE
                Apprentice

                Matt & everyone,

                Can you elaborate on the process you are using to do the ldiscan dring the WinPE?  And you are using this method to decide which drivers to download?

                 

                I am finding that my driver store is quickly becoming very large as more and more different type of machines get purchased.  In my current setup, I am downloading the whole driver store, which takes a long time.  If you are in fact using the inventory to figure which drivers to download, I would be super interested to know how you are do it.

                 

                I will worry about copying the proper dll files once I know the rest of the process.

                 

                Thanks in advance...

                -Miah

                • 6. Re: LDISCN32.exe no longer works in WinPE
                  Apprentice

                  This is the link to the latest version of the HII doc.  Note that this is technically unsupported by LanDesk, also this version no longer uses LDISCN32exe.

                   

                  http://www.droppedpackets.org/osd/hii-winpe.zip/view

                   

                  If you have any questions let me know.

                  • 7. Re: LDISCN32.exe no longer works in WinPE
                    Employee

                    Please note that a new version of the HII document has been published. The revised process no longer uses the inventory scanner to determine hardware type. In addition to the issue of the scanner not running under 8.8 SP2 (which, as you can read above, can be resolved), there were 1 or 2 long-standing issues with using the scanner that made me decide to design it out of the process.

                    • 8. Re: LDISCN32.exe no longer works in WinPE
                      Rookie

                      If you want to be able to use LDISCN32.exe in WinPE you must use version 8.80.2.15. That is the latest version that still works in WinPE. I have included it in this post.

                      • 9. Re: LDISCN32.exe no longer works in WinPE
                        Apprentice

                        Isaac -- the inventory scanner version you are referring to is in SP2 (one of my lab core servers is vanilla with SP2, and has the same version), however this problem still occurs with LDISCN32 unless I add the said dlls.  Perhaps you have SP2a installed on yours, which is why you're not experiencing the issue?