5 Replies Latest reply on Aug 7, 2009 4:28 AM by jan.buelens

    Imaging Lenovo R400

      When we first image an R400 out of the box it will hang at a black screen right  after running the sysprep process.
      At first I  thought it was an updatehal issue but that seems to be ruled out when I  commented out the updatehal lines.  If a hard reset is performed, the post imaging steps will then continue and successfully complete.  Once the post imaging process completes successfully at least once and we reimage again everything runs through.  It is only the initial imaging process that black screens and just hangs.
        • 1. Re: Imaging Lenovo R400
          Leon SupportEmployee

          I'm not sure if this is video controller issue. Maybe you can try another driver.



          • 2. Re: Imaging Lenovo R400

            Rick, Did you find any resolution to this? I am having the exact same issue. I received my first R400 today and after it's done with the image, it reboots, then a black screen.

            • 3. Re: Imaging Lenovo R400

              Have you tried the new HalConfig - the one that came with HII Rev 9.1?

              • 4. Re: Imaging Lenovo R400

                Thanks Jan. I did attempt the Halconfig without success, BUT, I did find a solution.


                I took the XP CD that I used to create my image and installed the OS from the CD. Once installed, I looked at what the processor was using for a driver (Device Manager --> Computer --> Right click on Processor and go to Properties --> Driver --> Driver Details). It was using the following files:






                I then copied those three files to my jump drive. Used Windows PE to dump the image back on the R400. After the dump, I used diskpart to enable it to be readable (No reboot required). I then copied those three files to C:\windows\system32. Rebooted the computer and WaLa. Fixed.

                • 5. Re: Imaging Lenovo R400

                  Was it the new HalConfig that you tried (the one that comes with HII V9.1)? And did you use the /cab=sp3.cab parameter? If the machine is montevino based and you used the old halconfig, or you used the new one but neglected to use the /cab parameter, you will indeed have problems.


                  FYI, other people have told me they successfully used halconfig V2.x with an R400.


                  If there is a valid reason to provide your own HAL files, there is a way to do so: create a hal subfolder in your machine specific driver folder and put the HAL files of your choice in it (see page 37 of the HII document, V9.1).