5 Replies Latest reply on Jan 15, 2009 9:25 AM by Admddi

    Machine shows "OFF" when trying to deploy image




      I've been running into this problem for a week now and just can't seem to find out what the problem is.

      First, let me describe the situation : I have one physical site (site A) where my Core server is, and one physical site (site B, which includes a PXE rep) where I need to deploy an image on a workstation.

      My OSD task is setup to take its image from a server in site B, using the imagew.exe from site B's PXE Rep.


      If I try to deploy that image to a virtual machine in site A (the only difference with deploying directly to site B being the PXE rep), it works perfectly fine and the custom job returns the following log :


      "0003FF57E689","OK",0,0:00:00,14/01/2009 14:44:52,14/01/2009 14:44:52,"WINPE, TIMEOUT=1800"
      "0003FF57E689","OK",5,0:00:03,14/01/2009 14:44:52,14/01/2009 14:44:55,"diskpart /s X:\LDClient\rmvol.txt"
      "0003FF57E689","OK",230227968,0:00:07,14/01/2009 14:44:55,14/01/2009 14:45:02,"drvmap.exe Renaultdesign\Administrator 108FAAAB891CE9A966F52305B1A I: <qt/>\\\images$<qt/>, STATUS FACILITY=3513"
      "0003FF57E689","OK",230227968,0:00:04,14/01/2009 14:45:02,14/01/2009 14:45:06,"drvmap.exe Renaultdesign\Administrator 108FAAAB891CE9A966F52305B1A H: <qt/>\\\ldmain$<qt/>, STATUS FACILITY=3513"
      "0003FF57E689","OK",0,0:00:03,14/01/2009 14:45:06,14/01/2009 14:45:09,"diskpart /s X:\LDClient\wipeDisk0.txt"
      "0003FF57E689","OK",0,0:00:07,14/01/2009 14:45:09,14/01/2009 14:45:16,"cmd /c format /Y /FS:NTFS /Q /V:C-DRIVE c:"
      "0003FF57E689","CANCELED","N/A","0:00:00","14/01/2009 14:48:17","14/01/2009 14:48:17","N/A"
      ; "Job Complete","0 Done","0 Failed","0 Off","1 Unknown"


      (I cancelled the job before it could finish).


      Now, if I try to deploy that image on a workstation or virtual machine in site B, things don't go my way and I'm getting the problem described here : http://community.landesk.com/support/docs/DOC-3473 (Machine shows "OFF") with the custom job returning the following log :


      "(OFF) 0003FFBED8DA","OFF","N/A","0:00:00","15/01/2009 15:28:57","15/01/2009 15:28:57","N/A"
      ; "Job Complete","0 Done","0 Failed","1 Off","0 Unknown"
      When watching the Core server in console mode, the custom job window pops up, hangs for a fews seconds and closes.


      I have checked all steps mentionned in http://community.landesk.com/support/docs/DOC-3473 but the issue remains :



        Start or restart the inventory service   => service was restarted


        Search for the IP address that WinPE has.  If another device has this IP address, delete that inventory record.   => no other device has the IP address of the workstation


        That device may show up twice in the database.  Delete all devices with that MAC Address.    => no other device has the MAC address of the workstation


        Open UDP port 9595 between the Core Server and the Agent workstation.   => this is the only thing I'm not sure how to check 


        Go to Configure | Services | Custom Jobs and set the Discovery to try both UDP and TCP.   => done


        Go to Configure | Services | Custom Jobs and check the box to Disable DNS/WINS Lookup.   => done


        Make sure the Core Server can ping the Agent workstation by name and IP.   => done, works fine 


        Update the NIC driver In the WinPE image.   => driver is up to date, and i can deploy the image to an identical VM in Site A 


        Make sure the Core Server and PXE reps are running the same version of software.   => done


        Verify that the client miniscans are being received by the core server. Enable the Store Scans option in Configure | Service | Inventory | Advanced. Set the value to 1 and restart the Inventory service. Browse to the ldmain\ldscan\Storage directory and verify that .IMS files are being received when the client boots into WinPE.   => done, .IMS files are being received 


      Any ideas or suggestions ? Really feels like I'm banging my head against a wall right now.

        • 1. Re: Machine shows "OFF" when trying to deploy image

          Have you confrmed that your miniscan contains the same IP as your client? You can locate the device's miniscan by looking in All Devices, you should see the MAC address of the client. There is not much data in this record, but the IP address should be there. If you see as the IP address then the miniscan was not successful. You could try manually re-running the miniscan from the client from x:\ldclient. We had one particular model of the Dell Optiplex that refused to work correctly for some reason and we always had to re-run the miniscan manually for the core to receive the client's IP address.

          • 2. Re: Machine shows "OFF" when trying to deploy image

            I've just checked and the IP adress is indeed on the record for the proper MAC address.


            I just tried running the miniscan manually : it works, you're a genius !

            Any way to permanently fix this so that my IT people in brazil don't have to manually scan each time they want to deploy a workstation ?

            • 3. Re: Machine shows "OFF" when trying to deploy image
              Jason SupportEmployee

              Take a look at this document

              WinPE Image fails, shows device as "off" and the IP Address is


              1 of 1 people found this helpful
              • 4. Re: Machine shows "OFF" when trying to deploy image

                Is this happening for all your machines you are trying to image or just a particular model? In our case it was only a specific model Dell Optiplex that had this issue, all others worked as they should. One thing you could do to make it more "user-friendly" is create an OSD script to run the miniscan and then publish it in your PXE menu for your IT staff to run before they launch the actual image script. Just remember that before you exit your miniscan script just re-launch the PXE menu.

                • 5. Re: Machine shows "OFF" when trying to deploy image

                  I will try adding the sleep line to the startnet.cmd file and redeploying my PXE tomorrow, see if it fixes the problem, thanks for the link.


                  And no, it's not limited to one particular machine, but to one physical site which happens to be a few thousand kilometers away with a very crappy network link.