5 Replies Latest reply on Feb 5, 2009 8:39 PM by zman

    AMclient doesn`t pull the policy automaticly

    Rookie

      Hi All,

       

      I haven noticed the amclinet.exe doen`t pull the policy automaticly from core server, but if i run the policy base delivery manualy from client it works fine. I tried reinstall the agent but still same.

      Please check and advice .

       

       

      Regards,

      Muru

        • 1. Re: AMclient doesn`t pull the policy automaticly
          zman Master

          So what version/sp of LANDesk, client OS, etc...?

           

          I would check your inventory of the machine and look at the local scheduled tasks for the machine and make sure it is running amclient. Also check the localsch.log file to make sure it is running. If it is not in either of those places you need to check you client config to make sure you have policies being ran. I think <= 8.7 uses the run key for amclient, so you can also check the registry and see if amclient is in the run key.

          • 2. Re: AMclient doesn`t pull the policy automaticly
            Rookie

            HI Zman,

             

            The OS running on windows 2003 SP 2 and Landesk 8.7 sp 4. I had atcahed the localsch.log file ,also checked in registry the amclient exist in run. However the amclient.exe run running at task manager.

             

            Regards,

            Muru

            • 3. Re: AMclient doesn`t pull the policy automaticly
              zman Master

              So it appears that amclient is running based on what you said about the run key, and the contents of the local scheduler log file.  So you have required policies that are not running.

               

              These policies how are they targeted - machine  or user? I know in 8.7 there was a lot of issues with user based required policies not running with initiated bt the local scheduler.

              Are they required Once?  Maybe they already ran once.

              Do these required policies run when you initiate amclient interactively - run from the shortcut?

              • 4. Re: AMclient doesn`t pull the policy automaticly
                Rookie

                Hi Zman,

                 

                The policy target base on the machines , yes its required once and i had checked the clients is didnt run at all..Even new policy also failed. when i checked at client machines got this error "web service request failed result(result 0x80004005, client error 5''

                • 5. Re: AMclient doesn`t pull the policy automaticly
                  zman Master

                  Make sure the CBA8 is installed LANDesk(R) Management Agent service. If this is a global problem  - majority of the clients experience this issue than it is probably the Core/IIS/Scheduler/ApM Service. If one or two clients than prob a client issue.