7 Replies Latest reply on Jul 15, 2010 6:05 AM by steveperks

    Adobe CS4 --skipProcessCheck not working

    Rookie

      Hi, I am looking for a soulution for this problem. The installation fails because IE is running.

       

      We have packed most versions of CS3 and CS4 production premium.

      When we try this on CS4 Design Premium it says that Internet Explorer is running and has to be closed in the middle of the installation.

       

      Adobe says use the --skipProcessCheck, but it doesn't do the trick.

       

      The scripts are the same and the packages are buildt the same.

      Why isn't it working ?

        • 1. Re: Adobe CS4 --skipProcessCheck not working
          zman Master

          Can you post your command line for the distribution package. Also, Adobe says ignoring these conflicting application may screw up the installation.

           

          One thing you could do is create a prerequisite batch file that closes any offending application using pskill or taskkill.

           

           TASKKILL /S system /F /IM iexplore.exe /T
           or
           tskill iexplore
          

           

          That way anything that would stop the app will be closed.

          • 2. Re: Adobe CS4 --skipProcessCheck not working
            Rookie

            There is a setup.exe file.

             

            Command line parameters are like this.

             

            --mode=silent --deploymentFile="\\xxxx-0002\files$\Adobe\Creative Suite\CS4 Design Premium\deployment\install.xml" --skipProcessCheck=1

             

            I have done all what it says on the adobe pages.

            The problem about stopping IE is that it is a webapplication program installation menu (Landesk management suite) or tomething like that. And I have been told it needs to run in order for the installation to run.

             

            There is always the possibility to use a batch file.

            I want to investigate one more thing first and that will be tomorrow, I am done for today.

            • 3. Re: Adobe CS4 --skipProcessCheck not working
              zman Master

              So have you tried running this outside of LANDesk to see what is causing the issue (Adobe or LANDesk)?

              • 4. Re: Adobe CS4 --skipProcessCheck not working
                Rookie

                I have tried it without using landesk and it is the setup file that is making the mess. I really need to have IE running when installing. I might be doing something wrong ,but I can not see it. The reason for beliving this is the fact that it is asking for serial number even if that is written in the override file. This last attemt was done when IE wasn't active. So it is not using or finding the deploymentfile.

                • 5. Re: Adobe CS4 --skipProcessCheck not working
                  zman Master

                  I would post the xml file (xxx out the sensitive information).  Also:

                   

                  "Note: If you were prompted for a serial number during the --record=1 process it is not required in the application.xml.override file. Although, including a serial number will not cause issues with the Enterprise Deployment Options."

                   

                  Is there a installation log file? In Windows, the log files are located in the [system drive]\Program Files\Common Files\Adobe\Installers folder

                   

                  I would try record again, shorten the path and have the xml file locally, and then try install it outside of LANDesk to see if it works.

                   

                  http://www.adobe.com/support/deployment/cs3_deployment.pdf

                  1 of 1 people found this helpful
                  • 6. Re: Adobe CS4 --skipProcessCheck not working
                    Rookie

                    The file application.xml.override might contain invalid hyphens. """"""" (Hope these are called hypens English is not my favorite flavor)

                    They contain these false hyphens if you copy them from the .pdf that Adobe supplies.

                     

                    OR

                     

                    the file content might be like this: (the license is written in a other .xml file and its not needed here)

                     

                    <?xml version="1.0" encoding="utf-8"?>
                    <Configuration>
                    <Payload>
                    <Data key="Registration">Suppress</Data>
                    <Data key="EULA">-1</Data>
                    <Data key="Updates">Suppress</Data>
                    </Payload>
                    </Configuration>

                    • 7. Re: Adobe CS4 --skipProcessCheck not working
                      Apprentice

                      I was getting this issue, it turned out that the XML files had slight errors in the commands, example --silent should be Silent, skipprocesscheck should be skipProcessCheck, deploymentfile, should be deploymentFile.

                       

                      The major issue is that the encoding must be UTF-8 for the xml's to work. A free application called notepad++ will fix the encoding..

                       

                      I hope this helps

                       

                      Steve