13 Replies Latest reply on Mar 17, 2015 1:46 PM by NeoIsTaken

    Waiting Policy has been made available

    Rookie

      Landesk version: 8.8 SP2a

       

      Client: Windows XP SP2

       

      Connection: External, connecting via mgmt. gateway

       

      Remote Control : working

       

      Inventory/Security Scan: working

       

      Invoker service: running

       

      I have looked at some of the other posts that deal with this issue but none of the responses posted on them have resolved the issue. I have a simple package that i am trying to pull from the client using policy and the deployment portal. The scheduled task lists that the "Policy has been made available" but when i initiate the pull by opening the portal, it goes through the check and reports back "No policies available".

       

      I have checked the policy.*.log files in \ldclient and their is nothing in them that points to any errors.

       

      Any ideas? Thx.

        • 1. Re: Waiting Policy has been made available
          Employee

          Are you using a wireless card?

          • 2. Re: Waiting Policy has been made available
            Rookie

            no. wired.

            • 3. Re: Waiting Policy has been made available
              Employee

              if you uncheck "dynamic bandwidth throtteling" in the delivery method for this job does it work?

              • 4. Re: Waiting Policy has been made available
                Rookie

                Ty,

                 

                That didn't make a difference.

                 

                I had no idea that the status of a task in 'My Tasks' can be different than what gets reported when you click on the task itself. The status of the task itself reports "Policy has been made available" but the status of the same scheduled task in 'My Tasks' reports "Failed, task handler exception".

                 

                I checked the scheduler service and that is set to a local account on the core which is a member of the Administrators group. Also, we have alternate credentials filled in with any other logins the scheduler may need.

                • 5. Re: Waiting Policy has been made available
                  zman Master

                  Seen that when the job is hung and you restart the Scheduler Service. Try This:

                   

                   

                  1. Cancel the task.
                  2. Restart the Scheduler Service
                  3. Restart the task.

                   

                  Is this a LANDesk query or ldap based targeted task? Also check if there are any hung LANDesk.Scheduler.GlobalScheduler.Skeleton or LANDesk.Scheduler.GlobalScheduler task that are hung on the core.

                  • 6. Re: Waiting Policy has been made available
                    Employee

                    As a side note.  Did this task work inside your environment?  It sounds like this is bigger than a Gateway issue.

                    • 7. Re: Waiting Policy has been made available
                      Rookie

                      zman .. will check task manager for the two items that you mentioned tomorrow morning. currently, this is only being applied to a single machine coming in via the GW.

                       

                      Ty .. the pull also fails on an internal machine.

                       

                      On the side, I did successfully push a swd task to an internal client. The question is if that worked, shouldn't scheduler work the same way for the external and internal client that are pulling in the policy? How different does the scheduler behave when doing a pull vs. a push?

                       

                      Could this just possibly be a bug that was introduced with landesk 8.8 SP2a?

                      • 8. Re: Waiting Policy has been made available
                        Rookie

                        We have got exactly the same problem apparently. When we launch the task of the policy it appears for a while in the portal and disapear.


                        Any solution?

                        • 9. Re: Waiting Policy has been made available
                          mrspike SSMMVPGroup

                          This may, or may not be the answer, but whenever I have issues with policies not taking, or items in the portal not showing I run the command (I have a .bat package I use) and it fixes 90% of these issues.

                           

                          The client side data base often gets corrupt, and you won't even know it until you find an instance like you are....

                           

                          You can just copy the text below into a .bat file and run it on the client or get it here: http://www.droppedpackets.org/software-distribution/policy-cleanup.bat/view

                           

                           

                           

                          : This script will delete the clients landesk database, recreate it, validate it and clean up
                          : old xml files/  Any xml files that are still required will repopulate as needed
                          : this is also good at fixing portal and other policy issues

                           

                          cmd /c del "c:\documents and settings\all users\application data\landesk\managementsuite\database" /q
                          del "C:\Documents and Settings\All Users\Application Data\LANDesk\ManagementSuite\landesk\files" /q
                          del "C:\Documents and Settings\All Users\Application Data\vulScan\*.xml" /q
                          del "C:\Program Files\LANDesk\LDClient\sdmcache\landesk\files\*.xml" /q
                          net stop "Landesk Policy Invoker"
                          "c:\program files\landesk\ldclient\clientdbutil.exe" /create
                          "c:\program files\landesk\ldclient\clientdbutil.exe" /validate
                          net start "Landesk Policy Invoker"
                          "c:\program files\landesk\ldclient\policy.sync.exe"
                          "c:\program files\landesk\ldclient\policy.client.invoker.exe"
                          EXIT /B 0

                          • 10. Re: Waiting Policy has been made available
                            Rookie

                                 I tested it but, unfortunatly, it does not work I always have the same problem on both computers. In the task it is says that policy is available but I have the text "Failed, task handler exception".

                                 The package in push method works.

                            • 11. Re: Waiting Policy has been made available
                              Rookie

                              Hi ,

                               

                              Thanks very much for the .bat file.

                              I have scheduled 2 policies one for Adobe Reader 9.0 and other for CCleaner. Of which both were installed successfully thorugh policy based method on one single client machine. but when i rescheduled the CCleaner on the same client machine then it was showing as Made Policy Available to Client .

                               

                              But running Landesk Software Deployment Portal was not showing any download.

                               

                              But due to the batch file all the Policies got reinstalled after running it Rather than only one last policy that was showing status of Made Policy Available to Client .

                               

                              But at client side after running the Landesk Software Deployment Portal all the Software Scheduled through Policy based got downloaded again and Reinstalled.

                               

                              Can you please help me with how can i download only the last policy at client by running some commands only affecting the last downloaded policy.


                              Thanks & Regards,
                              Sandeep

                              sandeepkumar@apwpresident.com

                              • 12. Re: Waiting Policy has been made available
                                irishmn76 SupportEmployee

                                James' link to droppedpackets got moved to the new droppedpackets site.  You can find his stuff here:

                                http://www.droppedpackets.org/technology/scripts/clean-up-policies/

                                • 13. Re: Waiting Policy has been made available
                                  Specialist

                                  Old post, but  since this is at the top of the search engine...

                                  I only needed one line from MrSpikes post

                                   

                                  "c:\program files\landesk\ldclient\policy.sync.exe"

                                   

                                   

                                  Thank you