6 Replies Latest reply on Mar 10, 2009 8:27 AM by jheinrich

    Error on accessing alerts...

    Rookie

      I have LD88SP2A installed.  I am trying to access alerts so that I can configure them but get an error every time the alert window tries to open.  I get a certificate warning, the alerts window starts to open, and then I get the below message.  I think there is a commnicatioins error between alerts and my core, but I don't know where to go in and double check that.  We recently had to move landesk to a new core, due to problems with the installation.  Is there a file/log that I can look into to check to see where the alerts are pointing and if so, how do I change the location of where the alerts are pointing?  thank  you...

       

      Error retrieving Data: (mx.messaging.messages::ErrorMessage)#0
        body = (Object)#1
        clientId = "DirectHTTPChannel0"
        correlationId = "318ABB8E-F609-6853-9E5B-47102FD49AD3"
        destination = ""
        extendedData = (null)
        faultCode = "Server.Error.Request"
        faultDetail = "Error: [IOErrorEvent type="ioError" bubbles=false ca...

        • 1. Re: Error on accessing alerts...
          cknott SupportEmployee

          Julie,  you probably need to put in the core server name under the Web Console box.  On the core, go to Configure | Services and its there on the general tab.

          • 2. Re: Error on accessing alerts...
            Rookie

            I have the core server name listed in the Web Console Settings.  I even tried the IP of the server.  I still get the certificate window indicating that the cert. does not match the one on the server, and then the error.

            • 3. Re: Error on accessing alerts...
              Rookie

              I also went through the steps listed in http://forum.landesk.com/support/message/14769#14769

              I already had the .srv entry in both LDSM and remote.

              • 4. Re: Error on accessing alerts...
                Rookie

                I also looked into ELM and noticed these errors every time I tried to open up an alert set for editing:

                 

                 

                Failed to initialize the AppDomain:/LM/W3SVC/1/Root/remote

                Exception: System.IO.FileLoadException

                Message: Could not load file or assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. Access is denied.

                StackTrace: at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)

                at System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)

                at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)

                at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)

                at System.Activator.CreateInstance(String assemblyName, String typeName, Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, Evidence securityInfo, StackCrawlMark& stackMark)

                at System.Activator.CreateInstance(String assemblyName, String typeName)

                at System.AppDomain.CreateInstance(String assemblyName, String typeName)

                at System.AppDomain.CreateInstance(String assemblyName, String typeName)

                at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironment(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters)

                at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironmentAndReportErrors(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters)

                For more information, see Help and Support Center at

                 

                 

                and then:

                 

                 

                Failed to execute request because the App-Domain could not be created. Error: 0x80070005 Access is denied.

                 

                 

                 





                • 5. Re: Error on accessing alerts...
                  Apprentice

                  Hi Julie,

                   

                  Verify security in folder "C:\Inetpub\wwwroot\remote". There should be the following accounts:

                   

                  Local administrator (Full control)

                  ASP.NET Machine Account (Allow: Read & Execute, List Folders and Read)

                  Local ISS_WPG (Allow: Read & Execute, List Folders and Read)

                  Local Internet Guest Account (Deny: Write)

                  Local Landesk Management Group (Full Control)

                  Local System account (Full Control)

                   

                  Good luck

                  Pedro

                  • 6. Re: Error on accessing alerts...
                    Rookie

                    Our install was missing some IIS components and App Pools which required a reinstall.  After that, there were some access permissions that needed to be reset and we are able to access alerts fine now.