7 Replies Latest reply on Feb 16, 2009 7:36 AM by pierattc

    Process Approver URL

    Apprentice

      When an Incident is Resolved in our system, it runs thru the survey process and a Reminder is sent to the customer with a Process Approver link ( {$ApplicationSetting.ProcessApprover.URL$} ).  This references the Process Approver URL in the System settings in Console.  Everytime this Reminder is generated, we get an Object Reference error.  After speaking with LanDesk Support yesterday, they had us update our Process Approver URL in Console from:

       

      http://<SERVERNAME>/<SERVICEPORTALDIRECTORY>/ProcessApprover.aspx?businessobject={businessobject}&uniqueid={uniqueid}

       

      to

       

      http:// <SERVERNAME>/<SERVICEPORTALDIRECTORY>/processapprover.aspx?businessobject={Class/Module/Name}.{Class/Name}&uniqueid={Guid}

       

      Unfortunately, this new URL keeps reverting back to the old URL.  Does anyone know where we can set this URL globally?

       

       

      Here is the information that was provided by LanDesk Support yesterday:

       

      Problem:
      If when performing an action that would send a ProcessApprover link in a notification (ie. an assignment, reminder, or other action with automatic assignment/reminder after it) you receive the following error either on the screen or in Event Viewer generated by Background Services:

       

      Invalid Path: ClassType IncidentManagement.Incident does not contain Attribute businessobject.

       

      Environment:
      ITBM 7.2.5 when patch 3403 applied.
      ITBM 7.2.6 onwards (unless Problem 3614 has since been addressed).

       

      Resolution:
      The problem is that the ProcessApprover link uses "pseudo-placeholders" ( {businessobject} and {uniqueid} ) to hold the data that will be converted by MailManager to make the link valid and relevant to the incident in question.  There have been changes in how/when placeholders are evaluated and now TPS tries to evaluate the pseudo-placeholders as normal ones hence the error above complaining that "businessobject" doesn't exist as an attribute.

       

      The fix is to edit the ProcessApprover URL to use real placeholders to replace the old ones.  They are most complex but achieve the same result.  Replace {businessobject} with {Class/Module/Name}.{Class/Name} and replace {uniqueid} with {Guid}.

       

      Ie. http://<SERVERNAME>/<SERVICEPORTALDIRECTORY>/processapprover.aspx?businessobject={Class/Module/Name}.{Class/Name}&uniqueid={Guid}

       

      This change is made within the System Settings.  For more information on where to set this see the ProcessApprover manual.

       

       

       

      Thanks,

      Chris

        • 1. Re: Process Approver URL
          Lara Hellman SupportEmployee

          Hi Chris,

           

          >> Unfortunately, this new URL keeps reverting back to the old URL.  Does anyone know where we can set this URL globally?

           

           

          In what way do you mean?  Are new notifications being sent using the old URL - as in do you continue to get the error when saving?

          Has the value for the Process Approver URL in System Settings reverted back too or is that saving properly?

           

          Thanks,

           

          Lara

          • 2. Re: Process Approver URL
            Apprentice

            When I logged out of Console (I was logged in as SA) and then logged back in, the URL had reverted back to the old one in System Settings.  So new Reminders were being created using the old URL.  We have currently turned off the Surveys (set the DoNotSurvey flag to True for all employees) until we can get the new URL setting to stay.

             

            On a side note, you can save the ticket without a problem.  The error doesn't seem to occur until MailManger tries to send out the email.

            • 3. Re: Process Approver URL
              Apprentice

              Is the Process Approver URL from the System Settings stored in a .config file somewhere that could be edited?

              • 4. Re: Process Approver URL
                LegoGuy SupportEmployee

                You should be able to set it under the Settings menu.  Click on Settings, then System.  In that window there is a section for Process Approver.  You can set the URL there.

                • 5. Re: Process Approver URL
                  Apprentice

                  Nephi, the problem has been that the URL has been reverting back to the incorrect URL after I logout of the Console.  I just changed the URL again, saved it and logged out of Console.  This time when I logged back in, the URL was still correct.  I also just tried logging into Console on another pc and it is showing the correct URL.  Just for fun, I just logged out of Console on that 2nd pc and logged back in to Console...it's the incorrect URL again.  It makes no sense.

                   

                  Chris

                  • 6. Re: Process Approver URL
                    Lara Hellman SupportEmployee

                    Hi Chris,

                     

                    The information is stored in the tps_application_setting table in the row with the tps_name URL.  I wonder if the problem you have is some strange Caching issue. Do you have multiple TPS's?

                     

                    Thanks,

                     

                    Lara

                    1 of 1 people found this helpful
                    • 7. Re: Process Approver URL
                      Apprentice

                      Lara, we do have 2 TPS's set up in our system.  We have set up a TPS for our daily use and a TPS for the Windows services.  I have updated the URL in the tps_application_setting table to the correct URL and we'll see if that works.