1 Reply Latest reply on Mar 11, 2016 2:02 AM by sthon

    Missing Patch not showing up in Server

    sthon Apprentice

      I have here some Windows 7 PCs that have missing patches, that even the Server knows about, but they are not downloaded and uploaded to the server:

      eg: "Sicherheitsupdate für Windows 7 (KB3108371)" is missing on my old 32Bit workstation, but the only KB3108371 we have in the available OS Patches list is the one from the 64Bit systems.

       

      The Systems have Windows Update Disabled by GPO, but I distributed the registry changes to allow the LANRev Agent to temporarily activate it to search for patches.

      I have confirmed that the registry setting is indeed active on the system:

      "OverwriteWSUSGPOSettings" is a dword with value 1 (0x00000001)

       

      The Agent has activated

      "Include services Information"

      "Scan Installer receipts"

      "Scan for missing operating system patches"

      "Scan for missing third-party patches"

       

      as well as

       

      "Include in OS Patchmanagement"

      "Include in third-party patch management"

      "Use only Absolute Manage for OS updates"

        • 1. Re: Missing Patch not showing up in Server
          sthon Apprentice

          Some more diagnostic Info:

          I removed the Computer from the GPO - it has now now applied Group Policies. I tried a microsoft Fixit for Windows Update. When checking for Updates i get only an error in die Logs:

           

          2016-03-11 09:27:34.681 [1916:ee8]  <6> - CCobraClientInstalledSoftwareCommand::ScanForMissingPatches: Checking with Microsoft for new software updates.
          2016-03-11 09:30:52.493 [1916:a30]  <6> - CCobraClientSDTask::CheckForPackages: Checking for packages (WasRestart=No, WasLogin=No)...
          2016-03-11 09:30:52.493 [1916:1398] <6> - CSocketStreamTask::ConnectToTarget: Connecting to 192.168.123.211:3971...
          2016-03-11 09:30:52.524 [1916:1398] <6> - CSocketStreamTask::ConnectToTarget: Connected to 192.168.123.211:3971 on 10.49.100.22:49363.
          2016-03-11 09:30:53.445 [1916:1398] <6> - CCobraClientSDTask::GetIsSlowNetwork: Adapter link speed=100 MBit/sec (Threshold=100 MBit/sec), Is slow network=No.
          2016-03-11 09:30:53.492 [1916:1398] <6> - CCobraCommand::SendCommand: Sending Command 'Get SD Packages' ID=4001 (Version=1, ServerType=1) to 192.168.123.211:3971
          2016-03-11 09:30:54.240 [1916:a30]  <6> - CCobraClientSDTask::CheckForPackages: 0 packages returned.
          2016-03-11 09:30:54.240 [1916:a3c]  <6> - CSocketStreamTask::SocketStreamDone: Connection to 192.168.123.211:3971 closed.
          2016-03-11 09:30:54.240 [1916:a30]  <6> - CCobraClientSDTask::DoPostInstallAction: Action: 0x00.
          2016-03-11 09:30:54.240 [1916:a30]  <6> - CCobraClientSDTask::Run: Going sleep for 300 seconds (wake up time=11.03.2016 09:35:54).
          2016-03-11 09:30:54.552 [1916:a24]  <6> - CSocketStreamTask::CSocketStreamTask: Incoming connection from 192.168.123.211:54703 on 10.49.100.22:3970.
          2016-03-11 09:30:54.911 [1916:1254] <6> - CCobraCommand::HandleData: Command 'Send SD Package Check Result' ID=4101 (Version=0, Date=11.03.2016 09:30:54, ServerType=0) received from 192.168.123.211:54703
          2016-03-11 09:30:54.911 [1916:1254] <6> - CCobraClientSDTask::SetPendingPackageList: 0 packages received
          2016-03-11 09:30:55.332 [1916:a3c]  <6> - CSocketStreamTask::SocketStreamDone: Connection to 192.168.123.211:54703 closed.
          2016-03-11 09:35:54.231 [1916:a30]  <6> - CCobraClientSDTask::CheckForPackages: Checking for packages (WasRestart=No, WasLogin=No)...
          2016-03-11 09:35:54.231 [1916:1254] <6> - CSocketStreamTask::ConnectToTarget: Connecting to 192.168.123.211:3971...
          2016-03-11 09:35:54.262 [1916:1254] <6> - CSocketStreamTask::ConnectToTarget: Connected to 192.168.123.211:3971 on 10.49.100.22:49368.
          2016-03-11 09:35:55.089 [1916:1254] <6> - CCobraClientSDTask::GetIsSlowNetwork: Adapter link speed=100 MBit/sec (Threshold=100 MBit/sec), Is slow network=No.
          2016-03-11 09:35:55.151 [1916:1254] <6> - CCobraCommand::SendCommand: Sending Command 'Get SD Packages' ID=4001 (Version=1, ServerType=1) to 192.168.123.211:3971
          2016-03-11 09:35:55.401 [1916:ee8]  <6> - External task check for termination: child process exited with code 1 (0x00000001)
          2016-03-11 09:35:55.401 [1916:78c]  <6> - External task check for termination: child process exited with code 1 (0x00000001)
          2016-03-11 09:35:55.494 [1916:ee8]  <6> - CCobraClientInstalledSoftwareCommand::ScanForMissingPatches: Unknown error occurred while checking for microsoft software updates: Couldn't search for updates..
          2016-03-11 09:35:55.494 [1916:78c]  <6> - CCobraClientInstalledSoftwareCommand::ScanForMissingPatches: Unknown error occurred while checking for microsoft software updates: Couldn't search for updates..