4 Replies Latest reply on Apr 6, 2016 3:15 PM by elysey

    HEAT Ops Console: Failed To Drop Database

    _aehlers55 Rookie

      HEAT Service Management (Premise) 2014.3.1


      In the past, I have been able to use our HEAT Ops Console to refresh our TEST (Staging) and MODL (uat) environments from PROD with no issues. We last refreshed data in December 2015 with no issues. We refreshed our MODL (UAT) environment from PROD with no issues. However, when we try to refresh TEST (Staging) from PROD, I am getting an error message. The message states: 'Failed to drop database HEATSM_TEST due to Cannot drop database "HEATSM_TEST" because it is currently in use.' I spoke with our DBA while attempting this refresh and he advised that the only user accessing this database was us while we were in the Ops Console.


      Is this something that anyone else has experienced before? We haven't made any changes to our TEST environment since the last refresh yet are getting this message. Would restarting the services on our TEST server make any difference with this?



        • 1. Re: HEAT Ops Console: Failed To Drop Database
          elysey Apprentice

          Hi Alex

          Haven't seen that in the past.  Majority of the issues I have found has always been permission issues. 

          Do you have your tenant environments in separate servers or is it all under one server?  If the first option, where is Ops Console installed?

          Have you tried running the refresh with the services (except License) in the test server turned off?

          • 2. Re: HEAT Ops Console: Failed To Drop Database
            _aehlers55 Rookie

            Thanks for the reply, Elyse.


            We have our tennants running on separate servers. The ops console is installed on the Test server.


            We are actually going to give the refresh a try while the services (minus License) are off on the Test Server. I have time scheduled with our other HEAT admin and our DBA who can turn these services off. I will be sure to post an update after we give this a try.

            • 3. Re: HEAT Ops Console: Failed To Drop Database
              _aehlers55 Rookie

              We shut off all services on the Test server, minus license, and tried to push from PROD to TEST. This was unsuccessful. We received the same message.


              However, we called in to HEAT Software and went an alternate route by manually backing up the PROD database and then Overwriting the TEST DB w/ the PROD data. I then did a push from PROD to TEST but next to the Target DB Option, selected Database already restored. This pushed the data thru to TEST successfully and after running our Query for TEST and rebuilding the cache, I was able to log in to a successfully refreshed test environment.

              • 4. Re: HEAT Ops Console: Failed To Drop Database
                elysey Apprentice

                Great to hear it's working again